summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2025-02-25 14:26:51 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2025-02-25 15:07:38 +0000
commitedce693e1b8fabd84651aa6c0888aafbcf238577 (patch)
tree06efa3cb78010357ab0e3a7690656f2c037549e5
parenta792a8e4e47666ae1ecfc8ac496486c6983c7cf3 (diff)
downloadmeta-mingw-walnascar.tar.gz
libiconv: tell autoreconf where to find supplementary macrosyocto-5.2walnascar-5.25.2_M3walnascar
The libiconv build is non-idiomatic, and most importantly doesn't use automake so there's no way to tell aclocal where to find macros. Currently that isn't an issue because our autotools class explicitly specifies any directories it can find containing macros but that will be removed shortly, so tell autoreconf where to find the macros as the upstream Makefile.devel does. Note that we need to pass absolute paths here because libiconv has a nested configure script which fails when autoreconf is used with relative paths. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--recipes-support/libiconv/libiconv_1.15.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-support/libiconv/libiconv_1.15.bb b/recipes-support/libiconv/libiconv_1.15.bb
index b58abb4..2f2b473 100644
--- a/recipes-support/libiconv/libiconv_1.15.bb
+++ b/recipes-support/libiconv/libiconv_1.15.bb
@@ -19,6 +19,9 @@ S = "${WORKDIR}/libiconv-${PV}"
19 19
20inherit autotools pkgconfig gettext 20inherit autotools pkgconfig gettext
21 21
22# Need to use absolute paths as autoreconf will recurse into libchardet
23EXTRA_AUTORECONF += "-I ${S}/m4 -I ${S}/srcm4"
24
22python __anonymous() { 25python __anonymous() {
23 if d.getVar("TARGET_OS") != "linux": 26 if d.getVar("TARGET_OS") != "linux":
24 return 27 return