diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-05-29 22:10:57 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2024-05-30 07:50:32 +0100 |
commit | 8c6eabc762f13d7ae5d1c22a70e306550cb8616d (patch) | |
tree | 12472ede8dc234862132a42978c0924e1f2f942f | |
parent | 4ac078fb567ce03d9181fb0480c7bd17dc5ddb5d (diff) | |
download | meta-mingw-8c6eabc762f13d7ae5d1c22a70e306550cb8616d.tar.gz |
mingw-w64: Upgrade to 12.0.0 release
Drop GCC-14 related backport, its not needed anymore
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r-- | recipes-devtools/mingw-w64/files/0001-crt-Fix-a-typo-in-the-ucrt-__imp_vfscanf-assignment.patch | 30 | ||||
-rw-r--r-- | recipes-devtools/mingw-w64/mingw-w64.inc | 3 | ||||
-rw-r--r-- | recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_12.0.0.bb (renamed from recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_9.0.0.bb) | 0 | ||||
-rw-r--r-- | recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_12.0.0.bb (renamed from recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_9.0.0.bb) | 2 | ||||
-rw-r--r-- | recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_12.0.0.bb (renamed from recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_9.0.0.bb) | 0 |
5 files changed, 2 insertions, 33 deletions
diff --git a/recipes-devtools/mingw-w64/files/0001-crt-Fix-a-typo-in-the-ucrt-__imp_vfscanf-assignment.patch b/recipes-devtools/mingw-w64/files/0001-crt-Fix-a-typo-in-the-ucrt-__imp_vfscanf-assignment.patch deleted file mode 100644 index bc41482..0000000 --- a/recipes-devtools/mingw-w64/files/0001-crt-Fix-a-typo-in-the-ucrt-__imp_vfscanf-assignment.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | From b0dcc496228373417e4f6134beb2f13ca3ed807e Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Martin=20Storsj=C3=B6?= <martin@martin.st> | ||
3 | Date: Thu, 5 Aug 2021 11:08:39 +0300 | ||
4 | Subject: [PATCH] crt: Fix a typo in the ucrt __imp_vfscanf assignment | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | The wrong function was assigned; this was a bug present since | ||
10 | 0dd9563a3ad71ad75cab1699ba5cfef2dd0bf9d8 (April 2021). | ||
11 | |||
12 | Upstream-Status: Backport [https://sourceforge.net/p/mingw-w64/mingw-w64/ci/b0dcc496228373417e4f6134beb2f13ca3ed807e] | ||
13 | Signed-off-by: Martin Storsjö <martin@martin.st> | ||
14 | --- | ||
15 | mingw-w64-crt/stdio/ucrt_vfscanf.c | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/mingw-w64-crt/stdio/ucrt_vfscanf.c b/mingw-w64-crt/stdio/ucrt_vfscanf.c | ||
19 | index fe44cdf71..8d1a76a8b 100644 | ||
20 | --- a/mingw-w64-crt/stdio/ucrt_vfscanf.c | ||
21 | +++ b/mingw-w64-crt/stdio/ucrt_vfscanf.c | ||
22 | @@ -11,4 +11,4 @@ | ||
23 | int __cdecl vfscanf (FILE *__stream, const char *__format, __builtin_va_list __local_argv) { | ||
24 | return __stdio_common_vfscanf(0, __stream, __format, NULL, __local_argv); | ||
25 | } | ||
26 | -int __cdecl (*__MINGW_IMP_SYMBOL(vfscanf))(FILE *, const char *, __builtin_va_list) = vsscanf; | ||
27 | +int __cdecl (*__MINGW_IMP_SYMBOL(vfscanf))(FILE *, const char *, __builtin_va_list) = vfscanf; | ||
28 | -- | ||
29 | 2.43.0 | ||
30 | |||
diff --git a/recipes-devtools/mingw-w64/mingw-w64.inc b/recipes-devtools/mingw-w64/mingw-w64.inc index ce5d0db..97315f4 100644 --- a/recipes-devtools/mingw-w64/mingw-w64.inc +++ b/recipes-devtools/mingw-w64/mingw-w64.inc | |||
@@ -4,8 +4,7 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/mingw-w64-v${PV}/COPYING;md5=bb936f0e04d8f | |||
4 | COMPATIBLE_HOST = ".*-mingw.*" | 4 | COMPATIBLE_HOST = ".*-mingw.*" |
5 | 5 | ||
6 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2" | 6 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2" |
7 | 7 | SRC_URI[sha256sum] = "cc41898aac4b6e8dd5cffd7331b9d9515b912df4420a3a612b5ea2955bbeed2f" | |
8 | SRC_URI[sha256sum] = "1929b94b402f5ff4d7d37a9fe88daa9cc55515a6134805c104d1794ae22a4181" | ||
9 | 8 | ||
10 | UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/mingw-w64/files/mingw-w64/mingw-w64-release/" | 9 | UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/mingw-w64/files/mingw-w64/mingw-w64-release/" |
11 | UPSTREAM_CHECK_REGEX = "mingw-w64-v(?P<pver>(\d+[\.\-_]*)+)\.tar" | 10 | UPSTREAM_CHECK_REGEX = "mingw-w64-v(?P<pver>(\d+[\.\-_]*)+)\.tar" |
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_9.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_12.0.0.bb index 68e77fa..68e77fa 100644 --- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_9.0.0.bb +++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_12.0.0.bb | |||
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_9.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_12.0.0.bb index 1aa470e..6d01d35 100644 --- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_9.0.0.bb +++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_12.0.0.bb | |||
@@ -2,7 +2,7 @@ DESCRIPTION = "Runtime libraries from MinGW-w64 project" | |||
2 | 2 | ||
3 | require mingw-w64.inc | 3 | require mingw-w64.inc |
4 | 4 | ||
5 | SRC_URI += "file://0001-crt-Fix-a-typo-in-the-ucrt-__imp_vfscanf-assignment.patch;striplevel=2" | 5 | #SRC_URI += "file://0001-crt-Fix-a-typo-in-the-ucrt-__imp_vfscanf-assignment.patch;striplevel=2" |
6 | 6 | ||
7 | S = "${WORKDIR}/mingw-w64-v${PV}/mingw-w64-crt" | 7 | S = "${WORKDIR}/mingw-w64-v${PV}/mingw-w64-crt" |
8 | B = "${WORKDIR}/build-${TARGET_SYS}" | 8 | B = "${WORKDIR}/build-${TARGET_SYS}" |
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_9.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_12.0.0.bb index fb7e54e..fb7e54e 100644 --- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_9.0.0.bb +++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_12.0.0.bb | |||