summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2024-09-19 13:29:47 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-09-19 13:32:04 +0100
commitdb1f53f73e95499a5f0b0edc45dd9cc9718d3c8a (patch)
treeab8175b2e04bbc9cb9523362ee70896b76f0d447
parent4ac6cbfdce1f85294bd54bcd8b074f7ef32c378f (diff)
downloadmeta-mingw-db1f53f73e95499a5f0b0edc45dd9cc9718d3c8a.tar.gz
zlib/zstd: Add correction of SOLIBS/SOLIBSDEV for mingw
The zlib/zstd recipes will always use .so suffixes when much of the system will use .dll. Reset the values for this recipe so that the code can set them more appropriate for the majority of cases. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--recipes-core/zlib/zlib_1.3%.bbappend2
-rw-r--r--recipes-extended/zstd/zstd_%.bbappend2
2 files changed, 4 insertions, 0 deletions
diff --git a/recipes-core/zlib/zlib_1.3%.bbappend b/recipes-core/zlib/zlib_1.3%.bbappend
index d03721a..d08daec 100644
--- a/recipes-core/zlib/zlib_1.3%.bbappend
+++ b/recipes-core/zlib/zlib_1.3%.bbappend
@@ -1 +1,3 @@
1EXTRA_OEMAKE:append:mingw32 = " LDSHAREDLIBC=''" 1EXTRA_OEMAKE:append:mingw32 = " LDSHAREDLIBC=''"
2SOLIBS:mingw32 = ".so.*"
3SOLIBSDEV:mingw32 = ".so"
diff --git a/recipes-extended/zstd/zstd_%.bbappend b/recipes-extended/zstd/zstd_%.bbappend
index 11a2d4e..ce7e01a 100644
--- a/recipes-extended/zstd/zstd_%.bbappend
+++ b/recipes-extended/zstd/zstd_%.bbappend
@@ -1,2 +1,4 @@
1EXTRA_OEMAKE:append:mingw32 = " OS=Windows" 1EXTRA_OEMAKE:append:mingw32 = " OS=Windows"
2FILES:${PN}:append:mingw32 = " ${libdir}/*.dll" 2FILES:${PN}:append:mingw32 = " ${libdir}/*.dll"
3SOLIBS:mingw32 = ".so.*"
4SOLIBSDEV:mingw32 = ".so"