summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-support/curl/curl_%.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes-support/curl/curl_%.bbappend b/recipes-support/curl/curl_%.bbappend
index a55c126..10c234d 100644
--- a/recipes-support/curl/curl_%.bbappend
+++ b/recipes-support/curl/curl_%.bbappend
@@ -1,3 +1,14 @@
1PACKAGECONFIG:remove:class-nativesdk:mingw32 = "openssl" 1PACKAGECONFIG:remove:class-nativesdk:mingw32 = "openssl"
2EXTRA_OECONF:append:class-nativesdk:mingw32 = " --without-ssl" 2EXTRA_OECONF:append:class-nativesdk:mingw32 = " --without-ssl"
3RRECOMMENDS:lib${BPN}:remove:mingw32 = "ca-certificates" 3RRECOMMENDS:lib${BPN}:remove:mingw32 = "ca-certificates"
4
5# Configure tests for ioctlsocket FIONBIO fails with GCC-14
6# because gcc can now find warnings when compiling the test
7# and these warnings are treated as errors
8# conftest.c: In function 'main':
9# conftest.c:137:41: error: passing argument 3 of 'ioctlsocket' from incompatible pointer type [-Wincompatible-pointer-types]
10# 137 | if(0 != ioctlsocket(0, FIONBIO, &flags))
11# | ^~~~~~
12# | |
13# | int *
14CFLAGS:append:mingw32 = " -Wno-error=incompatible-pointer-types"