diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-05-29 22:10:58 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2024-05-30 08:12:28 +0100 |
commit | 798f7e554ed2d3777db99bf6ebba85a2ccd9a549 (patch) | |
tree | 9d3d1000a9c3257f638c5f4b8a900ecb5a101d22 | |
parent | 8c6eabc762f13d7ae5d1c22a70e306550cb8616d (diff) | |
download | meta-mingw-798f7e554ed2d3777db99bf6ebba85a2ccd9a549.tar.gz |
curl: Disable incompatible-pointer-types warning as error on mingw
GCC-14 promoted this warning into error by default but code does not
build cleanly and now this warning becomes a hard error.
RP: Fix whitespace
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r-- | recipes-support/curl/curl_%.bbappend | 11 |
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes-support/curl/curl_%.bbappend b/recipes-support/curl/curl_%.bbappend index a55c126..10c234d 100644 --- a/recipes-support/curl/curl_%.bbappend +++ b/recipes-support/curl/curl_%.bbappend | |||
@@ -1,3 +1,14 @@ | |||
1 | PACKAGECONFIG:remove:class-nativesdk:mingw32 = "openssl" | 1 | PACKAGECONFIG:remove:class-nativesdk:mingw32 = "openssl" |
2 | EXTRA_OECONF:append:class-nativesdk:mingw32 = " --without-ssl" | 2 | EXTRA_OECONF:append:class-nativesdk:mingw32 = " --without-ssl" |
3 | RRECOMMENDS:lib${BPN}:remove:mingw32 = "ca-certificates" | 3 | RRECOMMENDS:lib${BPN}:remove:mingw32 = "ca-certificates" |
4 | |||
5 | # Configure tests for ioctlsocket FIONBIO fails with GCC-14 | ||
6 | # because gcc can now find warnings when compiling the test | ||
7 | # and these warnings are treated as errors | ||
8 | # conftest.c: In function 'main': | ||
9 | # conftest.c:137:41: error: passing argument 3 of 'ioctlsocket' from incompatible pointer type [-Wincompatible-pointer-types] | ||
10 | # 137 | if(0 != ioctlsocket(0, FIONBIO, &flags)) | ||
11 | # | ^~~~~~ | ||
12 | # | | | ||
13 | # | int * | ||
14 | CFLAGS:append:mingw32 = " -Wno-error=incompatible-pointer-types" | ||