diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-02-28 11:12:11 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-03-01 09:13:42 -0800 |
commit | 055dd8ceab5377e8694dfabe7d39b659643fd1a2 (patch) | |
tree | dac74ace955103e485660b2c3f9eb1c0aca2a71c | |
parent | edd8bd0f2443bbf1acc794df981cd05f1dbd6778 (diff) | |
download | meta-openembedded-055dd8ceab5377e8694dfabe7d39b659643fd1a2.tar.gz |
cyrus-sasl: Fix ptest builds
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Wang Mingyu <wangmy@fujitsu.com>
-rw-r--r-- | meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl/0001-sample-Rename-dprintf-to-cyrus_dprintf.patch | 91 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.28.bb | 1 |
2 files changed, 92 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl/0001-sample-Rename-dprintf-to-cyrus_dprintf.patch b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl/0001-sample-Rename-dprintf-to-cyrus_dprintf.patch new file mode 100644 index 0000000000..4c6d61dfc7 --- /dev/null +++ b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl/0001-sample-Rename-dprintf-to-cyrus_dprintf.patch | |||
@@ -0,0 +1,91 @@ | |||
1 | From ade70f39c4aa5a8830462d9ccf3b8f8dd968c0d8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 28 Feb 2022 11:10:26 -0800 | ||
4 | Subject: [PATCH] sample: Rename dprintf to cyrus_dprintf | ||
5 | |||
6 | This avoids shadowing the dprintf implementations in glibc | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | sample/client.c | 12 ++++++------ | ||
12 | sample/common.c | 2 +- | ||
13 | sample/common.h | 2 +- | ||
14 | 3 files changed, 8 insertions(+), 8 deletions(-) | ||
15 | |||
16 | diff --git a/sample/client.c b/sample/client.c | ||
17 | index e723c6b7..6a04f428 100644 | ||
18 | --- a/sample/client.c | ||
19 | +++ b/sample/client.c | ||
20 | @@ -241,9 +241,9 @@ int mysasl_negotiate(FILE *in, FILE *out, sasl_conn_t *conn) | ||
21 | int r, c; | ||
22 | |||
23 | /* get the capability list */ | ||
24 | - dprintf(0, "receiving capability list... "); | ||
25 | + cyrus_dprintf(0, "receiving capability list... "); | ||
26 | len = recv_string(in, buf, sizeof buf); | ||
27 | - dprintf(0, "%s\n", buf); | ||
28 | + cyrus_dprintf(0, "%s\n", buf); | ||
29 | |||
30 | if (mech) { | ||
31 | /* make sure that 'mech' appears in 'buf' */ | ||
32 | @@ -262,7 +262,7 @@ int mysasl_negotiate(FILE *in, FILE *out, sasl_conn_t *conn) | ||
33 | return -1; | ||
34 | } | ||
35 | |||
36 | - dprintf(1, "using mechanism %s\n", chosenmech); | ||
37 | + cyrus_dprintf(1, "using mechanism %s\n", chosenmech); | ||
38 | |||
39 | /* we send up to 3 strings; | ||
40 | the mechanism chosen, the presence of initial response, | ||
41 | @@ -276,7 +276,7 @@ int mysasl_negotiate(FILE *in, FILE *out, sasl_conn_t *conn) | ||
42 | } | ||
43 | |||
44 | for (;;) { | ||
45 | - dprintf(2, "waiting for server reply...\n"); | ||
46 | + cyrus_dprintf(2, "waiting for server reply...\n"); | ||
47 | |||
48 | c = fgetc(in); | ||
49 | switch (c) { | ||
50 | @@ -303,10 +303,10 @@ int mysasl_negotiate(FILE *in, FILE *out, sasl_conn_t *conn) | ||
51 | } | ||
52 | |||
53 | if (data) { | ||
54 | - dprintf(2, "sending response length %d...\n", len); | ||
55 | + cyrus_dprintf(2, "sending response length %d...\n", len); | ||
56 | send_string(out, data, len); | ||
57 | } else { | ||
58 | - dprintf(2, "sending null response...\n"); | ||
59 | + cyrus_dprintf(2, "sending null response...\n"); | ||
60 | send_string(out, "", 0); | ||
61 | } | ||
62 | } | ||
63 | diff --git a/sample/common.c b/sample/common.c | ||
64 | index 712549fd..d138e450 100644 | ||
65 | --- a/sample/common.c | ||
66 | +++ b/sample/common.c | ||
67 | @@ -127,7 +127,7 @@ int recv_string(FILE *f, char *buf, int buflen) | ||
68 | |||
69 | int debuglevel = 0; | ||
70 | |||
71 | -int dprintf(int lvl, const char *fmt, ...) | ||
72 | +int cyrus_dprintf(int lvl, const char *fmt, ...) | ||
73 | { | ||
74 | va_list ap; | ||
75 | int ret = 0; | ||
76 | diff --git a/sample/common.h b/sample/common.h | ||
77 | index 819d0101..cd56907a 100644 | ||
78 | --- a/sample/common.h | ||
79 | +++ b/sample/common.h | ||
80 | @@ -43,7 +43,7 @@ extern int send_string(FILE *f, const char *s, int l); | ||
81 | extern int recv_string(FILE *f, char *buf, int buflen); | ||
82 | |||
83 | extern int debuglevel; | ||
84 | -extern int dprintf(int lvl, const char *fmt, ...); | ||
85 | +extern int cyrus_dprintf(int lvl, const char *fmt, ...); | ||
86 | |||
87 | extern void saslerr(int why, const char *what); | ||
88 | extern void saslfail(int why, const char *what); | ||
89 | -- | ||
90 | 2.35.1 | ||
91 | |||
diff --git a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.28.bb b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.28.bb index 95a093cd11..98899dfd5e 100644 --- a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.28.bb +++ b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.28.bb | |||
@@ -10,6 +10,7 @@ SRCREV = "7a6b45b177070198fed0682bea5fa87c18abb084" | |||
10 | SRC_URI = "git://github.com/cyrusimap/cyrus-sasl;protocol=https;branch=cyrus-sasl-2.1 \ | 10 | SRC_URI = "git://github.com/cyrusimap/cyrus-sasl;protocol=https;branch=cyrus-sasl-2.1 \ |
11 | file://avoid-to-call-AC_TRY_RUN.patch \ | 11 | file://avoid-to-call-AC_TRY_RUN.patch \ |
12 | file://debian_patches_0014_avoid_pic_overwrite.diff \ | 12 | file://debian_patches_0014_avoid_pic_overwrite.diff \ |
13 | file://0001-sample-Rename-dprintf-to-cyrus_dprintf.patch \ | ||
13 | file://saslauthd.service \ | 14 | file://saslauthd.service \ |
14 | file://saslauthd.conf \ | 15 | file://saslauthd.conf \ |
15 | file://CVE-2019-19906.patch \ | 16 | file://CVE-2019-19906.patch \ |