summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2024-08-19 13:54:42 +0200
committerKhem Raj <raj.khem@gmail.com>2024-08-19 10:19:32 -0700
commit202bcbd9d9fb6214250a9dcfded7c901b89b7d53 (patch)
tree9c320dd997eb9be523ebfdb737ef4f50c23bbd7b
parentc4594daeabfcae9e0a341d519abb7933717b5b6d (diff)
downloadmeta-openembedded-202bcbd9d9fb6214250a9dcfded7c901b89b7d53.tar.gz
blueman: fix installation paths
* pass systemdsystemunitdir and systemduserunitdir to set correct directories instead of using libdir from: meson.build:systemd_base_path = join_paths(libdir, 'systemd') which is wrong e.g. with multilib where libdir might be /usr/lib64 instead of usr/lib used in ${nonarch_base_libdir} which is used by systemd_* variables: export systemd_system_unitdir="/usr/lib/systemd/system" export systemd_user_unitdir="/usr/lib/systemd/user" fixes: ERROR: Didn't find service unit 'blueman-mechanism.service', specified in SYSTEMD_SERVICE:blueman. * inherit python3targetconfig to install into right python site-packages without this it installs into /usr/lib/python3.12/site-packages/ instead of /usr/lib64/python3.12/site-packages set in PYTHON_SITEPACKAGES_DIR variable used in FILES, causing blueman: 295 installed and not shipped files. [installed-vs-shipped] # $PYTHON_SITEPACKAGES_DIR # set oe-core/meta/classes-recipe/python3-dir.bbclass:11 # "${libdir}/${PYTHON_DIR}/site-packages" PYTHON_SITEPACKAGES_DIR="/usr/lib64/python3.12/site-packages" Signed-off-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb b/meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb
index c2bb4d24c6..42e20cc9ed 100644
--- a/meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb
+++ b/meta-networking/recipes-connectivity/blueman/blueman_2.4.3.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
4 4
5DEPENDS = "gtk+3 glib-2.0 bluez5 python3-pygobject python3-cython-native" 5DEPENDS = "gtk+3 glib-2.0 bluez5 python3-pygobject python3-cython-native"
6 6
7inherit meson gettext systemd gsettings pkgconfig python3native gtk-icon-cache useradd features_check 7inherit meson gettext systemd gsettings pkgconfig python3native gtk-icon-cache useradd features_check python3targetconfig
8 8
9REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" 9REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
10 10
@@ -13,7 +13,10 @@ SRC_URI = "git://github.com/blueman-project/blueman.git;protocol=https;branch=2-
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14SRCREV = "7bcf919ad6ac0ee9a8c66b18b0ca98af877d4c8f" 14SRCREV = "7bcf919ad6ac0ee9a8c66b18b0ca98af877d4c8f"
15 15
16EXTRA_OEMESON = "-Druntime_deps_check=false" 16EXTRA_OEMESON = "-Druntime_deps_check=false \
17 -Dsystemdsystemunitdir=${systemd_system_unitdir} \
18 -Dsystemduserunitdir=${systemd_user_unitdir} \
19"
17 20
18SYSTEMD_SERVICE:${PN} = "${BPN}-mechanism.service" 21SYSTEMD_SERVICE:${PN} = "${BPN}-mechanism.service"
19SYSTEMD_AUTO_ENABLE:${PN} = "disable" 22SYSTEMD_AUTO_ENABLE:${PN} = "disable"
@@ -40,8 +43,8 @@ PACKAGECONFIG[polkit] = "-Dpolicykit=true,-Dpolicykit=false"
40FILES:${PN} += " \ 43FILES:${PN} += " \
41 ${datadir} \ 44 ${datadir} \
42 ${systemd_user_unitdir} \ 45 ${systemd_user_unitdir} \
46 ${systemd_system_unitdir} \
43 ${PYTHON_SITEPACKAGES_DIR} \ 47 ${PYTHON_SITEPACKAGES_DIR} \
44 ${prefix}${systemd_system_unitdir} \
45" 48"
46 49
47# In code, path to python is a variable that is replaced with path to native version of it 50# In code, path to python is a variable that is replaced with path to native version of it