summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-02-25 11:06:27 +0000
committerKhem Raj <raj.khem@gmail.com>2022-02-28 08:39:26 -0800
commit272f2083d46a5a023d0d18dcd3e8540a7c5c1cc8 (patch)
tree9b2786776df9e2aff8e0c9edbcbdd8ba808401d0
parentba34834fdd8785faa5cdfa9ea7fb2425b2efdc27 (diff)
downloadmeta-openembedded-272f2083d46a5a023d0d18dcd3e8540a7c5c1cc8.tar.gz
layer.conf: change layer priority to match oe-core
Layer priority is the ultimate decider of what recipe is used: if layer A has recipe foo_1 and layer B has recipe foo_2, if layer A's priority is higher than B then foo_1 will be used, even though the version in B is higher, and even if PREFERRED_VERSION_foo is set to 2. This complicates recipes moving between layers, for example when a newer version of a recipe (say, python3-wheel) is taken from a layer with a higher priority (say, meta-python) and moved to a layer with a lower priority (say, oe-core) then it has to be removed before it is added: there is no way to have it in both layers and work correctly. Higher priorities are useful in distribution layers where you may want to override specific recipes without any other fuss. However as all of the layers in meta-oe simply add more recipes in defined areas, there's no need to have a higher layer priority. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-filesystems/conf/layer.conf2
-rw-r--r--meta-gnome/conf/layer.conf2
-rw-r--r--meta-initramfs/conf/layer.conf2
-rw-r--r--meta-multimedia/conf/layer.conf2
-rw-r--r--meta-oe/conf/layer.conf2
-rw-r--r--meta-perl/conf/layer.conf2
-rw-r--r--meta-python/conf/layer.conf2
-rw-r--r--meta-webserver/conf/layer.conf2
-rw-r--r--meta-xfce/conf/layer.conf2
9 files changed, 9 insertions, 9 deletions
diff --git a/meta-filesystems/conf/layer.conf b/meta-filesystems/conf/layer.conf
index b5f59d9bac..75a27d6654 100644
--- a/meta-filesystems/conf/layer.conf
+++ b/meta-filesystems/conf/layer.conf
@@ -7,7 +7,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
7 7
8BBFILE_COLLECTIONS += "filesystems-layer" 8BBFILE_COLLECTIONS += "filesystems-layer"
9BBFILE_PATTERN_filesystems-layer = "^${LAYERDIR}/" 9BBFILE_PATTERN_filesystems-layer = "^${LAYERDIR}/"
10BBFILE_PRIORITY_filesystems-layer = "6" 10BBFILE_PRIORITY_filesystems-layer = "5"
11 11
12# This should only be incremented on significant changes that will 12# This should only be incremented on significant changes that will
13# cause compatibility issues with other layers 13# cause compatibility issues with other layers
diff --git a/meta-gnome/conf/layer.conf b/meta-gnome/conf/layer.conf
index 3f6b4f7b76..2fb3485155 100644
--- a/meta-gnome/conf/layer.conf
+++ b/meta-gnome/conf/layer.conf
@@ -6,7 +6,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
6 6
7BBFILE_COLLECTIONS += "gnome-layer" 7BBFILE_COLLECTIONS += "gnome-layer"
8BBFILE_PATTERN_gnome-layer := "^${LAYERDIR}/" 8BBFILE_PATTERN_gnome-layer := "^${LAYERDIR}/"
9BBFILE_PRIORITY_gnome-layer = "7" 9BBFILE_PRIORITY_gnome-layer = "5"
10 10
11# auto-pack gnome help files 11# auto-pack gnome help files
12IMAGE_LINGUAS_COMPLEMENTARY:append = " ${@bb.utils.contains('DISTRO_FEATURES','helpfiles','*-help-%s','',d)}" 12IMAGE_LINGUAS_COMPLEMENTARY:append = " ${@bb.utils.contains('DISTRO_FEATURES','helpfiles','*-help-%s','',d)}"
diff --git a/meta-initramfs/conf/layer.conf b/meta-initramfs/conf/layer.conf
index 33e61d333f..c63383faf7 100644
--- a/meta-initramfs/conf/layer.conf
+++ b/meta-initramfs/conf/layer.conf
@@ -13,7 +13,7 @@ BBFILE_PATTERN_meta-initramfs := "^${LAYERDIR}/"
13# choosing carefully how this layer interacts with all of the 13# choosing carefully how this layer interacts with all of the
14# other layers. 14# other layers.
15 15
16BBFILE_PRIORITY_meta-initramfs = "8" 16BBFILE_PRIORITY_meta-initramfs = "5"
17LAYERDEPENDS_meta-initramfs = "core" 17LAYERDEPENDS_meta-initramfs = "core"
18 18
19LAYERSERIES_COMPAT_meta-initramfs = "kirkstone" 19LAYERSERIES_COMPAT_meta-initramfs = "kirkstone"
diff --git a/meta-multimedia/conf/layer.conf b/meta-multimedia/conf/layer.conf
index 1fe9c80330..b5120bb539 100644
--- a/meta-multimedia/conf/layer.conf
+++ b/meta-multimedia/conf/layer.conf
@@ -23,7 +23,7 @@ LICENSE_PATH += "${LAYERDIR}/licenses"
23# choosing carefully how this layer interacts with all of the 23# choosing carefully how this layer interacts with all of the
24# other layers. 24# other layers.
25 25
26BBFILE_PRIORITY_multimedia-layer = "6" 26BBFILE_PRIORITY_multimedia-layer = "5"
27 27
28# This should only be incremented on significant changes that will 28# This should only be incremented on significant changes that will
29# cause compatibility issues with other layers 29# cause compatibility issues with other layers
diff --git a/meta-oe/conf/layer.conf b/meta-oe/conf/layer.conf
index 93f3dc5807..88715d5e82 100644
--- a/meta-oe/conf/layer.conf
+++ b/meta-oe/conf/layer.conf
@@ -21,7 +21,7 @@ BBFILE_PATTERN_openembedded-layer := "^${LAYERDIR}/"
21# choosing carefully how this layer interacts with all of the 21# choosing carefully how this layer interacts with all of the
22# other layers. 22# other layers.
23 23
24BBFILE_PRIORITY_openembedded-layer = "6" 24BBFILE_PRIORITY_openembedded-layer = "5"
25 25
26# only activates content when identified layers are present, 26# only activates content when identified layers are present,
27# to ensure yocto compatibility check pass 27# to ensure yocto compatibility check pass
diff --git a/meta-perl/conf/layer.conf b/meta-perl/conf/layer.conf
index 4f075e9a92..3cb9571d41 100644
--- a/meta-perl/conf/layer.conf
+++ b/meta-perl/conf/layer.conf
@@ -7,7 +7,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
7 7
8BBFILE_COLLECTIONS += "perl-layer" 8BBFILE_COLLECTIONS += "perl-layer"
9BBFILE_PATTERN_perl-layer := "^${LAYERDIR}/" 9BBFILE_PATTERN_perl-layer := "^${LAYERDIR}/"
10BBFILE_PRIORITY_perl-layer = "6" 10BBFILE_PRIORITY_perl-layer = "5"
11 11
12# This should only be incremented on significant changes that will 12# This should only be incremented on significant changes that will
13# cause compatibility issues with other layers 13# cause compatibility issues with other layers
diff --git a/meta-python/conf/layer.conf b/meta-python/conf/layer.conf
index 98f734152f..e444498ff0 100644
--- a/meta-python/conf/layer.conf
+++ b/meta-python/conf/layer.conf
@@ -6,7 +6,7 @@ BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
6 6
7BBFILE_COLLECTIONS += "meta-python" 7BBFILE_COLLECTIONS += "meta-python"
8BBFILE_PATTERN_meta-python := "^${LAYERDIR}/" 8BBFILE_PATTERN_meta-python := "^${LAYERDIR}/"
9BBFILE_PRIORITY_meta-python = "7" 9BBFILE_PRIORITY_meta-python = "5"
10 10
11# This should only be incremented on significant changes that will 11# This should only be incremented on significant changes that will
12# cause compatibility issues with other layers 12# cause compatibility issues with other layers
diff --git a/meta-webserver/conf/layer.conf b/meta-webserver/conf/layer.conf
index 312c39b3b3..5ae5e796ae 100644
--- a/meta-webserver/conf/layer.conf
+++ b/meta-webserver/conf/layer.conf
@@ -9,7 +9,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
9 9
10BBFILE_COLLECTIONS += "webserver" 10BBFILE_COLLECTIONS += "webserver"
11BBFILE_PATTERN_webserver := "^${LAYERDIR}/" 11BBFILE_PATTERN_webserver := "^${LAYERDIR}/"
12BBFILE_PRIORITY_webserver = "6" 12BBFILE_PRIORITY_webserver = "5"
13 13
14# This should only be incremented on significant changes that will 14# This should only be incremented on significant changes that will
15# cause compatibility issues with other layers 15# cause compatibility issues with other layers
diff --git a/meta-xfce/conf/layer.conf b/meta-xfce/conf/layer.conf
index be58708679..28dfc5b340 100644
--- a/meta-xfce/conf/layer.conf
+++ b/meta-xfce/conf/layer.conf
@@ -6,7 +6,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
6 6
7BBFILE_COLLECTIONS += "xfce-layer" 7BBFILE_COLLECTIONS += "xfce-layer"
8BBFILE_PATTERN_xfce-layer := "^${LAYERDIR}/" 8BBFILE_PATTERN_xfce-layer := "^${LAYERDIR}/"
9BBFILE_PRIORITY_xfce-layer = "7" 9BBFILE_PRIORITY_xfce-layer = "5"
10 10
11# This should only be incremented on significant changes that will 11# This should only be incremented on significant changes that will
12# cause compatibility issues with other layers 12# cause compatibility issues with other layers