diff options
author | Yoann Congal <yoann.congal@smile.fr> | 2025-05-09 00:35:14 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-05-08 18:29:34 -0700 |
commit | 273c29232e0d2d1bdb65bb8abd053b1fa4b7733c (patch) | |
tree | 72aa818f0552b21a4862c2537b53d6e731cb105e | |
parent | 18a627a46ce1a02bea6fcd68384b54d7c6aa69bb (diff) | |
download | meta-openembedded-273c29232e0d2d1bdb65bb8abd053b1fa4b7733c.tar.gz |
hiawatha: use -std=gnu17 for compilation
hiawatha does not build under -std=gnu23 which is the default of
gcc15. Forcing -std=gnu17 fixes these build errors:
| .../tmp/work/core2-64-poky-linux/hiawatha/11.2/hiawatha-11.2/src/hiawatha.c:814:25: error: passing argument 2 of 'signal' from incompatible pointer type [-Wincompatible-pointer-types]
| 814 | signal(SIGHUP, HUP_handler);
| | ^~~~~~~~~~~
| | |
| | void (*)(void)
| .../tmp/work/core2-64-poky-linux/hiawatha/11.2/recipe-sysroot/usr/include/signal.h:88:57: note: expected '__sighandler_t' {aka 'void (*)(int)'} but argument is of type 'void (*)(void)'
| 88 | extern __sighandler_t signal (int __sig, __sighandler_t __handler)
| | ~~~~~~~~~~~~~~~^~~~~~~~~
| .../tmp/work/core2-64-poky-linux/hiawatha/11.2/hiawatha-11.2/src/hiawatha.c:294:6: note: 'HUP_handler' declared here
| 294 | void HUP_handler() {
| | ^~~~~~~~~~~
| .../tmp/work/core2-64-poky-linux/hiawatha/11.2/recipe-sysroot/usr/include/signal.h:72:16: note: '__sighandler_t' declared here
| 72 | typedef void (*__sighandler_t) (int);
| | ^~~~~~~~~~~~~~
Note: Upstream project has no published way to upstream patches.
Signed-off-by: Yoann Congal <yoann.congal@smile.fr>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-webserver/recipes-httpd/hiawatha/hiawatha_11.2.bb | 2 |
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/hiawatha/hiawatha_11.2.bb b/meta-webserver/recipes-httpd/hiawatha/hiawatha_11.2.bb index 169e385da6..098c07e954 100644 --- a/meta-webserver/recipes-httpd/hiawatha/hiawatha_11.2.bb +++ b/meta-webserver/recipes-httpd/hiawatha/hiawatha_11.2.bb | |||
@@ -19,6 +19,8 @@ SYSTEMD_SERVICE:${PN} = "hiawatha.service" | |||
19 | 19 | ||
20 | inherit cmake update-rc.d systemd | 20 | inherit cmake update-rc.d systemd |
21 | 21 | ||
22 | CFLAGS += "-std=gnu17" | ||
23 | |||
22 | EXTRA_OECMAKE = " -DENABLE_IPV6=OFF \ | 24 | EXTRA_OECMAKE = " -DENABLE_IPV6=OFF \ |
23 | -DENABLE_CACHE=OFF \ | 25 | -DENABLE_CACHE=OFF \ |
24 | -DENABLE_DEBUG=OFF \ | 26 | -DENABLE_DEBUG=OFF \ |