summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-02 21:36:09 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-05 22:49:35 -0700
commit2a1ae8b23d60b3ed2d886ca25b0ca225a34faec7 (patch)
treea65f83a0dd1b006b16d4343de4810f44b4697f9f
parent6c251848590867debaaf87bfe12bed572d8f6a8d (diff)
downloadmeta-openembedded-2a1ae8b23d60b3ed2d886ca25b0ca225a34faec7.tar.gz
glm: Disable clang specific warnings
This code should be fixed but for now lets disable the warnings as errors atleast, so it can compile with clang Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/glm/glm_0.9.9.8.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/glm/glm_0.9.9.8.bb b/meta-oe/recipes-graphics/glm/glm_0.9.9.8.bb
index 71a005a564..9edcb2b6e1 100644
--- a/meta-oe/recipes-graphics/glm/glm_0.9.9.8.bb
+++ b/meta-oe/recipes-graphics/glm/glm_0.9.9.8.bb
@@ -22,6 +22,8 @@ S = "${WORKDIR}/git"
22 22
23inherit cmake 23inherit cmake
24 24
25CXXFLAGS:append:toolchain-clang = " -Wno-error=invalid-utf8 -Wno-error=disabled-macro-expansion -Wno-error=reserved-identifier"
26
25do_install() { 27do_install() {
26 install -d ${D}${includedir} ${D}${docdir}/glm ${D}${libdir}/pkgconfig ${D}${libdir}/cmake/glm 28 install -d ${D}${includedir} ${D}${docdir}/glm ${D}${libdir}/pkgconfig ${D}${libdir}/cmake/glm
27 cp -R --no-dereference --preserve=mode,links ${S}/glm ${D}${includedir} 29 cp -R --no-dereference --preserve=mode,links ${S}/glm ${D}${includedir}