diff options
author | Niko Mauno <niko.mauno@vaisala.com> | 2025-04-04 10:51:49 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-04-24 18:43:19 -0700 |
commit | 2cd4763dc133aba5ec61c822ad7f29e4de9f358d (patch) | |
tree | 90d1dcbf12b5b7b8464ed2736a6025b957269aae | |
parent | 86c0c57ddd51c83b57f3ced6a7b87d63a08d010a (diff) | |
download | meta-openembedded-2cd4763dc133aba5ec61c822ad7f29e4de9f358d.tar.gz |
system-config-printer: Update D-Bus runtime dependency declaration
In order to facilitate users who wish to use e.g. dbus-broker as their
runtime D-Bus implementation, change the Freedesktop.org specific D-Bus
runtime dependency to honor oe-core's new VIRTUAL-RUNTIME_dbus
variable.
With this change we also align with oe-core commit 5dfca64b78
("dbus-glib: depend on dbus, not dbus-x11") which mentions that
dbus-x11 hasn't existed as a package since 2012[1] and is just a
RPROVIDES in dbus, so depend on dbus directly instead.
Signed-off-by: Niko Mauno <niko.mauno@vaisala.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-networking/dynamic-layers/meta-python/recipes-printing/system-config-printer/system-config-printer_1.5.18.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-networking/dynamic-layers/meta-python/recipes-printing/system-config-printer/system-config-printer_1.5.18.bb b/meta-networking/dynamic-layers/meta-python/recipes-printing/system-config-printer/system-config-printer_1.5.18.bb index bff16b4412..f9a5e15689 100644 --- a/meta-networking/dynamic-layers/meta-python/recipes-printing/system-config-printer/system-config-printer_1.5.18.bb +++ b/meta-networking/dynamic-layers/meta-python/recipes-printing/system-config-printer/system-config-printer_1.5.18.bb | |||
@@ -38,7 +38,7 @@ FILES:${PN} += "${libdir} ${datadir}" | |||
38 | 38 | ||
39 | RDEPENDS:${PN} = " \ | 39 | RDEPENDS:${PN} = " \ |
40 | cups \ | 40 | cups \ |
41 | dbus-x11 \ | 41 | ${VIRTUAL-RUNTIME_dbus} \ |
42 | gtk+3 \ | 42 | gtk+3 \ |
43 | libnotify \ | 43 | libnotify \ |
44 | python3-core \ | 44 | python3-core \ |