diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-08-03 17:05:17 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-08-06 10:27:15 -0700 |
commit | 2d1838e2cec7532da0fbcb3498ef69789bb8ca2c (patch) | |
tree | ca9136d45f57ddf84443c43e2cb2dc611b8b5c91 | |
parent | ff7795ab7ba7f438b305f2845eecd1f3a2f9e692 (diff) | |
download | meta-openembedded-2d1838e2cec7532da0fbcb3498ef69789bb8ca2c.tar.gz |
python3-cryptography: Upgrade 2.8 -> 3.0
Upgrade to release 3.0:
- Deprecated support for Python 2. At the time there is no time
table for actually dropping support, however we strongly
encourage all users to upgrade their Python, as Python 2 no
longer receives support from the Python core team.
- Added support for OpenSSH serialization format for ec, ed25519,
rsa and dsa private keys.
- Added support for OpenSSH certificates.
- Added :meth:`~cryptography.fernet.Fernet.encrypt_at_time` and
:meth:`~cryptography.fernet.Fernet.decrypt_at_time` to
:class:`~cryptography.fernet.Fernet`.
- Added support for the :class:`~cryptography.x509.SubjectInformationAccess`
X.509 extension.
- Added support for parsing :class:`~cryptography.x509.SignedCertificateTimestamps`
in OCSP responses.
- Added support for parsing attributes in certificate signing
requests.
- Added support for encoding attributes in certificate signing
requests.
- On OpenSSL 1.1.1d and higher cryptography now uses OpenSSL's
built-in CSPRNG instead of its own OS random engine because
ithese versions of OpenSSL properly reseed on fork.
BACKWARDS INCOMPATIBLE:
- Support for LibreSSL 2.7.x, 2.8.x, and 2.9.0 has been removed
(2.9.1+ is still supported).
- Dropped support for macOS 10.9, macOS users must upgrade to
10.10 or newer.
- RSA :meth:`~cryptography.hazmat.primitives.asymmetric.rsa.generate_private_key`
no longer accepts public_exponent values except 65537 and 3
(the latter for legacy purposes).
- X.509 certificate parsing now enforces that the version field
contains a valid value, rather than deferring this check until
:attr:`~cryptography.x509.Certificate.version` is accessed.
- Added initial support for creating PKCS12 files with
:func:`~cryptography.hazmat.primitives.serialization.pkcs12.serialize_key_and_certificates`.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-cryptography_3.0.bb (renamed from meta-python/recipes-devtools/python/python3-cryptography_2.8.bb) | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb b/meta-python/recipes-devtools/python/python3-cryptography_3.0.bb index 95e903b290..05a2350e37 100644 --- a/meta-python/recipes-devtools/python/python3-cryptography_2.8.bb +++ b/meta-python/recipes-devtools/python/python3-cryptography_3.0.bb | |||
@@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=097f805837700cfac572ac274cd38124" | |||
6 | 6 | ||
7 | LDSHARED += "-pthread" | 7 | LDSHARED += "-pthread" |
8 | 8 | ||
9 | SRC_URI[md5sum] = "77730058b556c6d9838679a94c6229ce" | 9 | SRC_URI[md5sum] = "163608a7cb838c6b39360e1e64377d54" |
10 | SRC_URI[sha256sum] = "3cda1f0ed8747339bbdf71b9f38ca74c7b592f24f65cdb3ab3765e4b02871651" | 10 | SRC_URI[sha256sum] = "8e924dbc025206e97756e8903039662aa58aa9ba357d8e1d8fc29e3092322053" |
11 | 11 | ||
12 | SRC_URI += " \ | 12 | SRC_URI += " \ |
13 | file://run-ptest \ | 13 | file://run-ptest \ |