summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2025-05-18 10:31:44 -0700
committerKhem Raj <raj.khem@gmail.com>2025-05-19 08:37:20 -0700
commit3b05ba3794b458051beee42c7924df82f8e6070b (patch)
tree33a130f73e30030c185f04d1e51b31b1b871abc3
parent8803832e70274b14c00f6b7806a22ebf6dd4ffa9 (diff)
downloadmeta-openembedded-3b05ba3794b458051beee42c7924df82f8e6070b.tar.gz
python3-propcache: Fix build with cython 3.1
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-propcache/0001-Fix-build-with-cython-3.1.x.patch34
-rw-r--r--meta-python/recipes-devtools/python/python3-propcache_0.3.1.bb1
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-propcache/0001-Fix-build-with-cython-3.1.x.patch b/meta-python/recipes-devtools/python/python3-propcache/0001-Fix-build-with-cython-3.1.x.patch
new file mode 100644
index 0000000000..3b86b23c00
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-propcache/0001-Fix-build-with-cython-3.1.x.patch
@@ -0,0 +1,34 @@
1From 8d44d867f7cd86da4edf328e06b13778577ea4b7 Mon Sep 17 00:00:00 2001
2From: WXbet <57314510+WXbet@users.noreply.github.com>
3Date: Thu, 15 May 2025 21:54:48 +0200
4Subject: [PATCH] Fix build with cython 3.1.x
5
6closes #113
7
8Upstream-Status: Submitted [https://github.com/aio-libs/propcache/pull/114]
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 packaging/pep517_backend/_backend.py | 2 +-
12 requirements/cython.txt | 2 +-
13 2 files changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/packaging/pep517_backend/_backend.py b/packaging/pep517_backend/_backend.py
16index 7588db3..f75b83a 100644
17--- a/packaging/pep517_backend/_backend.py
18+++ b/packaging/pep517_backend/_backend.py
19@@ -379,7 +379,7 @@ def get_requires_for_build_wheel(
20 elif sysconfig.get_config_var('Py_GIL_DISABLED'):
21 c_ext_build_deps = ['Cython ~= 3.1.0a1']
22 else:
23- c_ext_build_deps = ['Cython ~= 3.0.12']
24+ c_ext_build_deps = ['Cython ~= 3.1']
25
26 return _setuptools_get_requires_for_build_wheel(
27 config_settings=config_settings,
28diff --git a/requirements/cython.txt b/requirements/cython.txt
29index 69a1d6f..5b356ed 100644
30--- a/requirements/cython.txt
31+++ b/requirements/cython.txt
32@@ -1 +1 @@
33-cython==3.0.12
34+cython~=3.1
diff --git a/meta-python/recipes-devtools/python/python3-propcache_0.3.1.bb b/meta-python/recipes-devtools/python/python3-propcache_0.3.1.bb
index 24b72f09c3..afa6822563 100644
--- a/meta-python/recipes-devtools/python/python3-propcache_0.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-propcache_0.3.1.bb
@@ -3,6 +3,7 @@ HOMEPAGE = "https://github.com/aio-libs/propcache"
3LICENSE = "Apache-2.0" 3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5 5
6SRC_URI += "file://0001-Fix-build-with-cython-3.1.x.patch"
6SRC_URI[sha256sum] = "40d980c33765359098837527e18eddefc9a24cea5b45e078a7f3bb5b032c6ecf" 7SRC_URI[sha256sum] = "40d980c33765359098837527e18eddefc9a24cea5b45e078a7f3bb5b032c6ecf"
7 8
8inherit pypi python_setuptools_build_meta ptest-python-pytest cython 9inherit pypi python_setuptools_build_meta ptest-python-pytest cython