summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2025-01-23 16:14:33 -0800
committerKhem Raj <raj.khem@gmail.com>2025-01-24 18:27:33 -0800
commit3de33656f9dc541832b14556095e88f37f90232f (patch)
tree0da3f8992eda417599fc6539bd4891fc35ab542b
parent6d828d32e22736a4017f64fb92c5571de2451230 (diff)
downloadmeta-openembedded-3de33656f9dc541832b14556095e88f37f90232f.tar.gz
ncftp: Replace references to ACLOCALEXTRAPATH
- ACLOCALEXTRAPATH is gone in core with commit 878e1517d4890b31332a506ce903d57e1d7dff87 - Add patches to fix build with latest clang and gcc - Drop disabling warnings as the fixes above take care of the problem Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-daemons/ncftp/ncftp/0001-ncftp-3.2.7-fix-gcc14.patch20
-rw-r--r--meta-networking/recipes-daemons/ncftp/ncftp/0002-ncftp-3.2.7-fix-clang.patch73
-rw-r--r--meta-networking/recipes-daemons/ncftp/ncftp_3.2.7.bb4
3 files changed, 96 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/ncftp/ncftp/0001-ncftp-3.2.7-fix-gcc14.patch b/meta-networking/recipes-daemons/ncftp/ncftp/0001-ncftp-3.2.7-fix-gcc14.patch
new file mode 100644
index 0000000000..9b8a0c778b
--- /dev/null
+++ b/meta-networking/recipes-daemons/ncftp/ncftp/0001-ncftp-3.2.7-fix-gcc14.patch
@@ -0,0 +1,20 @@
1fix select arg detection
2
3Reference:
4 https://bugs.gentoo.org/921487
5
6Upstream-Status: Inappropriate [unresponsive contact email address]
7
8Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10--- a/autoconf_local/aclocal.m4
11+++ b/autoconf_local/aclocal.m4
12@@ -4196,7 +4196,7 @@ AC_MSG_CHECKING([types of arguments for
13 #include <sys/select.h>
14 #endif
15 #include <sys/socket.h> /* MG: always incl */
16-extern select ($ac_cv_func_select_arg1,$ac_cv_func_select_arg234,$ac_cv_func_select_arg234,$ac_cv_func_select_arg234,$ac_cv_func_select_arg5);],,dnl
17+extern int select ($ac_cv_func_select_arg1,$ac_cv_func_select_arg234,$ac_cv_func_select_arg234,$ac_cv_func_select_arg234,$ac_cv_func_select_arg5);],,dnl
18 [ac_not_found=no ; break 3],ac_not_found=yes)
19 done
20 done
diff --git a/meta-networking/recipes-daemons/ncftp/ncftp/0002-ncftp-3.2.7-fix-clang.patch b/meta-networking/recipes-daemons/ncftp/ncftp/0002-ncftp-3.2.7-fix-clang.patch
new file mode 100644
index 0000000000..a8de816e62
--- /dev/null
+++ b/meta-networking/recipes-daemons/ncftp/ncftp/0002-ncftp-3.2.7-fix-clang.patch
@@ -0,0 +1,73 @@
1Fix compilation with clang-16
2
3aclocal.m4 contains code that no longer compiles: missing headers and missing
4return types.
5
6Reference:
7 https://gitweb.gentoo.org/repo/gentoo.git/tree/net-ftp/ncftp/files/ncftp-3.2.7-fix-clang.patch
8
9Upstream-Status: Inappropriate [unresponsive contact email address]
10
11Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13--- a/autoconf_local/aclocal.m4
14+++ b/autoconf_local/aclocal.m4
15@@ -3057,6 +3057,7 @@ AC_TRY_LINK([
16 #include <sys/uio.h>
17 #include <sys/socket.h>
18 #include <sys/un.h>
19+#include <string.h>
20 ],[
21 struct sockaddr_un uaddr;
22
23@@ -3285,6 +3286,7 @@ AC_TRY_LINK([
24 #ifdef HAVE_RESOLV_H
25 # include <resolv.h>
26 #endif
27+#include <string.h>
28 ],[
29 /* function-body */
30 int len;
31@@ -3363,6 +3365,7 @@ else
32 #include <stdio.h>
33 #include <stdlib.h>
34
35+ int
36 main(int argc, char **argv)
37 {
38 /* Note: don't actually call readline,
39@@ -5144,6 +5147,7 @@ do
40 #ifdef HAVE_STDLIB_H
41 # include <stdlib.h>
42 #endif
43+#include <string.h>
44
45 #ifdef HAVE_NCURSES_H
46 # define NCURSES_OPAQUE 0
47@@ -5175,6 +5179,7 @@ do
48 #endif
49
50
51+int
52 main(int argc, char **argv)
53 {
54 /* Note: don't actually call curses, since it may block;
55@@ -6509,7 +6514,6 @@ char *malloc();
56 #endif
57 #endif /* MG */
58
59-int
60 int main(void)
61 {
62 char *data, *data2, *data3;
63@@ -6606,8 +6610,9 @@ else
64 AC_CACHE_CHECK(whether setvbuf arguments are reversed,
65 ac_cv_func_setvbuf_reversed,
66 [AC_TRY_RUN([#include <stdio.h>
67+ $include <stdlib.h>
68 /* If setvbuf has the reversed format, exit 0. */
69- main () {
70+ int main (void) {
71 /* This call has the arguments reversed.
72 A reversed system may check and see that the address of main
73 is not _IOLBF, _IONBF, or _IOFBF, and return nonzero. */
diff --git a/meta-networking/recipes-daemons/ncftp/ncftp_3.2.7.bb b/meta-networking/recipes-daemons/ncftp/ncftp_3.2.7.bb
index de111cac05..9ef9182b54 100644
--- a/meta-networking/recipes-daemons/ncftp/ncftp_3.2.7.bb
+++ b/meta-networking/recipes-daemons/ncftp/ncftp_3.2.7.bb
@@ -9,6 +9,8 @@ SRC_URI = "https://www.ncftp.com/public_ftp/ncftp/${BP}-src.tar.xz \
9 file://ncftp-configure-use-BUILD_CC-for-ccdv.patch \ 9 file://ncftp-configure-use-BUILD_CC-for-ccdv.patch \
10 file://unistd.patch \ 10 file://unistd.patch \
11 file://0001-Forward-port-defining-PREFIX_BINDIR-to-use-new-autoc.patch \ 11 file://0001-Forward-port-defining-PREFIX_BINDIR-to-use-new-autoc.patch \
12 file://0001-ncftp-3.2.7-fix-gcc14.patch \
13 file://0002-ncftp-3.2.7-fix-clang.patch \
12 " 14 "
13SRC_URI[sha256sum] = "d41c5c4d6614a8eae2ed4e4d7ada6b6d3afcc9fb65a4ed9b8711344bef24f7e8" 15SRC_URI[sha256sum] = "d41c5c4d6614a8eae2ed4e4d7ada6b6d3afcc9fb65a4ed9b8711344bef24f7e8"
14 16
@@ -20,7 +22,7 @@ PACKAGECONFIG ??= ""
20PACKAGECONFIG[ccdv] = "--enable-ccdv,--disable-ccdv,," 22PACKAGECONFIG[ccdv] = "--enable-ccdv,--disable-ccdv,,"
21 23
22EXTRA_OECONF = "--disable-precomp --disable-universal ac_cv_path_TAR=tar" 24EXTRA_OECONF = "--disable-precomp --disable-universal ac_cv_path_TAR=tar"
23ACLOCALEXTRAPATH:append = " -I ${S}/autoconf_local" 25EXTRA_AUTORECONF += "-I ${S}/autoconf_local"
24 26
25do_install () { 27do_install () {
26 install -d ${D}${bindir} ${D}${sysconfdir} ${D}${mandir} 28 install -d ${D}${bindir} ${D}${sysconfdir} ${D}${mandir}