summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-15 13:30:13 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-17 08:57:04 -0700
commit41b38d74218c10db1f95c0dc5a6ed17abff7e17a (patch)
tree2b881a286f1817dc64a49ae49e58730028851aeb
parent812b1c01b09644833101f7e52bf1b13513c4c532 (diff)
downloadmeta-openembedded-41b38d74218c10db1f95c0dc5a6ed17abff7e17a.tar.gz
python3-incremental: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-incremental.inc20
-rw-r--r--meta-python/recipes-devtools/python/python3-incremental_17.5.0.bb22
2 files changed, 20 insertions, 22 deletions
diff --git a/meta-python/recipes-devtools/python/python-incremental.inc b/meta-python/recipes-devtools/python/python-incremental.inc
deleted file mode 100644
index ef5e903fbf..0000000000
--- a/meta-python/recipes-devtools/python/python-incremental.inc
+++ /dev/null
@@ -1,20 +0,0 @@
1DESCRIPTION = "Incremental is a small library that versions your Python projects"
2HOMEPAGE = "https://github.com/twisted/incremental"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=6ca9b07f08e2c72d48c74d363d1e0e15"
5
6SRC_URI[md5sum] = "602746e0d438e075a5a9e0678140bba2"
7SRC_URI[sha256sum] = "7b751696aaf36eebfab537e458929e194460051ccad279c72b755a167eebd4b3"
8
9inherit pypi
10
11RDEPENDS_${PN} += " \
12 ${PYTHON_PN}-twisted \
13 ${PYTHON_PN}-click \
14"
15
16# -native is needed to build python[3]-twisted, however, we need to take steps to
17# prevent a circular dependency. The build apparently does not use the part of
18# python-incremental which uses python-twisted, so this hack is OK.
19RDEPENDS_${PYTHON_PN}-incremental-native_remove = "${PYTHON_PN}-twisted-native"
20BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-incremental_17.5.0.bb b/meta-python/recipes-devtools/python/python3-incremental_17.5.0.bb
index 0f04df4a67..568ba19898 100644
--- a/meta-python/recipes-devtools/python/python3-incremental_17.5.0.bb
+++ b/meta-python/recipes-devtools/python/python3-incremental_17.5.0.bb
@@ -1,2 +1,20 @@
1inherit setuptools3 1DESCRIPTION = "Incremental is a small library that versions your Python projects"
2require python-incremental.inc 2HOMEPAGE = "https://github.com/twisted/incremental"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=6ca9b07f08e2c72d48c74d363d1e0e15"
5
6SRC_URI[md5sum] = "602746e0d438e075a5a9e0678140bba2"
7SRC_URI[sha256sum] = "7b751696aaf36eebfab537e458929e194460051ccad279c72b755a167eebd4b3"
8
9inherit pypi setuptools3
10
11RDEPENDS_${PN} += " \
12 ${PYTHON_PN}-twisted \
13 ${PYTHON_PN}-click \
14"
15
16# -native is needed to build python[3]-twisted, however, we need to take steps to
17# prevent a circular dependency. The build apparently does not use the part of
18# python-incremental which uses python-twisted, so this hack is OK.
19RDEPENDS_${PYTHON_PN}-incremental-native_remove = "${PYTHON_PN}-twisted-native"
20BBCLASSEXTEND = "native"