diff options
author | Yoann Congal <yoann.congal@smile.fr> | 2025-05-03 00:49:45 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-05-03 01:59:06 -0700 |
commit | 46866b0022690f7408d0c5d7d3a22ba03e3af1a7 (patch) | |
tree | f300a49b860fb11f1d174c1a04769d93ecf71c04 | |
parent | 0d5ffeeb70639920ab20de1e6ef4c5ece72b97bd (diff) | |
download | meta-openembedded-46866b0022690f7408d0c5d7d3a22ba03e3af1a7.tar.gz |
python3-evdev: add ptest
root@qemux86-64:~# ptest-runner python3-evdev
START: ptest-runner
2025-05-02T22:19
BEGIN: /usr/lib/python3-evdev/ptest
[ 61.988046] input: test-py-evdev-uinput as /devices/virtual/input/input18
[ 61.990878] input: test-py-evdev-uinput as /devices/virtual/input/input19
[ 61.993060] input: test-py-evdev-uinput as /devices/virtual/input/input20
[ 61.994497] input: py-evdev-uinput as /devices/virtual/input/input21
[ 61.996659] input: test-py-evdev-uinput as /devices/virtual/input/input22
PASS: tests/test_ecodes.py:test_equality
PASS: tests/test_ecodes.py:test_access
PASS: tests/test_ecodes.py:test_overlap
PASS: tests/test_ecodes.py:test_generated
PASS: tests/test_events.py:test_categorize
PASS: tests/test_events.py:test_keyevent
PASS: tests/test_uinput.py:test_open
PASS: tests/test_uinput.py:test_open_context
PASS: tests/test_uinput.py:test_maxnamelen
PASS: tests/test_uinput.py:test_enable_events
PASS: tests/test_uinput.py:test_abs_values
PASS: tests/test_uinput.py:test_write
PASS: tests/test_uinput.py:test_not_a_character_device
PASS: tests/test_uinput.py:test_not_a_character_device_2
PASS: tests/test_uinput.py:test_not_a_character_device_3
PASS: tests/test_util.py:test_match_ecodes_a
============================================================================
Testsuite summary
DURATION: 0
END: /usr/lib/python3-evdev/ptest
2025-05-02T22:19
STOP: ptest-runner
TOTAL: 1 FAIL: 0
Signed-off-by: Yoann Congal <yoann.congal@smile.fr>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/conf/include/ptest-packagelists-meta-python.inc | 1 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-evdev_1.9.2.bb | 2 |
2 files changed, 2 insertions, 1 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc index a1465dac7c..b953ae2502 100644 --- a/meta-python/conf/include/ptest-packagelists-meta-python.inc +++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc | |||
@@ -23,6 +23,7 @@ PTESTS_FAST_META_PYTHON = "\ | |||
23 | python3-dasbus \ | 23 | python3-dasbus \ |
24 | python3-dominate \ | 24 | python3-dominate \ |
25 | python3-dnspython \ | 25 | python3-dnspython \ |
26 | python3-evdev \ | ||
26 | python3-execnet \ | 27 | python3-execnet \ |
27 | python3-fastjsonschema \ | 28 | python3-fastjsonschema \ |
28 | python3-fastnumbers \ | 29 | python3-fastnumbers \ |
diff --git a/meta-python/recipes-devtools/python/python3-evdev_1.9.2.bb b/meta-python/recipes-devtools/python/python3-evdev_1.9.2.bb index dc777cb987..993dfca1e6 100644 --- a/meta-python/recipes-devtools/python/python3-evdev_1.9.2.bb +++ b/meta-python/recipes-devtools/python/python3-evdev_1.9.2.bb | |||
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=d7bd1cc4c71b706c7e2d4053aef50f2a" | |||
5 | 5 | ||
6 | SRC_URI[sha256sum] = "5d3278892ce1f92a74d6bf888cc8525d9f68af85dbe336c95d1c87fb8f423069" | 6 | SRC_URI[sha256sum] = "5d3278892ce1f92a74d6bf888cc8525d9f68af85dbe336c95d1c87fb8f423069" |
7 | 7 | ||
8 | inherit pypi python_setuptools_build_meta | 8 | inherit pypi python_setuptools_build_meta ptest-python-pytest |
9 | 9 | ||
10 | do_compile:prepend() { | 10 | do_compile:prepend() { |
11 | rm -rf ${S}/evdev/ecodes.c | 11 | rm -rf ${S}/evdev/ecodes.c |