diff options
author | Bartosz Golaszewski <brgl@bgdev.pl> | 2022-05-12 10:41:43 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-05-14 08:17:25 -0700 |
commit | 5ba8fdacdb7480f6f44d328294a7c7a3d034cc9c (patch) | |
tree | f5923aada3806ae03c15f4f5c94a485d42cf2cd9 | |
parent | 6e4ec4b18098928f3e9799f92d7eb8bd2afffe6c (diff) | |
download | meta-openembedded-5ba8fdacdb7480f6f44d328294a7c7a3d034cc9c.tar.gz |
python3-eth-keys: new package
Add a recipe for eth-keys: common API for Ethereum key operations.
Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb | 1 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-eth-keys_0.4.0.bb | 11 |
2 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb index 11de569a9b..41bb24b324 100644 --- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb +++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb | |||
@@ -111,6 +111,7 @@ RDEPENDS:packagegroup-meta-python3 = "\ | |||
111 | python3-engineio \ | 111 | python3-engineio \ |
112 | python3-et-xmlfile \ | 112 | python3-et-xmlfile \ |
113 | python3-eth-hash \ | 113 | python3-eth-hash \ |
114 | python3-eth-keys \ | ||
114 | python3-eth-typing \ | 115 | python3-eth-typing \ |
115 | python3-eth-utils \ | 116 | python3-eth-utils \ |
116 | python3-evdev \ | 117 | python3-evdev \ |
diff --git a/meta-python/recipes-devtools/python/python3-eth-keys_0.4.0.bb b/meta-python/recipes-devtools/python/python3-eth-keys_0.4.0.bb new file mode 100644 index 0000000000..b0b1aad76d --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-eth-keys_0.4.0.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | SUMMARY = "A common API for Ethereum key operations with pluggable backends." | ||
2 | HOMEPAGE = "https://github.com/ethereum/eth-keys" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2beaef1b1764f4d6b46084c885b4bcad" | ||
6 | |||
7 | SRC_URI[sha256sum] = "7d18887483bc9b8a3fdd8e32ddcb30044b9f08fcb24a380d93b6eee3a5bb3216" | ||
8 | |||
9 | inherit pypi setuptools3 | ||
10 | |||
11 | RDEPENDS:${PN} += "python3-eth-utils" | ||