diff options
author | Khem Raj <raj.khem@gmail.com> | 2025-05-03 21:33:01 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-05-04 23:18:21 -0700 |
commit | 5f1e50c437d43ae63ea64df460bec5a7004ff75d (patch) | |
tree | 46dc04ac757d0188026c80cfc4a5fbb8d2074ef0 | |
parent | c97562863f7d57d6e10275a7616a187b7602a44e (diff) | |
download | meta-openembedded-5f1e50c437d43ae63ea64df460bec5a7004ff75d.tar.gz |
python3-icu: Fix build with GCC-15
drop is_trivial check
Fixes
| In file included from bases.cpp:32:
| arg.h:856:37: error: static assertion failed
| 856 | static_assert(std::is_trivial<T>::value); \
| | ~~~~~~~~~~~~~~~~~~~~^~~~~
| arg.h:859:1: note: in expansion of macro '_IS_POD'
| 859 | _IS_POD(AnyPythonObject);
| | ^~~~~~~
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-icu/0001-Remove-assert-checking-for-trivial-type.patch | 26 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-icu_2.15.2.bb | 3 |
2 files changed, 28 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-icu/0001-Remove-assert-checking-for-trivial-type.patch b/meta-python/recipes-devtools/python/python3-icu/0001-Remove-assert-checking-for-trivial-type.patch new file mode 100644 index 0000000000..4c75eb5f7b --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-icu/0001-Remove-assert-checking-for-trivial-type.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From 3d58fb48bb1cef2177aab8e291167638993495f4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 3 May 2025 21:27:34 -0700 | ||
4 | Subject: [PATCH] Remove assert checking for trivial type | ||
5 | |||
6 | This fails with GCC-15, is_trivial is deprecated in C++26 | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | arg.h | 1 - | ||
13 | 1 file changed, 1 deletion(-) | ||
14 | |||
15 | diff --git a/arg.h b/arg.h | ||
16 | index a493d11..6cb232d 100644 | ||
17 | --- a/arg.h | ||
18 | +++ b/arg.h | ||
19 | @@ -853,7 +853,6 @@ public: | ||
20 | }; | ||
21 | |||
22 | #define _IS_POD(T) \ | ||
23 | - static_assert(std::is_trivial<T>::value); \ | ||
24 | static_assert(std::is_standard_layout<T>::value) | ||
25 | |||
26 | _IS_POD(AnyPythonObject); | ||
diff --git a/meta-python/recipes-devtools/python/python3-icu_2.15.2.bb b/meta-python/recipes-devtools/python/python3-icu_2.15.2.bb index 77013330d8..d265a20975 100644 --- a/meta-python/recipes-devtools/python/python3-icu_2.15.2.bb +++ b/meta-python/recipes-devtools/python/python3-icu_2.15.2.bb | |||
@@ -12,7 +12,8 @@ UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}" | |||
12 | 12 | ||
13 | SRC_URI[sha256sum] = "561e77eedff17cec6839f26211f7a5ce3c071b776e8a0ec9d1207f46cbce598f" | 13 | SRC_URI[sha256sum] = "561e77eedff17cec6839f26211f7a5ce3c071b776e8a0ec9d1207f46cbce598f" |
14 | 14 | ||
15 | SRC_URI += "file://0001-Fix-host-contamination-of-include-files.patch" | 15 | SRC_URI += "file://0001-Fix-host-contamination-of-include-files.patch \ |
16 | file://0001-Remove-assert-checking-for-trivial-type.patch" | ||
16 | 17 | ||
17 | inherit pkgconfig pypi python_setuptools_build_meta | 18 | inherit pkgconfig pypi python_setuptools_build_meta |
18 | 19 | ||