summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-09-12 21:57:13 -0700
committerKhem Raj <raj.khem@gmail.com>2024-09-12 23:21:25 -0700
commit6658d465954b10ee28d8a9da56bc5c0c8a819bcc (patch)
treeabfe4909caeafb5b0c9eaeead85144139790c6c6
parentcb1c641b0f790a09795b044c3a71fc29268a209f (diff)
downloadmeta-openembedded-6658d465954b10ee28d8a9da56bc5c0c8a819bcc.tar.gz
python3-fsspec: Add recipe
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-fsspec_2024.9.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-fsspec_2024.9.0.bb b/meta-python/recipes-devtools/python/python3-fsspec_2024.9.0.bb
new file mode 100644
index 0000000000..49ca4b3e93
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-fsspec_2024.9.0.bb
@@ -0,0 +1,22 @@
1SUMMARY = "A specification that python filesystems should adhere to."
2HOMEPAGE = "https://github.com/fsspec/filesystem_spec"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b38a11bf4dcdfc66307f8515ce1fbaa6"
5
6DEPENDS = "python3-hatch-vcs-native python3-hatchling-native"
7SRC_URI[sha256sum] = "4b0afb90c2f21832df142f292649035d80b421f60a9e1c027802e5a0da2b04e8"
8
9inherit pypi python_hatchling ptest
10
11PYPI_PACKAGE = "fsspec"
12
13RDEPENDS:${PN}-ptest += "\
14 python3-pytest \
15 python3-pytest-mock \
16 python3-pytest-asyncio \
17 python3-pytest-cov \
18 python3-pytest-benchmark \
19 python3-aiohttp \
20 python3-numpy \
21 python3-requests \
22"