diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-07-06 15:44:48 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-07-07 10:26:37 -0400 |
commit | 71091b064430ad262a7b100596d296b216e36d11 (patch) | |
tree | 99ecfe689cff9fc2a885c92394f6c960e421d25a | |
parent | 8e1c900eff54c50c9a5137d804a9c5ce6923c292 (diff) | |
download | meta-openembedded-71091b064430ad262a7b100596d296b216e36d11.tar.gz |
opencv: Link with libatomic on mips
Fixes linking errors e.g.
parallel.cpp:(.text._ZN3tbb6detail2d19start_forINS1_13blocked_rangeIiEEN2cv12_GLOBAL__N_113ProxyLoopBodyEKNS1_16auto_partitionerEE8finalizeERKNS1_14execution_dataE+0xe8): undefined reference to `__atomic_fetch_add_8'
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv_4.6.0.bb | 2 |
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_4.6.0.bb b/meta-oe/recipes-support/opencv/opencv_4.6.0.bb index 46f9237753..cbac75e0bd 100644 --- a/meta-oe/recipes-support/opencv/opencv_4.6.0.bb +++ b/meta-oe/recipes-support/opencv/opencv_4.6.0.bb | |||
@@ -99,6 +99,8 @@ EXTRA_OECMAKE = "-DOPENCV_EXTRA_MODULES_PATH=${WORKDIR}/contrib/modules \ | |||
99 | ${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.1", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1 -DENABLE_SSE41=1", "", d)} \ | 99 | ${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.1", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1 -DENABLE_SSE41=1", "", d)} \ |
100 | ${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.2", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1 -DENABLE_SSE41=1 -DENABLE_SSE42=1", "", d)} \ | 100 | ${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.2", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1 -DENABLE_SSE41=1 -DENABLE_SSE42=1", "", d)} \ |
101 | " | 101 | " |
102 | LDFLAGS:append:mips = " -Wl,--no-as-needed -latomic -Wl,--as-needed" | ||
103 | |||
102 | EXTRA_OECMAKE:append:x86 = " -DX86=ON" | 104 | EXTRA_OECMAKE:append:x86 = " -DX86=ON" |
103 | # disable sse4.1 and sse4.2 to fix 32bit build failure | 105 | # disable sse4.1 and sse4.2 to fix 32bit build failure |
104 | # https://github.com/opencv/opencv/issues/21597 | 106 | # https://github.com/opencv/opencv/issues/21597 |