diff options
author | Gary Thomas <gary@mlbassoc.com> | 2015-10-09 06:55:01 -0600 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-10-23 12:53:25 +0200 |
commit | 77582ef1bedd7c36c6aa708ffd474d613e55ad9d (patch) | |
tree | 5b6b95da48f4f4875f7efb694ac509819b13f9c1 | |
parent | 9dc7608a0cce8c845d2747fc0e55cc14e369d665 (diff) | |
download | meta-openembedded-77582ef1bedd7c36c6aa708ffd474d613e55ad9d.tar.gz |
poppler: Support building against QT4-embedded
These changes allow the poppler package to build using qt4e.
To enable them, add this line to local.conf
PACKAGECONFIG_append_pn-poppler = " qt4e"
Signed-off-by: Gary Thomas <gary@mlbassoc.com>
Upstream-status: Innapropriate [OE configuration]
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler-0.35.0/fix-qt4e-library-dependencies.patch | 28 | ||||
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler_0.35.0.bb | 6 |
2 files changed, 33 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler-0.35.0/fix-qt4e-library-dependencies.patch b/meta-oe/recipes-support/poppler/poppler-0.35.0/fix-qt4e-library-dependencies.patch new file mode 100644 index 0000000000..f67e1f5039 --- /dev/null +++ b/meta-oe/recipes-support/poppler/poppler-0.35.0/fix-qt4e-library-dependencies.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | Configuration changes needed to allow building with QT4-embedded | ||
2 | |||
3 | Index: poppler-0.35.0/configure.ac | ||
4 | =================================================================== | ||
5 | --- poppler-0.35.0.orig/configure.ac | ||
6 | +++ poppler-0.35.0/configure.ac | ||
7 | @@ -654,17 +654,17 @@ AC_ARG_ENABLE(poppler-qt4, | ||
8 | enable_poppler_qt4="try") | ||
9 | if test x$enable_poppler_qt4 = xyes; then | ||
10 | PKG_CHECK_MODULES(POPPLER_QT4, | ||
11 | - QtCore >= 4.7.0 QtGui >= 4.7.0 QtXml >= 4.7.0) | ||
12 | + QtCoreE >= 4.7.0 QtGuiE >= 4.7.0 QtXmlE >= 4.7.0) | ||
13 | PKG_CHECK_MODULES(POPPLER_QT4_TEST, | ||
14 | - QtTest >= 4.7.0) | ||
15 | + QtTestE >= 4.7.0) | ||
16 | elif test x$enable_poppler_qt4 = xtry; then | ||
17 | PKG_CHECK_MODULES(POPPLER_QT4, | ||
18 | - QtCore >= 4.7.0 QtGui >= 4.7.0 QtXml >= 4.7.0, | ||
19 | + QtCoreE >= 4.7.0 QtGuiE >= 4.7.0 QtXmlE >= 4.7.0, | ||
20 | [enable_poppler_qt4="yes"], | ||
21 | [enable_poppler_qt4="no"]) | ||
22 | if test x$enable_poppler_qt4 = xyes; then | ||
23 | PKG_CHECK_MODULES(POPPLER_QT4_TEST, | ||
24 | - QtTest >= 4.7.0, | ||
25 | + QtTestE >= 4.7.0, | ||
26 | [enable_poppler_qt4="yes"], | ||
27 | [enable_poppler_qt4="no"]) | ||
28 | fi | ||
diff --git a/meta-oe/recipes-support/poppler/poppler_0.35.0.bb b/meta-oe/recipes-support/poppler/poppler_0.35.0.bb index 520aa6b6a1..efb7241284 100644 --- a/meta-oe/recipes-support/poppler/poppler_0.35.0.bb +++ b/meta-oe/recipes-support/poppler/poppler_0.35.0.bb | |||
@@ -20,14 +20,18 @@ PACKAGECONFIG[tiff] = "--enable-libtiff,--disable-libtiff,tiff" | |||
20 | PACKAGECONFIG[curl] = "--enable-libcurl,--disable-libcurl,curl" | 20 | PACKAGECONFIG[curl] = "--enable-libcurl,--disable-libcurl,curl" |
21 | PACKAGECONFIG[openjpeg] = "--enable-libopenjpeg=openjpeg2,--disable-libopenjpeg,openjpeg" | 21 | PACKAGECONFIG[openjpeg] = "--enable-libopenjpeg=openjpeg2,--disable-libopenjpeg,openjpeg" |
22 | PACKAGECONFIG[qt5] = "--enable-poppler-qt5 --with-moc-qt5=${STAGING_BINDIR_NATIVE}/qt5/moc,--disable-poppler-qt5,qtbase" | 22 | PACKAGECONFIG[qt5] = "--enable-poppler-qt5 --with-moc-qt5=${STAGING_BINDIR_NATIVE}/qt5/moc,--disable-poppler-qt5,qtbase" |
23 | PACKAGECONFIG[qt4e] = "--enable-poppler-qt4 --with-moc-qt4=${STAGING_BINDIR_NATIVE}/moc4,--disable-poppler-qt4,qt4-embedded" | ||
23 | 24 | ||
24 | EXTRA_OECONF = "\ | 25 | EXTRA_OECONF = "\ |
25 | --enable-xpdf-headers \ | 26 | --enable-xpdf-headers \ |
26 | --disable-gtk-test \ | 27 | --disable-gtk-test \ |
27 | --disable-poppler-qt4 \ | ||
28 | --enable-zlib \ | 28 | --enable-zlib \ |
29 | " | 29 | " |
30 | 30 | ||
31 | # Adjust library names when building for QT4e | ||
32 | QT4E_PATCHES = "${@bb.utils.contains('PACKAGECONFIG', 'qt4e', 'file://fix-qt4e-library-dependencies.patch', '', d)}" | ||
33 | SRC_URI_append = "${QT4E_PATCHES}" | ||
34 | |||
31 | # check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points | 35 | # check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points |
32 | def get_poppler_fpu_setting(bb, d): | 36 | def get_poppler_fpu_setting(bb, d): |
33 | if d.getVar('TARGET_FPU', 1) in [ 'soft' ]: | 37 | if d.getVar('TARGET_FPU', 1) in [ 'soft' ]: |