diff options
author | Derek Straka <derek@asterius.io> | 2025-01-30 21:57:38 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-01-30 14:15:37 -0800 |
commit | 82b0c7943e6fb695b6c5cb90f04bd7470acf326f (patch) | |
tree | 91b445b4dd10844ce07d91cfc59ebedfc608de4d | |
parent | 3ac7852b9b8901b78424368e16cf8aea716ee7ec (diff) | |
download | meta-openembedded-82b0c7943e6fb695b6c5cb90f04bd7470acf326f.tar.gz |
python3-dominate: update recipe to use the ptest-python-pytest class
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-dominate/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-dominate_2.9.1.bb | 13 |
2 files changed, 1 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dominate/run-ptest b/meta-python/recipes-devtools/python/python3-dominate/run-ptest deleted file mode 100644 index 8d2017d39c..0000000000 --- a/meta-python/recipes-devtools/python/python3-dominate/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-dominate_2.9.1.bb b/meta-python/recipes-devtools/python/python3-dominate_2.9.1.bb index cce304498a..a0dd638087 100644 --- a/meta-python/recipes-devtools/python/python3-dominate_2.9.1.bb +++ b/meta-python/recipes-devtools/python/python3-dominate_2.9.1.bb | |||
@@ -4,23 +4,12 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b52f2d57d10c4f7ee67a7eb9615d5d24" | |||
4 | 4 | ||
5 | SRC_URI[sha256sum] = "558284687d9b8aae1904e3d6051ad132dd4a8c0cf551b37ea4e7e42a31d19dc4" | 5 | SRC_URI[sha256sum] = "558284687d9b8aae1904e3d6051ad132dd4a8c0cf551b37ea4e7e42a31d19dc4" |
6 | 6 | ||
7 | inherit pypi ptest python_setuptools_build_meta | 7 | inherit pypi ptest-python-pytest python_setuptools_build_meta |
8 | 8 | ||
9 | SRC_URI += " \ | 9 | SRC_URI += " \ |
10 | file://58f7d7fdb171f80ed6ce97e6ca4409723975c47f.patch \ | 10 | file://58f7d7fdb171f80ed6ce97e6ca4409723975c47f.patch \ |
11 | file://run-ptest \ | ||
12 | " | 11 | " |
13 | 12 | ||
14 | RDEPENDS:${PN}-ptest += " \ | ||
15 | python3-pytest \ | ||
16 | python3-unittest-automake-output \ | ||
17 | " | ||
18 | |||
19 | do_install_ptest() { | ||
20 | install -d ${D}${PTEST_PATH}/tests | ||
21 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
22 | } | ||
23 | |||
24 | RDEPENDS:${PN} += "\ | 13 | RDEPENDS:${PN} += "\ |
25 | python3-numbers \ | 14 | python3-numbers \ |
26 | python3-threading \ | 15 | python3-threading \ |