diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-05-26 22:01:24 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-05-28 06:55:33 -0700 |
commit | 89406f918d38c550403c7ce99cf146ba4ce808a3 (patch) | |
tree | be1a295d35736074da902da5eb1a646c2b09c3ca | |
parent | 827f51176517219b9d0f7f6783970edc9079a5a5 (diff) | |
download | meta-openembedded-89406f918d38c550403c7ce99cf146ba4ce808a3.tar.gz |
projucer: Update to latest master tip
Drop patch which no longer is needed as it has been fixed differently
upstream
License-Update: Updated to reflect JUCE 6 Terms [1]
[1] https://github.com/juce-framework/JUCE/commit/de6ecc57f84294e82a608bcc6d0f5d11645f15e3#diff-4673a3aba01813b595de187a7a6e9e63a3491d55821606fecd9f13a10c188a1d
Signed-off-by: Khem Raj <raj.khem@gmail.com>
3 files changed, 44 insertions, 87 deletions
diff --git a/meta-multimedia/recipes-multimedia/juce/projucer.inc b/meta-multimedia/recipes-multimedia/juce/projucer.inc index ab0f23879f..9f03cbd80f 100644 --- a/meta-multimedia/recipes-multimedia/juce/projucer.inc +++ b/meta-multimedia/recipes-multimedia/juce/projucer.inc | |||
@@ -4,7 +4,7 @@ JUCE supported platforms, including Linux and Embedded Linux." | |||
4 | SECTION = "utils" | 4 | SECTION = "utils" |
5 | HOMEPAGE = "http://juce.com/" | 5 | HOMEPAGE = "http://juce.com/" |
6 | LICENSE = "GPLv3" | 6 | LICENSE = "GPLv3" |
7 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a20f91622a47d4e4af9340d5d3f1a2d8" | 7 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=12e9c2db7897c0349a4cc1c6d2a8c5d5" |
8 | 8 | ||
9 | inherit pkgconfig features_check | 9 | inherit pkgconfig features_check |
10 | 10 | ||
@@ -13,14 +13,13 @@ REQUIRED_DISTRO_FEATURES = "x11" | |||
13 | DEPENDS = "libx11 libxext libxinerama libxrandr libxcursor freetype alsa-lib curl bzip2 libpng harfbuzz glib-2.0 libpcre" | 13 | DEPENDS = "libx11 libxext libxinerama libxrandr libxcursor freetype alsa-lib curl bzip2 libpng harfbuzz glib-2.0 libpcre" |
14 | DEPENDS_append_libc-musl = " libexecinfo" | 14 | DEPENDS_append_libc-musl = " libexecinfo" |
15 | 15 | ||
16 | SRCREV = "724ae27c71ef809b836df06713cf9e50bc14162b" | 16 | SRCREV = "90e8da0cfb54ac593cdbed74c3d0c9b09bad3a9f" |
17 | BRANCH = "master" | 17 | BRANCH = "master" |
18 | SRC_URI = "git://github.com/WeAreROLI/JUCE.git;protocol=https;branch=${BRANCH} \ | 18 | SRC_URI = "git://github.com/WeAreROLI/JUCE.git;protocol=https;branch=${BRANCH} \ |
19 | file://0001-Disable-webkit-component.patch \ | ||
20 | " | 19 | " |
21 | 20 | ||
22 | S = "${WORKDIR}/git" | 21 | S = "${WORKDIR}/git" |
23 | PV = "5.4.5" | 22 | PV = "6.0.8" |
24 | 23 | ||
25 | JUCE_PROJUCER_BUILD_PATH = "${B}/extras/Projucer/Builds" | 24 | JUCE_PROJUCER_BUILD_PATH = "${B}/extras/Projucer/Builds" |
26 | JUCE_PROJUCER_MAKEFILE_PATH = "${JUCE_PROJUCER_BUILD_PATH}/LinuxMakefile" | 25 | JUCE_PROJUCER_MAKEFILE_PATH = "${JUCE_PROJUCER_BUILD_PATH}/LinuxMakefile" |
diff --git a/meta-multimedia/recipes-multimedia/juce/projucer/0001-Disable-webkit-component.patch b/meta-multimedia/recipes-multimedia/juce/projucer/0001-Disable-webkit-component.patch deleted file mode 100644 index 3728439c71..0000000000 --- a/meta-multimedia/recipes-multimedia/juce/projucer/0001-Disable-webkit-component.patch +++ /dev/null | |||
@@ -1,83 +0,0 @@ | |||
1 | From df7190f430f30ee522f56f9714d42ee796f0d5ff Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 2 Dec 2019 22:18:41 -0800 | ||
4 | Subject: [PATCH] Disable webkit component | ||
5 | |||
6 | It asks for enable JUCER_ENABLE_GPL_MODE | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | extras/Projucer/Builds/LinuxMakefile/Makefile | 10 +++++----- | ||
11 | extras/Projucer/JuceLibraryCode/AppConfig.h | 4 ++-- | ||
12 | 2 files changed, 7 insertions(+), 7 deletions(-) | ||
13 | |||
14 | diff --git a/extras/Projucer/Builds/LinuxMakefile/Makefile b/extras/Projucer/Builds/LinuxMakefile/Makefile | ||
15 | index 25b490460..8960f5bc6 100644 | ||
16 | --- a/extras/Projucer/Builds/LinuxMakefile/Makefile | ||
17 | +++ b/extras/Projucer/Builds/LinuxMakefile/Makefile | ||
18 | @@ -35,13 +35,13 @@ ifeq ($(CONFIG),Debug) | ||
19 | TARGET_ARCH := -march=native | ||
20 | endif | ||
21 | |||
22 | - JUCE_CPPFLAGS := $(DEPFLAGS) -DLINUX=1 -DDEBUG=1 -D_DEBUG=1 -DJUCER_LINUX_MAKE_6D53C8B4=1 -DJUCE_APP_VERSION=5.4.5 -DJUCE_APP_VERSION_HEX=0x50405 $(shell pkg-config --cflags x11 xinerama xext freetype2 webkit2gtk-4.0 gtk+-x11-3.0) -pthread -I../../JuceLibraryCode -I../../../../modules $(CPPFLAGS) | ||
23 | + JUCE_CPPFLAGS := $(DEPFLAGS) -DLINUX=1 -DDEBUG=1 -D_DEBUG=1 -DJUCER_LINUX_MAKE_6D53C8B4=1 -DJUCE_APP_VERSION=5.4.5 -DJUCE_APP_VERSION_HEX=0x50405 $(shell pkg-config --cflags x11 xinerama xext freetype2) -pthread -I../../JuceLibraryCode -I../../../../modules $(CPPFLAGS) | ||
24 | JUCE_CPPFLAGS_APP := -DJucePlugin_Build_VST=0 -DJucePlugin_Build_VST3=0 -DJucePlugin_Build_AU=0 -DJucePlugin_Build_AUv3=0 -DJucePlugin_Build_RTAS=0 -DJucePlugin_Build_AAX=0 -DJucePlugin_Build_Standalone=0 -DJucePlugin_Build_Unity=0 | ||
25 | JUCE_TARGET_APP := Projucer | ||
26 | |||
27 | JUCE_CFLAGS += $(JUCE_CPPFLAGS) $(TARGET_ARCH) -g -ggdb -O0 $(CFLAGS) | ||
28 | JUCE_CXXFLAGS += $(JUCE_CFLAGS) -std=c++11 $(CXXFLAGS) | ||
29 | - JUCE_LDFLAGS += $(TARGET_ARCH) -L$(JUCE_BINDIR) -L$(JUCE_LIBDIR) $(shell pkg-config --libs x11 xinerama xext freetype2 webkit2gtk-4.0 gtk+-x11-3.0) -lrt -ldl -lpthread $(LDFLAGS) | ||
30 | + JUCE_LDFLAGS += $(TARGET_ARCH) -L$(JUCE_BINDIR) -L$(JUCE_LIBDIR) $(shell pkg-config --libs x11 xinerama xext freetype2) -lrt -ldl -lpthread $(LDFLAGS) | ||
31 | |||
32 | CLEANCMD = rm -rf $(JUCE_OUTDIR)/$(TARGET) $(JUCE_OBJDIR) | ||
33 | endif | ||
34 | @@ -56,13 +56,13 @@ ifeq ($(CONFIG),Release) | ||
35 | TARGET_ARCH := -march=native | ||
36 | endif | ||
37 | |||
38 | - JUCE_CPPFLAGS := $(DEPFLAGS) -DLINUX=1 -DNDEBUG=1 -DJUCER_LINUX_MAKE_6D53C8B4=1 -DJUCE_APP_VERSION=5.4.5 -DJUCE_APP_VERSION_HEX=0x50405 $(shell pkg-config --cflags x11 xinerama xext freetype2 webkit2gtk-4.0 gtk+-x11-3.0) -pthread -I../../JuceLibraryCode -I../../../../modules $(CPPFLAGS) | ||
39 | + JUCE_CPPFLAGS := $(DEPFLAGS) -DLINUX=1 -DNDEBUG=1 -DJUCER_LINUX_MAKE_6D53C8B4=1 -DJUCE_APP_VERSION=5.4.5 -DJUCE_APP_VERSION_HEX=0x50405 $(shell pkg-config --cflags x11 xinerama xext freetype2) -pthread -I../../JuceLibraryCode -I../../../../modules $(CPPFLAGS) | ||
40 | JUCE_CPPFLAGS_APP := -DJucePlugin_Build_VST=0 -DJucePlugin_Build_VST3=0 -DJucePlugin_Build_AU=0 -DJucePlugin_Build_AUv3=0 -DJucePlugin_Build_RTAS=0 -DJucePlugin_Build_AAX=0 -DJucePlugin_Build_Standalone=0 -DJucePlugin_Build_Unity=0 | ||
41 | JUCE_TARGET_APP := Projucer | ||
42 | |||
43 | JUCE_CFLAGS += $(JUCE_CPPFLAGS) $(TARGET_ARCH) -O3 $(CFLAGS) | ||
44 | JUCE_CXXFLAGS += $(JUCE_CFLAGS) -std=c++11 $(CXXFLAGS) | ||
45 | - JUCE_LDFLAGS += $(TARGET_ARCH) -L$(JUCE_BINDIR) -L$(JUCE_LIBDIR) $(shell pkg-config --libs x11 xinerama xext freetype2 webkit2gtk-4.0 gtk+-x11-3.0) -fvisibility=hidden -lrt -ldl -lpthread $(LDFLAGS) | ||
46 | + JUCE_LDFLAGS += $(TARGET_ARCH) -L$(JUCE_BINDIR) -L$(JUCE_LIBDIR) $(shell pkg-config --libs x11 xinerama xext freetype2) -fvisibility=hidden -lrt -ldl -lpthread $(LDFLAGS) | ||
47 | |||
48 | CLEANCMD = rm -rf $(JUCE_OUTDIR)/$(TARGET) $(JUCE_OBJDIR) | ||
49 | endif | ||
50 | @@ -136,7 +136,7 @@ all : $(JUCE_OUTDIR)/$(JUCE_TARGET_APP) | ||
51 | |||
52 | $(JUCE_OUTDIR)/$(JUCE_TARGET_APP) : $(OBJECTS_APP) $(RESOURCES) | ||
53 | @command -v pkg-config >/dev/null 2>&1 || { echo >&2 "pkg-config not installed. Please, install it."; exit 1; } | ||
54 | - @pkg-config --print-errors x11 xinerama xext freetype2 webkit2gtk-4.0 gtk+-x11-3.0 | ||
55 | + @pkg-config --print-errors x11 xinerama xext freetype2 | ||
56 | @echo Linking "Projucer - App" | ||
57 | -$(V_AT)mkdir -p $(JUCE_BINDIR) | ||
58 | -$(V_AT)mkdir -p $(JUCE_LIBDIR) | ||
59 | diff --git a/extras/Projucer/JuceLibraryCode/AppConfig.h b/extras/Projucer/JuceLibraryCode/AppConfig.h | ||
60 | index dffd5af75..53302bd24 100644 | ||
61 | --- a/extras/Projucer/JuceLibraryCode/AppConfig.h | ||
62 | +++ b/extras/Projucer/JuceLibraryCode/AppConfig.h | ||
63 | @@ -32,7 +32,7 @@ | ||
64 | // BEGIN SECTION A | ||
65 | |||
66 | #ifndef JUCER_ENABLE_GPL_MODE | ||
67 | - #define JUCER_ENABLE_GPL_MODE 0 | ||
68 | + #define JUCER_ENABLE_GPL_MODE 1 | ||
69 | #endif | ||
70 | |||
71 | // END SECTION A | ||
72 | @@ -180,7 +180,7 @@ | ||
73 | // juce_gui_extra flags: | ||
74 | |||
75 | #ifndef JUCE_WEB_BROWSER | ||
76 | - //#define JUCE_WEB_BROWSER 1 | ||
77 | + #define JUCE_WEB_BROWSER 0 | ||
78 | #endif | ||
79 | |||
80 | #ifndef JUCE_ENABLE_LIVE_CONSTANT_EDITOR | ||
81 | -- | ||
82 | 2.24.0 | ||
83 | |||
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-0.8.3/0001-test-Check-for-googletest-on-system-first.patch b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-0.8.3/0001-test-Check-for-googletest-on-system-first.patch new file mode 100644 index 0000000000..8a6aceac87 --- /dev/null +++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-0.8.3/0001-test-Check-for-googletest-on-system-first.patch | |||
@@ -0,0 +1,41 @@ | |||
1 | From dc5fa7a4b342ef80cda533cdb821841d8183287c Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 23 May 2021 09:01:09 -0700 | ||
4 | Subject: [PATCH] test: Check for googletest on system first | ||
5 | |||
6 | This ensures if googletest is instslled already then use that version | ||
7 | before downloading and building own copy | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | tests/CMakeLists.txt | 6 +++++- | ||
13 | 1 file changed, 5 insertions(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt | ||
16 | index 97f7c1a..3dfdd1c 100644 | ||
17 | --- a/tests/CMakeLists.txt | ||
18 | +++ b/tests/CMakeLists.txt | ||
19 | @@ -2,6 +2,10 @@ | ||
20 | # DOWNLOAD AND BUILD OF GOOGLETEST | ||
21 | #------------------------------- | ||
22 | |||
23 | +find_package(GTest) | ||
24 | + | ||
25 | +if(NOT GTest_FOUND) | ||
26 | + | ||
27 | include(FetchContent) | ||
28 | |||
29 | message("Fetching googletest...") | ||
30 | @@ -23,7 +27,7 @@ if(NOT googletest_POPULATED) | ||
31 | add_subdirectory(${googletest_SOURCE_DIR} ${googletest_BINARY_DIR}) | ||
32 | set(BUILD_SHARED_LIBS ${BUILD_SHARED_LIBS_BAK}) | ||
33 | endif() | ||
34 | - | ||
35 | +endif() | ||
36 | #------------------------------- | ||
37 | # SOURCE FILES CONFIGURATION | ||
38 | #------------------------------- | ||
39 | -- | ||
40 | 2.31.1 | ||
41 | |||