diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-01-29 20:53:42 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-01-29 21:09:39 -0800 |
commit | 94e34a6d910a0c6c2b3df6f45e6711e50564d68c (patch) | |
tree | 51a5fbb83434a71a4fa6f36aed2afad88cd1d8ec | |
parent | 7c82652b2a0f254d83a4629251af5272fd05f4b2 (diff) | |
download | meta-openembedded-94e34a6d910a0c6c2b3df6f45e6711e50564d68c.tar.gz |
mongodb: Pass MAXLINELENGTH to scons invocation
This helps in overcoming a problem when using scons with ccache enabled.
When commands get longer, then it resorts to using response files to do
the operations e.g. @/tmp/tmp96j6icra.lnk when this response file is
inboked by compiler it works ok, however, this does not when ccache is
used to invoke the complilation. We see errors e.g.
ccache @/tmp/tmppsyij_0v.lnk
ccache: error: execute_noreturn of @/tmp/tmppsyij_0v.lnk failed: No such file or directory
Using MAXLINELENGTH setting ensures that we can use ARG_MAX to extend
the length of commandline and hence avoid using response files. This
issue is also reported in mongodb [1]
[1] https://jira.mongodb.org/browse/SERVER-38389
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb | 1 |
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb index 524f0fc90c..56512a2e2e 100644 --- a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb +++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb | |||
@@ -76,6 +76,7 @@ WIREDTIGER:aarch64 = "on" | |||
76 | 76 | ||
77 | EXTRA_OESCONS = "PREFIX=${prefix} \ | 77 | EXTRA_OESCONS = "PREFIX=${prefix} \ |
78 | DESTDIR=${D} \ | 78 | DESTDIR=${D} \ |
79 | MAXLINELENGTH='2097152' \ | ||
79 | LIBPATH=${STAGING_LIBDIR} \ | 80 | LIBPATH=${STAGING_LIBDIR} \ |
80 | LINKFLAGS='${LDFLAGS}' \ | 81 | LINKFLAGS='${LDFLAGS}' \ |
81 | CXXFLAGS='${CXXFLAGS}' \ | 82 | CXXFLAGS='${CXXFLAGS}' \ |