diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2022-09-20 13:02:08 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-09-21 06:34:45 -0700 |
commit | 9d03f96bb18ce3cbe5902d2d0ae95b2fe5143e8c (patch) | |
tree | 0ba061b02dbb2b5e3dfb460e518a8ece6dd0586c | |
parent | 1a2556e97debf5d386d362f87060aa25a52b2718 (diff) | |
download | meta-openembedded-9d03f96bb18ce3cbe5902d2d0ae95b2fe5143e8c.tar.gz |
python3-termcolor: Upgrade 1.1.0 -> 2.0.1
Upgrade to release 2.0.1:
- Add support for Python 3.11 and PyPy
- Add support for Python 3.10
- Add type annotations to the project and run mypy on CI
- Add tests
- Refer to GitHub Releases for release notes for 2.0.0+
- Autodeploy to TestPyPI and to PyPI for GH releases
- Migrate from setuptools + setuptools_scm to hatchling + hatch-vcs
- Replace deprecated license_file with license_files in setup.cfg
- Use declarative metadata in setup.cfg
- Replace 3.9-dev with 3.9 in CI to use Python 3.9 final
- Drop support for EOL Python <= 3.6
- Remove hardcoded VERSION constant
- Update source URL
License-Update: Removed new line from the end of license file.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
3 files changed, 16 insertions, 40 deletions
diff --git a/meta-python/recipes-devtools/python/python3-termcolor/0001-setup.py-Use-setuptools-instead-of-distutils.patch b/meta-python/recipes-devtools/python/python3-termcolor/0001-setup.py-Use-setuptools-instead-of-distutils.patch deleted file mode 100644 index a55a6a914b..0000000000 --- a/meta-python/recipes-devtools/python/python3-termcolor/0001-setup.py-Use-setuptools-instead-of-distutils.patch +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | From e30308284c721210e2ba50d8b3d159cedf5eada8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 28 Feb 2022 14:44:42 -0800 | ||
4 | Subject: [PATCH] setup.py: Use setuptools instead of distutils | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | setup.py | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/setup.py b/setup.py | ||
13 | index c4fe4ed..dad1d29 100755 | ||
14 | --- a/setup.py | ||
15 | +++ b/setup.py | ||
16 | @@ -23,7 +23,7 @@ | ||
17 | # Author: Konstantin Lepa <konstantin.lepa@gmail.com> | ||
18 | |||
19 | import os | ||
20 | -from distutils.core import setup | ||
21 | +from setuptools import setup | ||
22 | |||
23 | prjdir = os.path.dirname(__file__) | ||
24 | |||
25 | -- | ||
26 | 2.35.1 | ||
27 | |||
diff --git a/meta-python/recipes-devtools/python/python3-termcolor_1.1.0.bb b/meta-python/recipes-devtools/python/python3-termcolor_1.1.0.bb deleted file mode 100644 index 15bab622a6..0000000000 --- a/meta-python/recipes-devtools/python/python3-termcolor_1.1.0.bb +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | SUMMARY = "ANSII Color formatting for output in terminal" | ||
2 | HOMEPAGE = "https://pypi.python.org/pypi/termcolor" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=809e8749b63567978acfbd81d9f6a27d" | ||
6 | |||
7 | inherit pypi setuptools3 | ||
8 | |||
9 | SRC_URI += "file://0001-setup.py-Use-setuptools-instead-of-distutils.patch" | ||
10 | |||
11 | SRC_URI[sha256sum] = "1d6d69ce66211143803fbc56652b41d73b4a400a2891d7bf7a1cdf4c02de613b" | ||
12 | |||
13 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-python/recipes-devtools/python/python3-termcolor_2.0.1.bb b/meta-python/recipes-devtools/python/python3-termcolor_2.0.1.bb new file mode 100644 index 0000000000..47f7938f16 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-termcolor_2.0.1.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | SUMMARY = "ANSII Color formatting for output in terminal" | ||
2 | HOMEPAGE = "https://pypi.python.org/pypi/termcolor" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=e5f5f7c9b280511f124dba5dda3d180e" | ||
6 | |||
7 | inherit pypi python_setuptools_build_meta | ||
8 | |||
9 | SRC_URI[sha256sum] = "6b2cf769e93364a2676e1de56a7c0cff2cf5bd07f37e9cc80b0dd6320ebfe388" | ||
10 | |||
11 | DEPENDS += " \ | ||
12 | ${PYTHON_PN}-toml-native \ | ||
13 | ${PYTHON_PN}-hatch-vcs-native \ | ||
14 | " | ||
15 | |||
16 | BBCLASSEXTEND = "native" | ||