summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJugurtha BELKALEM <jugurtha.belkalem@smile.fr>2020-08-28 09:10:59 +0200
committerKhem Raj <raj.khem@gmail.com>2020-08-28 17:16:57 -0700
commita100cce1fcaa53f7f888ae11a95227d66ff1034d (patch)
tree3096313cd3f12138b7f6033823bf5b5013e284d6
parent0a27b0840f57d64cab091c9a0681582832d72c2d (diff)
downloadmeta-openembedded-a100cce1fcaa53f7f888ae11a95227d66ff1034d.tar.gz
recipe/ettercap : new ettercap recipe
Ettercap is a comprehensive suite for man in the middle attacks. It features sniffing of live connections, content filtering on the fly and many other interesting tricks. It supports active and passive dissection of many protocols and includes many features for network and host analysis. To test ettercap : $ ettercap -T -i eth0 # Text mode or $ ettercap -C -i eth0 # console based mode Signed-off-by: Jugurtha BELKALEM <jugurtha.belkalem@smile.fr> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/ettercap/ettercap_0.8.3.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ettercap/ettercap_0.8.3.1.bb b/meta-networking/recipes-support/ettercap/ettercap_0.8.3.1.bb
new file mode 100644
index 0000000000..c641c265e2
--- /dev/null
+++ b/meta-networking/recipes-support/ettercap/ettercap_0.8.3.1.bb
@@ -0,0 +1,42 @@
1SUMMARY = "A suite for man in the middle attacks"
2HOMEPAGE = "https://github.com/Ettercap/ettercap"
3LICENSE = "GPL-2.0+"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6inherit cmake
7
8DEPENDS += "ethtool \
9 geoip \
10 librepo \
11 libnet \
12 libpcap \
13 ncurses \
14 openssl \
15 zlib \
16 bison-native \
17 flex-native \
18 "
19
20RDEPENDS_${PN} += "bash ethtool libgcc"
21
22SRC_URI = "gitsm://github.com/Ettercap/ettercap"
23
24SRCREV = "7281fbddb7da7478beb1d21e3cb105fff3778b31"
25
26S = "${WORKDIR}/git"
27
28EXTRA_OECMAKE = " \
29 -DCMAKE_SKIP_RPATH=TRUE \
30 -DBUNDLED_LIBS=ON \
31 -DENABLE_IPV6=ON \
32 -DENABLE_GTK=OFF \
33"
34
35# Replaces default encoding set (ISO-8859-1) with UTF-8 in ettercap
36# configuration file installed by the package.
37# It ensures that all characters are properly decoded and avoids
38# any fatal errors while running in text mode (-T).
39do_install_append() {
40 sed -i 's@utf8_encoding.*@utf8_encoding = "UTF-8"@g' \
41 ${D}/etc/ettercap/etter.conf
42}