diff options
author | Dmitry Baryshkov <dmitry.baryshkov@linaro.org> | 2024-09-13 13:17:26 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-09-13 11:30:12 -0700 |
commit | a31ee04e75e30f3ca4822b0bc8f58f37f1cc0d45 (patch) | |
tree | 5246d94a685d2cf9ad86ac6adcea7cc5fa550216 | |
parent | 572e183e5f32353071c52731e2068eab584b8dff (diff) | |
download | meta-openembedded-a31ee04e75e30f3ca4822b0bc8f58f37f1cc0d45.tar.gz |
gpsd: apply patch to fix gpsd building on Musl
Import the patch from pending MR to fix the way flags are being handled
by SConsript. Otherwise CXXFLAGS being added to CCFLAGS, masking test
results because of the -fvisibility-inlines-hidden warning turning into
error.
Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-navigation/gpsd/gpsd/fix-pps_strerror_r.patch | 51 | ||||
-rw-r--r-- | meta-oe/recipes-navigation/gpsd/gpsd_3.25.bb | 1 |
2 files changed, 52 insertions, 0 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd/fix-pps_strerror_r.patch b/meta-oe/recipes-navigation/gpsd/gpsd/fix-pps_strerror_r.patch new file mode 100644 index 0000000000..8942b39524 --- /dev/null +++ b/meta-oe/recipes-navigation/gpsd/gpsd/fix-pps_strerror_r.patch | |||
@@ -0,0 +1,51 @@ | |||
1 | From c72a489e2eb13296c7b514b7341033114abf430a Mon Sep 17 00:00:00 2001 | ||
2 | From: Miroslav Lichvar <mlichvar@redhat.com> | ||
3 | Date: Mon, 22 Apr 2024 11:31:24 +0200 | ||
4 | Subject: [PATCH 1/2] SConscript: provide variable names to MergeFlags | ||
5 | |||
6 | If the scons MergeFlags() function is provided with a list of | ||
7 | compiler/linker options, it needs to guess what options belong where. If | ||
8 | it doesn't recognize an option, it is silently ignored. There are also | ||
9 | ambiguous options that could be both in CFLAGS and LINKFLAGS (e.g. -spec). | ||
10 | |||
11 | Provide MergeFlags() with a dict instead of list to avoid the guesswork | ||
12 | in order to pass all options, even if some are not recognized by scons. | ||
13 | Switch LDFLAGS to LINKFLAGS for better compatibility with existing | ||
14 | scripts. | ||
15 | |||
16 | Upstream-Status: Submitted [https://gitlab.com/gpsd/gpsd/-/merge_requests/406] | ||
17 | Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org> | ||
18 | |||
19 | --- | ||
20 | SConscript | 11 ++++++----- | ||
21 | 1 file changed, 6 insertions(+), 5 deletions(-) | ||
22 | |||
23 | diff --git a/SConscript b/SConscript | ||
24 | index dab481654..ee90d87c4 100644 | ||
25 | --- a/SConscript | ||
26 | +++ b/SConscript | ||
27 | @@ -585,8 +585,8 @@ env['SC_PYTHON'] = sys.executable # Path to SCons Python | ||
28 | # explicitly quote them or (better yet) use the "=" form of GNU option | ||
29 | # settings. | ||
30 | # | ||
31 | -# Scons also uses different internal names than most other build-systems. | ||
32 | -# So we rely on MergeFlags/ParseFlags to do the right thing for us. | ||
33 | +# Scons also uses different internal names than most other build-systems, | ||
34 | +# e.g. it uses LINKFLAGS instead of LDFLAGS. | ||
35 | # | ||
36 | # scons uses gcc, or clang, to link. Thus LDFLAGS does not serve its | ||
37 | # traditional function of providing arguments to ln. LDFLAGS set in the | ||
38 | @@ -618,7 +618,10 @@ for i in ["ARFLAGS", | ||
39 | "SHLINKFLAGS", | ||
40 | ]: | ||
41 | if i in os.environ: | ||
42 | - env.MergeFlags(Split(os.getenv(i))) | ||
43 | + t = i | ||
44 | + if t == "LDFLAGS": | ||
45 | + t = "LINKFLAGS" | ||
46 | + env.MergeFlags({t: Split(os.getenv(i))}) | ||
47 | |||
48 | |||
49 | # Keep scan-build options in the environment | ||
50 | -- | ||
51 | GitLab | ||
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.25.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.25.bb index 3d817172e2..f893ac359b 100644 --- a/meta-oe/recipes-navigation/gpsd/gpsd_3.25.bb +++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.25.bb | |||
@@ -7,6 +7,7 @@ PROVIDES = "virtual/gpsd" | |||
7 | 7 | ||
8 | SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \ | 8 | SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \ |
9 | file://gpsd.init \ | 9 | file://gpsd.init \ |
10 | file://fix-pps_strerror_r.patch \ | ||
10 | " | 11 | " |
11 | SRC_URI[sha256sum] = "b368b6a305e3f7a6382d23a0cbfc1d78923060b6b7f54cf7987a73c7b4a9afc2" | 12 | SRC_URI[sha256sum] = "b368b6a305e3f7a6382d23a0cbfc1d78923060b6b7f54cf7987a73c7b4a9afc2" |
12 | 13 | ||