summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-29 10:35:25 -0800
committerKhem Raj <raj.khem@gmail.com>2023-01-29 21:09:39 -0800
commitb055d708ae2a1a0c7d7d35e03886ef1629a504ae (patch)
tree4562aa3baabf6bb95eb1bcfb9b61b25a1d44d86c
parent24724ee764cc09b61c09bd5cc470a8c5d41f8f17 (diff)
downloadmeta-openembedded-b055d708ae2a1a0c7d7d35e03886ef1629a504ae.tar.gz
rdma-core: Inherit python3targetconfig
It uses python3-config during build to grok the python specific includedirs, therefore its important to ensure that target specific python3-config is used, otherwise currently it defaults to native python3-config which ends up adding native python3 include paths which might work out ok but is exposed when target is 32bit + lfs enabled, the headers don't match between native and target python Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/rdma-core/rdma-core_42.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/rdma-core/rdma-core_42.0.bb b/meta-networking/recipes-support/rdma-core/rdma-core_42.0.bb
index 86243a52c5..a2d5142953 100644
--- a/meta-networking/recipes-support/rdma-core/rdma-core_42.0.bb
+++ b/meta-networking/recipes-support/rdma-core/rdma-core_42.0.bb
@@ -28,7 +28,7 @@ FILES_SOLIBSDEV = ""
28FILES:${PN} += "${libdir}/*" 28FILES:${PN} += "${libdir}/*"
29INSANE_SKIP:${PN} += "dev-so" 29INSANE_SKIP:${PN} += "dev-so"
30 30
31inherit cmake cpan-base pkgconfig python3native systemd 31inherit cmake cpan-base pkgconfig python3native python3targetconfig systemd
32 32
33SYSTEMD_SERVICE:${PN} = " \ 33SYSTEMD_SERVICE:${PN} = " \
34 srp_daemon.service \ 34 srp_daemon.service \