summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWolfgang Meyer <Wolfgang.Meyer@gossenmetrawatt.com>2022-09-08 11:51:36 +0200
committerKhem Raj <raj.khem@gmail.com>2023-07-03 11:34:36 -0700
commitb0c8cb29a14b43effe2595df40a40d8a188622d2 (patch)
tree1e48b903fe799012891aa0635ac40839f6194de2
parent3990b23ec73771917e13ee648c3173b5cbe46b6a (diff)
downloadmeta-openembedded-b0c8cb29a14b43effe2595df40a40d8a188622d2.tar.gz
fbida: Switch to git fetcher
fbida has not seen any versioned releases for five years even though development has not stalled. Update to latest commit that builds with the legacy gnumake style build system ([2019-01-24] ac9005bf0). Support for lirc, curl, sane, and cairo-gl has been dropped, the corresponding packageconfigs and dependencies were removed from the recipe. Dependencies to libinput and udev have been added. Signed-off-by: Wolfgang Meyer <Wolfgang.Meyer@gossenmetrawatt.com> Signed-off-by: Roland Hieber <rhi@pengutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/fbida/fbida_git.bb (renamed from meta-oe/recipes-graphics/fbida/fbida_2.14.bb)31
-rw-r--r--meta-oe/recipes-graphics/fbida/files/cairo-weak-detect.patch17
2 files changed, 10 insertions, 38 deletions
diff --git a/meta-oe/recipes-graphics/fbida/fbida_2.14.bb b/meta-oe/recipes-graphics/fbida/fbida_git.bb
index 3d65399cd2..b2e2a4bdcf 100644
--- a/meta-oe/recipes-graphics/fbida/fbida_2.14.bb
+++ b/meta-oe/recipes-graphics/fbida/fbida_git.bb
@@ -1,23 +1,24 @@
1SUMMARY = "Framebuffer image and doc viewer tools" 1SUMMARY = "Framebuffer image and doc viewer tools"
2DESCRIPTION = "The fbida project contains a few applications for viewing and editing images, \ 2DESCRIPTION = "The fbida project contains a few applications for viewing and editing images, \
3 with the main focus being photos." 3 with the main focus being photos."
4HOMEPAGE = "http://linux.bytesex.org/fbida/" 4HOMEPAGE = "https://www.kraxel.org/blog/linux/fbida/"
5AUTHOR = "Gerd Hoffmann" 5AUTHOR = "Gerd Hoffmann"
6SECTION = "utils" 6SECTION = "utils"
7 7
8LICENSE = "GPL-2.0-only" 8LICENSE = "GPL-2.0-only"
9LIC_FILES_CHKSUM = "file://COPYING;md5=e8feb78a32950a909621bbb51f634b39" 9LIC_FILES_CHKSUM = "file://COPYING;md5=e8feb78a32950a909621bbb51f634b39"
10 10
11DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif libdrm pixman poppler libepoxy cairo" 11DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif libdrm pixman udev libinput poppler libepoxy cairo"
12 12
13SRC_URI = "https://www.kraxel.org/releases/fbida/fbida-${PV}.tar.gz \ 13PV = "2.14+git${SRCPV}"
14 file://0001-Avoid-using-host-path.patch \ 14SRC_URI = "git://github.com/kraxel/fbida;protocol=https;branch=master \
15 file://fix-preprocessor.patch \ 15 file://0001-Avoid-using-host-path.patch \
16 file://fix-preprocessor.patch \
16 file://support-jpeg-turbo.patch \ 17 file://support-jpeg-turbo.patch \
17 file://cairo-weak-detect.patch \
18 file://fbida-gcc10.patch \ 18 file://fbida-gcc10.patch \
19 " 19"
20SRC_URI[sha256sum] = "95b7c01556cb6ef9819f358b314ddfeb8a4cbe862b521a3ed62f03d163154438" 20SRCREV = "ac9005bf0bbf50f14dc1b368be5084c8e0510a5d"
21S = "${WORKDIR}/git"
21 22
22inherit pkgconfig features_check 23inherit pkgconfig features_check
23 24
@@ -26,18 +27,12 @@ REQUIRED_DISTRO_FEATURES = "opengl"
26 27
27EXTRA_OEMAKE = "STRIP= 'srcdir=${S}' -f ${S}/GNUmakefile" 28EXTRA_OEMAKE = "STRIP= 'srcdir=${S}' -f ${S}/GNUmakefile"
28 29
29PACKAGECONFIG ??= "gif png curl" 30PACKAGECONFIG ??= "gif png"
30PACKAGECONFIG[curl] = ",,curl"
31PACKAGECONFIG[gif] = ",,giflib" 31PACKAGECONFIG[gif] = ",,giflib"
32PACKAGECONFIG[png] = ",,libpng" 32PACKAGECONFIG[png] = ",,libpng"
33PACKAGECONFIG[tiff] = ",,tiff" 33PACKAGECONFIG[tiff] = ",,tiff"
34PACKAGECONFIG[motif] = ",,libx11 libxext libxpm libxt openmotif" 34PACKAGECONFIG[motif] = ",,libx11 libxext libxpm libxt openmotif"
35PACKAGECONFIG[webp] = ",,libwebp" 35PACKAGECONFIG[webp] = ",,libwebp"
36PACKAGECONFIG[lirc] = ",,lirc"
37# This can only be enabled when cairo has egl enabled in its packageconfig support too
38PACKAGECONFIG[egl] = ",,"
39
40EXTRA_OEMAKE += ""${@bb.utils.contains('PACKAGECONFIG', 'egl', 'HAVE_CAIRO_GL=yes', 'HAVE_CAIRO_GL=no', d)}""
41 36
42CFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '-DEGL_NO_X11=1', d)}" 37CFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '-DEGL_NO_X11=1', d)}"
43 38
@@ -48,9 +43,6 @@ do_compile() {
48 43
49 # Be sure to respect preferences (force to "no") 44 # Be sure to respect preferences (force to "no")
50 # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH} 45 # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH}
51 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'curl', d)}" ]; then
52 sed -i -e '/^HAVE_LIBCURL/s/:=.*$/:= no/' ${S}/GNUmakefile
53 fi
54 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'gif', d)}" ]; then 46 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'gif', d)}" ]; then
55 sed -i -e '/^HAVE_LIBGIF/s/:=.*$/:= no/' ${S}/GNUmakefile 47 sed -i -e '/^HAVE_LIBGIF/s/:=.*$/:= no/' ${S}/GNUmakefile
56 fi 48 fi
@@ -66,9 +58,6 @@ do_compile() {
66 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'webp', d)}" ]; then 58 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'webp', d)}" ]; then
67 sed -i -e '/^HAVE_LIBWEBP/s/:=.*$/:= no/' ${S}/GNUmakefile 59 sed -i -e '/^HAVE_LIBWEBP/s/:=.*$/:= no/' ${S}/GNUmakefile
68 fi 60 fi
69 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'lirc', d)}" ]; then
70 sed -i -e '/^HAVE_LIBLIRC/s/:=.*$/:= no/' ${S}/GNUmakefile
71 fi
72 61
73 oe_runmake 62 oe_runmake
74} 63}
diff --git a/meta-oe/recipes-graphics/fbida/files/cairo-weak-detect.patch b/meta-oe/recipes-graphics/fbida/files/cairo-weak-detect.patch
deleted file mode 100644
index c7c579cc41..0000000000
--- a/meta-oe/recipes-graphics/fbida/files/cairo-weak-detect.patch
+++ /dev/null
@@ -1,17 +0,0 @@
1OE configures cairo to disable EGL support, however fbida expects cairo with egl support
2this patch therefore makes it possible to set HAVE_CAIRO_GL via recipe
3
4Upstream-Status: Inappropriate [OE-Specific]
5Signed-off-by: Khem Raj <raj.khem@gmail.com>
6
7--- a/GNUmakefile
8+++ b/GNUmakefile
9@@ -67,7 +67,7 @@ define make-config
10 LIB := $(LIB)
11 RESDIR := $(call ac_resdir)
12 HAVE_LINUX_FB_H := $(call ac_header,linux/fb.h)
13-HAVE_CAIRO_GL := $(call ac_pkg_config,cairo-gl)
14+HAVE_CAIRO_GL ?= $(call ac_pkg_config,cairo-gl)
15 HAVE_LIBPCD := $(call ac_lib,pcd_open,pcd)
16 HAVE_LIBGIF := $(call ac_lib,DGifOpenFileName,gif)
17 HAVE_LIBWEBP := $(call ac_pkg_config,libwebp)