diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-06-03 16:42:32 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-06-05 18:43:10 -0700 |
commit | c13b51f12b25e49354c16302ceb7aaeb2bb8f8a7 (patch) | |
tree | c9c320a1c6c9015aa453ab1be820b94d722b5826 | |
parent | 870a2f8e541f9c525f1cb4e3b90ed24658c0a1e2 (diff) | |
download | meta-openembedded-c13b51f12b25e49354c16302ceb7aaeb2bb8f8a7.tar.gz |
python3-feedformatter: Consolidate in a single file
Consolidate inc and bb files into a single bb file.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python-feedformatter.inc | 16 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb | 18 |
2 files changed, 17 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python-feedformatter.inc b/meta-python/recipes-devtools/python/python-feedformatter.inc deleted file mode 100644 index 6ddcaa98ec..0000000000 --- a/meta-python/recipes-devtools/python/python-feedformatter.inc +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | DESCRIPTION = "A Python library for generating news feeds in RSS and Atom formats" | ||
2 | HOMEPAGE = "http://code.google.com/p/feedformatter/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "BSD-3-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=258e3f39e2383fbd011035d04311008d" | ||
6 | SRCREV = "7391193c83e10420b5a2d8ef846d23fc368c6d85" | ||
7 | |||
8 | SRC_URI = "git://github.com/marianoguerra/feedformatter.git" | ||
9 | |||
10 | S = "${WORKDIR}/git" | ||
11 | |||
12 | RDEPENDS_${PN} += "\ | ||
13 | ${PYTHON_PN}-datetime \ | ||
14 | ${PYTHON_PN}-io \ | ||
15 | ${PYTHON_PN}-xml \ | ||
16 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb b/meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb index 95a5405f38..81c5fde132 100644 --- a/meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb +++ b/meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb | |||
@@ -1,2 +1,18 @@ | |||
1 | DESCRIPTION = "A Python library for generating news feeds in RSS and Atom formats" | ||
2 | HOMEPAGE = "http://code.google.com/p/feedformatter/" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "BSD-3-Clause" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=258e3f39e2383fbd011035d04311008d" | ||
6 | |||
7 | SRC_URI = "git://github.com/marianoguerra/feedformatter.git" | ||
8 | SRCREV = "7391193c83e10420b5a2d8ef846d23fc368c6d85" | ||
9 | |||
10 | S = "${WORKDIR}/git" | ||
11 | |||
1 | inherit setuptools3 | 12 | inherit setuptools3 |
2 | require python-feedformatter.inc | 13 | |
14 | RDEPENDS_${PN} += "\ | ||
15 | ${PYTHON_PN}-datetime \ | ||
16 | ${PYTHON_PN}-io \ | ||
17 | ${PYTHON_PN}-xml \ | ||
18 | " | ||