summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-03 16:42:32 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-05 18:43:10 -0700
commitc13b51f12b25e49354c16302ceb7aaeb2bb8f8a7 (patch)
treec9c320a1c6c9015aa453ab1be820b94d722b5826
parent870a2f8e541f9c525f1cb4e3b90ed24658c0a1e2 (diff)
downloadmeta-openembedded-c13b51f12b25e49354c16302ceb7aaeb2bb8f8a7.tar.gz
python3-feedformatter: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-feedformatter.inc16
-rw-r--r--meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb18
2 files changed, 17 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python-feedformatter.inc b/meta-python/recipes-devtools/python/python-feedformatter.inc
deleted file mode 100644
index 6ddcaa98ec..0000000000
--- a/meta-python/recipes-devtools/python/python-feedformatter.inc
+++ /dev/null
@@ -1,16 +0,0 @@
1DESCRIPTION = "A Python library for generating news feeds in RSS and Atom formats"
2HOMEPAGE = "http://code.google.com/p/feedformatter/"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING;md5=258e3f39e2383fbd011035d04311008d"
6SRCREV = "7391193c83e10420b5a2d8ef846d23fc368c6d85"
7
8SRC_URI = "git://github.com/marianoguerra/feedformatter.git"
9
10S = "${WORKDIR}/git"
11
12RDEPENDS_${PN} += "\
13 ${PYTHON_PN}-datetime \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-xml \
16 "
diff --git a/meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb b/meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb
index 95a5405f38..81c5fde132 100644
--- a/meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb
+++ b/meta-python/recipes-devtools/python/python3-feedformatter_0.4.bb
@@ -1,2 +1,18 @@
1DESCRIPTION = "A Python library for generating news feeds in RSS and Atom formats"
2HOMEPAGE = "http://code.google.com/p/feedformatter/"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING;md5=258e3f39e2383fbd011035d04311008d"
6
7SRC_URI = "git://github.com/marianoguerra/feedformatter.git"
8SRCREV = "7391193c83e10420b5a2d8ef846d23fc368c6d85"
9
10S = "${WORKDIR}/git"
11
1inherit setuptools3 12inherit setuptools3
2require python-feedformatter.inc 13
14RDEPENDS_${PN} += "\
15 ${PYTHON_PN}-datetime \
16 ${PYTHON_PN}-io \
17 ${PYTHON_PN}-xml \
18 "