summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-22 18:50:29 -0700
committerKhem Raj <raj.khem@gmail.com>2023-05-23 08:48:18 -0700
commitc75d0ca313d2c81ff8e127510dca69628c40a9fe (patch)
tree454e95a93cb9165107f2ce93dbe33a5c72c3d7fb
parentb1b7ee87ac55fced4bcf88b0e374025d7f908731 (diff)
downloadmeta-openembedded-c75d0ca313d2c81ff8e127510dca69628c40a9fe.tar.gz
dovecot: Upgrade to 2.3.20
- Re-enable LTO again, it works ok. - Turn systemd into a packageconfig and enable it when systemd is in distro features Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/dovecot/dovecot_2.3.20.bb (renamed from meta-networking/recipes-support/dovecot/dovecot_2.3.14.bb)22
1 files changed, 9 insertions, 13 deletions
diff --git a/meta-networking/recipes-support/dovecot/dovecot_2.3.14.bb b/meta-networking/recipes-support/dovecot/dovecot_2.3.20.bb
index d8c483191f..7729bb4a8b 100644
--- a/meta-networking/recipes-support/dovecot/dovecot_2.3.14.bb
+++ b/meta-networking/recipes-support/dovecot/dovecot_2.3.20.bb
@@ -12,9 +12,7 @@ SRC_URI = "http://dovecot.org/releases/2.3/dovecot-${PV}.tar.gz \
12 file://0001-not-check-pandoc.patch \ 12 file://0001-not-check-pandoc.patch \
13 file://0001-m4-Check-for-libunwind-instead-of-libunwind-generic.patch \ 13 file://0001-m4-Check-for-libunwind-instead-of-libunwind-generic.patch \
14 " 14 "
15 15SRC_URI[sha256sum] = "caa832eb968148abdf35ee9d0f534b779fa732c0ce4a913d9ab8c3469b218552"
16SRC_URI[md5sum] = "2f03532cec3280ae45a101a7a55ccef5"
17SRC_URI[sha256sum] = "c8b3d7f3af1e558a3ff0f970309d4013a4d3ce136f8c02a53a3b05f345b9a34a"
18 16
19DEPENDS = "openssl xz zlib bzip2 libcap icu libtirpc bison-native" 17DEPENDS = "openssl xz zlib bzip2 libcap icu libtirpc bison-native"
20CFLAGS += "-I${STAGING_INCDIR}/tirpc" 18CFLAGS += "-I${STAGING_INCDIR}/tirpc"
@@ -22,9 +20,10 @@ LDFLAGS += "-ltirpc"
22 20
23inherit autotools pkgconfig systemd useradd gettext 21inherit autotools pkgconfig systemd useradd gettext
24 22
25PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ldap pam', d)}" 23PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ldap pam systemd', d)}"
26 24
27PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam," 25PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,"
26PACKAGECONFIG[systemd] = "--with-systemd,--without-systemd,systemd,"
28PACKAGECONFIG[ldap] = "--with-ldap=plugin,--without-ldap,openldap," 27PACKAGECONFIG[ldap] = "--with-ldap=plugin,--without-ldap,openldap,"
29PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4," 28PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
30 29
@@ -42,12 +41,7 @@ CACHED_CONFIGUREVARS += "i_cv_signed_size_t=no \
42 41
43# hardcode epoll() to avoid running unsafe tests 42# hardcode epoll() to avoid running unsafe tests
44# BSD needs kqueue and uclibc poll() 43# BSD needs kqueue and uclibc poll()
45EXTRA_OECONF = " --with-ioloop=epoll \ 44EXTRA_OECONF = " --with-ioloop=epoll"
46 --with-systemdsystemunitdir=${systemd_unitdir}/system"
47
48# Uses hidden symbols
49# libssl_iostream_openssl.so: undefined reference to `ssl_iostream_handshake'
50LTO = ""
51 45
52SYSTEMD_PACKAGES = "${PN}" 46SYSTEMD_PACKAGES = "${PN}"
53SYSTEMD_SERVICE:${PN} = "dovecot.service dovecot.socket" 47SYSTEMD_SERVICE:${PN} = "dovecot.service dovecot.socket"
@@ -56,9 +50,11 @@ SYSTEMD_AUTO_ENABLE = "disable"
56do_install:append () { 50do_install:append () {
57 install -d 755 ${D}/etc/dovecot 51 install -d 755 ${D}/etc/dovecot
58 touch 644 ${D}/etc/dovecot/dovecot.conf 52 touch 644 ${D}/etc/dovecot/dovecot.conf
59 install -m 0644 ${WORKDIR}/dovecot.service ${D}${systemd_unitdir}/system 53 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" ]; then
60 sed -i -e 's#@SYSCONFDIR@#${sysconfdir}#g' ${D}${systemd_unitdir}/system/dovecot.service 54 install -m 0644 ${WORKDIR}/dovecot.service ${D}${systemd_unitdir}/system
61 sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/dovecot.service 55 sed -i -e 's#@SYSCONFDIR@#${sysconfdir}#g' ${D}${systemd_unitdir}/system/dovecot.service
56 sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/dovecot.service
57 fi
62} 58}
63 59
64USERADD_PACKAGES = "${PN}" 60USERADD_PACKAGES = "${PN}"