diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-04-24 10:27:53 -0700 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2017-04-25 16:10:55 -0400 |
commit | c8d5f975fc4eb05a0cfdd988ec567c863a14d45c (patch) | |
tree | 4175520819a44c4989cda226afaa17ebfbc97ab3 | |
parent | d16352e9b4a916fa520896e9df96819f1388aef3 (diff) | |
download | meta-openembedded-c8d5f975fc4eb05a0cfdd988ec567c863a14d45c.tar.gz |
yp-tools: Fix build with gcc7
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r-- | meta-networking/recipes-support/nis/yp-tools/0001-lib-yp_all_host.c-Fix-build-with-gcc-7.patch | 33 | ||||
-rw-r--r-- | meta-networking/recipes-support/nis/yp-tools_3.3.bb | 3 |
2 files changed, 35 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/nis/yp-tools/0001-lib-yp_all_host.c-Fix-build-with-gcc-7.patch b/meta-networking/recipes-support/nis/yp-tools/0001-lib-yp_all_host.c-Fix-build-with-gcc-7.patch new file mode 100644 index 0000000000..d1d5f9ca78 --- /dev/null +++ b/meta-networking/recipes-support/nis/yp-tools/0001-lib-yp_all_host.c-Fix-build-with-gcc-7.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From 71fdfdfcea2bfa5f522512366bfcdf95f861ecc6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 23 Apr 2017 23:44:37 -0700 | ||
4 | Subject: [PATCH] lib/yp_all_host.c: Fix build with gcc 7 | ||
5 | |||
6 | fixes | ||
7 | |||
8 | | ../../../../../../../workspace/sources/yp-tools/lib/yp_all_host.c: In function 'yp_all_host': | ||
9 | | ../../../../../../../workspace/sources/yp-tools/lib/yp_all_host.c:109:30: error: comparison between pointer and zero character constant [-Werror=pointer-compare] | ||
10 | | inmap == NULL || inmap == '\0') | ||
11 | | ^~ | ||
12 | |||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | lib/yp_all_host.c | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/lib/yp_all_host.c b/lib/yp_all_host.c | ||
19 | index 59cf236..4a07a7e 100644 | ||
20 | --- a/lib/yp_all_host.c | ||
21 | +++ b/lib/yp_all_host.c | ||
22 | @@ -106,7 +106,7 @@ yp_all_host (const char *indomain, const char *inmap, | ||
23 | |||
24 | if (hostname == NULL || hostname[0] == '\0' || | ||
25 | indomain == NULL || indomain[0] == '\0' || | ||
26 | - inmap == NULL || inmap == '\0') | ||
27 | + inmap == NULL || inmap[0] == '\0') | ||
28 | return YPERR_BADARGS; | ||
29 | |||
30 | res = YPERR_YPERR; | ||
31 | -- | ||
32 | 2.12.2 | ||
33 | |||
diff --git a/meta-networking/recipes-support/nis/yp-tools_3.3.bb b/meta-networking/recipes-support/nis/yp-tools_3.3.bb index 69217fad1e..7bd4630f75 100644 --- a/meta-networking/recipes-support/nis/yp-tools_3.3.bb +++ b/meta-networking/recipes-support/nis/yp-tools_3.3.bb | |||
@@ -15,7 +15,8 @@ SRC_URI = "http://www.linux-nis.org/download/yp-tools/${BP}.tar.bz2 \ | |||
15 | file://domainname.service \ | 15 | file://domainname.service \ |
16 | file://yp-tools-ipv4-ipv6-Provide-an-in-place-version-of-mapv4v6addr.patch \ | 16 | file://yp-tools-ipv4-ipv6-Provide-an-in-place-version-of-mapv4v6addr.patch \ |
17 | file://alignment-cheat.patch \ | 17 | file://alignment-cheat.patch \ |
18 | " | 18 | file://0001-lib-yp_all_host.c-Fix-build-with-gcc-7.patch \ |
19 | " | ||
19 | SRC_URI[md5sum] = "acebeecc11a73fb8097503670344834c" | 20 | SRC_URI[md5sum] = "acebeecc11a73fb8097503670344834c" |
20 | SRC_URI[sha256sum] = "812be817df3d4c25813552be336c6c6ad5aedaf65611b81af3ad9f98fb3c2e50" | 21 | SRC_URI[sha256sum] = "812be817df3d4c25813552be336c6c6ad5aedaf65611b81af3ad9f98fb3c2e50" |
21 | 22 | ||