diff options
author | Ross Burton <ross.burton@arm.com> | 2022-07-14 13:44:00 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-07-15 12:48:34 -0400 |
commit | ca039757994cd6643b63c70cd85145eb98331e2a (patch) | |
tree | f3845399a93ad0055af6950deb84d0b4dd89fc95 | |
parent | a2cd474a57301ea50c2b7dc921ba678c96d35d45 (diff) | |
download | meta-openembedded-ca039757994cd6643b63c70cd85145eb98331e2a.tar.gz |
python3-pyrad: fix build system specification
The upstream pyproject.toml says it needs to be built with the Poetry
frontend, but that's deprecated behaviour and it should use the Poetry
Core API instead.
Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pyrad/use-poetry-core.patch | 26 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pyrad_2.4.bb | 2 |
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyrad/use-poetry-core.patch b/meta-python/recipes-devtools/python/python3-pyrad/use-poetry-core.patch new file mode 100644 index 0000000000..43a177da0a --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pyrad/use-poetry-core.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | Upstream-Status: Backport [https://github.com/pyradius/pyrad/commit/ffe182a44909e8f8278fb3e2ea052ddc097b48b9] | ||
2 | Signed-off-by: Ross Burton <ross.burton@arm.com> | ||
3 | |||
4 | From a4b70067dd6269e14a2f9530d820390a8a454231 Mon Sep 17 00:00:00 2001 | ||
5 | From: Martin Weinelt <hexa@darmstadt.ccc.de> | ||
6 | Date: Thu, 14 Apr 2022 22:07:37 +0200 | ||
7 | Subject: [PATCH] Use poetry-core for pyproject based builds | ||
8 | |||
9 | https://github.com/python-poetry/poetry-core#why-is-this-required | ||
10 | --- | ||
11 | pyproject.toml | 4 ++-- | ||
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/pyproject.toml b/pyproject.toml | ||
15 | index 87b1df3..711c52f 100755 | ||
16 | --- a/pyproject.toml | ||
17 | +++ b/pyproject.toml | ||
18 | @@ -1,6 +1,6 @@ | ||
19 | [build-system] | ||
20 | -requires = ["poetry>=1.0"] | ||
21 | -build-backend = "poetry.masonry.api" | ||
22 | +requires = ["poetry-core>=1.0.0"] | ||
23 | +build-backend = "poetry.core.masonry.api" | ||
24 | |||
25 | [tool.poetry] | ||
26 | name = "pyrad" | ||
diff --git a/meta-python/recipes-devtools/python/python3-pyrad_2.4.bb b/meta-python/recipes-devtools/python/python3-pyrad_2.4.bb index b2d0dc324b..bce1e2fd14 100644 --- a/meta-python/recipes-devtools/python/python3-pyrad_2.4.bb +++ b/meta-python/recipes-devtools/python/python3-pyrad_2.4.bb | |||
@@ -6,4 +6,6 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665 | |||
6 | PYPI_PACKAGE = "pyrad" | 6 | PYPI_PACKAGE = "pyrad" |
7 | SRC_URI[sha256sum] = "057de4b7e89d8da57ba782c1bde45c63ebee720ae2c0b0a69beaff15c47e30d9" | 7 | SRC_URI[sha256sum] = "057de4b7e89d8da57ba782c1bde45c63ebee720ae2c0b0a69beaff15c47e30d9" |
8 | 8 | ||
9 | SRC_URI += "file://use-poetry-core.patch" | ||
10 | |||
9 | inherit pypi python_poetry_core | 11 | inherit pypi python_poetry_core |