summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuan Chao <yuanc.fnst@cn.fujitsu.com>2019-09-05 15:35:13 +0900
committerKhem Raj <raj.khem@gmail.com>2019-09-05 18:13:44 -0700
commitca1cc870c5eb34646f73e241667b22463ebd65fd (patch)
treead7645a6754252518df81994b388d80bf0696ff8
parent517bd23da6cac1dd10adc3100cb82446d6c3e089 (diff)
downloadmeta-openembedded-ca1cc870c5eb34646f73e241667b22463ebd65fd.tar.gz
numactl: upgrade 2.0.12 -> 2.0.13
Remove patch: 0001-fix-NULL-pointer-problem.patch since this is included in 2.0.13 Signed-off-by: Yuan Chao <yuanc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/numactl/numactl/0001-fix-NULL-pointer-problem.patch35
-rw-r--r--meta-oe/recipes-support/numactl/numactl_git.bb5
2 files changed, 2 insertions, 38 deletions
diff --git a/meta-oe/recipes-support/numactl/numactl/0001-fix-NULL-pointer-problem.patch b/meta-oe/recipes-support/numactl/numactl/0001-fix-NULL-pointer-problem.patch
deleted file mode 100644
index 0497613dda..0000000000
--- a/meta-oe/recipes-support/numactl/numactl/0001-fix-NULL-pointer-problem.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From 5c16beff9909b28f55f25f48ed7ddbf98d8b1d5c Mon Sep 17 00:00:00 2001
2From: Roy Li <rongqing.li@windriver.com>
3Date: Wed, 18 Jul 2018 09:43:55 +0800
4Subject: [PATCH] fix NULL pointer problem
5
6return 0 if distance_table is NULL
7
8Upstream-Status: Pending
9
10read_distance_table() maybe return 0, but distance_table is not set,
11if distance_table is used, and will lead to SEGFAULT
12
13Signed-off-by: Roy Li <rongqing.li@windriver.com>
14
15Signed-off-by: Changqing Li <changqing.li@windriver.com>
16---
17 distance.c | 2 ++
18 1 file changed, 2 insertions(+)
19
20diff --git a/distance.c b/distance.c
21index 8d472af..6a6e886 100644
22--- a/distance.c
23+++ b/distance.c
24@@ -113,6 +113,8 @@ int numa_distance(int a, int b)
25 int err = read_distance_table();
26 if (err < 0)
27 return 0;
28+ if(!distance_table)
29+ return 0;
30 }
31 if ((unsigned)a >= distance_numnodes || (unsigned)b >= distance_numnodes)
32 return 0;
33--
342.7.4
35
diff --git a/meta-oe/recipes-support/numactl/numactl_git.bb b/meta-oe/recipes-support/numactl/numactl_git.bb
index 279ac04156..f13b1795f1 100644
--- a/meta-oe/recipes-support/numactl/numactl_git.bb
+++ b/meta-oe/recipes-support/numactl/numactl_git.bb
@@ -10,11 +10,10 @@ inherit autotools-brokensep ptest
10 10
11LIC_FILES_CHKSUM = "file://README.md;beginline=19;endline=32;md5=f8ff2391624f28e481299f3f677b21bb" 11LIC_FILES_CHKSUM = "file://README.md;beginline=19;endline=32;md5=f8ff2391624f28e481299f3f677b21bb"
12 12
13SRCREV = "841253d1313b01a968c380cae4f498f20c46e5aa" 13SRCREV = "5d9f16722e3df49dc618a9f361bd482559695db7"
14PV = "2.0.12+git${SRCPV}" 14PV = "2.0.13+git${SRCPV}"
15 15
16SRC_URI = "git://github.com/numactl/numactl \ 16SRC_URI = "git://github.com/numactl/numactl \
17 file://0001-fix-NULL-pointer-problem.patch \
18 file://Fix-the-test-output-format.patch \ 17 file://Fix-the-test-output-format.patch \
19 file://Makefile \ 18 file://Makefile \
20 file://run-ptest \ 19 file://run-ptest \