diff options
author | Ross Burton <ross.burton@intel.com> | 2018-07-27 12:19:14 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-07-27 19:26:51 -0700 |
commit | d00b7bd416eceb4d6aa70a572832a05d6f9870c0 (patch) | |
tree | f44358e2d1b6ea5d2cfa42fe19d2c8ad4dfd9b9a | |
parent | 9b743db42aa81b3ea4ca519c095f0836ba25a1d8 (diff) | |
download | meta-openembedded-d00b7bd416eceb4d6aa70a572832a05d6f9870c0.tar.gz |
libusb-compat: add (from oe-core)
This is being removed from oe-core, so add to meta-oe as some recipes still
claim to need it.
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/libusb/libusb-compat/0001-usb.h-Include-sys-types.h.patch | 30 | ||||
-rw-r--r-- | meta-oe/recipes-support/libusb/libusb-compat_0.1.5.bb | 42 |
2 files changed, 72 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libusb/libusb-compat/0001-usb.h-Include-sys-types.h.patch b/meta-oe/recipes-support/libusb/libusb-compat/0001-usb.h-Include-sys-types.h.patch new file mode 100644 index 0000000000..b88440dec9 --- /dev/null +++ b/meta-oe/recipes-support/libusb/libusb-compat/0001-usb.h-Include-sys-types.h.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 340f911f9e3f4ff6b01682c5341c959060782af2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 2 Apr 2015 19:18:45 -0700 | ||
4 | Subject: [PATCH] usb.h: Include sys/types.h | ||
5 | |||
6 | We need the definitions for things like u_intX_t | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | libusb/usb.h | 2 ++ | ||
13 | 1 file changed, 2 insertions(+) | ||
14 | |||
15 | diff --git a/libusb/usb.h b/libusb/usb.h | ||
16 | index 84e730f..caffae2 100644 | ||
17 | --- a/libusb/usb.h | ||
18 | +++ b/libusb/usb.h | ||
19 | @@ -31,6 +31,8 @@ | ||
20 | |||
21 | #include <dirent.h> | ||
22 | |||
23 | +#include <sys/types.h> | ||
24 | + | ||
25 | /* | ||
26 | * USB spec information | ||
27 | * | ||
28 | -- | ||
29 | 2.1.4 | ||
30 | |||
diff --git a/meta-oe/recipes-support/libusb/libusb-compat_0.1.5.bb b/meta-oe/recipes-support/libusb/libusb-compat_0.1.5.bb new file mode 100644 index 0000000000..1ddbe238fc --- /dev/null +++ b/meta-oe/recipes-support/libusb/libusb-compat_0.1.5.bb | |||
@@ -0,0 +1,42 @@ | |||
1 | SUMMARY = "libusb-0.1 compatibility layer for libusb1" | ||
2 | DESCRIPTION = "libusb-0.1 compatible layer for libusb1, a drop-in replacement \ | ||
3 | that aims to look, feel and behave exactly like libusb-0.1" | ||
4 | HOMEPAGE = "http://www.libusb.org/" | ||
5 | BUGTRACKER = "http://www.libusb.org/report" | ||
6 | SECTION = "libs" | ||
7 | |||
8 | LICENSE = "LGPLv2.1+" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f2ac5f3ac4835e8f91324a26a590a423" | ||
10 | DEPENDS = "libusb1" | ||
11 | |||
12 | # Few packages are known not to work with libusb-compat (e.g. libmtp-1.0.0), | ||
13 | # so here libusb-0.1 is removed completely instead of adding virtual/libusb0. | ||
14 | # Besides, libusb-0.1 uses a per 1ms polling that hurts a lot to power | ||
15 | # consumption. | ||
16 | PROVIDES = "libusb virtual/libusb0" | ||
17 | BBCLASSEXTEND = "native nativesdk" | ||
18 | |||
19 | PE = "1" | ||
20 | |||
21 | SRC_URI = "${SOURCEFORGE_MIRROR}/libusb/libusb-compat-${PV}.tar.bz2 \ | ||
22 | file://0001-usb.h-Include-sys-types.h.patch \ | ||
23 | " | ||
24 | |||
25 | SRC_URI[md5sum] = "2780b6a758a1e2c2943bdbf7faf740e4" | ||
26 | SRC_URI[sha256sum] = "404ef4b6b324be79ac1bfb3d839eac860fbc929e6acb1ef88793a6ea328bc55a" | ||
27 | |||
28 | UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/libusb/files/libusb-compat-0.1/" | ||
29 | UPSTREAM_CHECK_REGEX = "/libusb-compat-(?P<pver>(\d+[\.\-_]*)+)/$" | ||
30 | |||
31 | BINCONFIG = "${bindir}/libusb-config" | ||
32 | |||
33 | inherit autotools pkgconfig binconfig-disabled lib_package | ||
34 | |||
35 | EXTRA_OECONF = "--libdir=${base_libdir}" | ||
36 | |||
37 | do_install_append() { | ||
38 | install -d ${D}${libdir} | ||
39 | if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then | ||
40 | mv ${D}${base_libdir}/pkgconfig ${D}${libdir} | ||
41 | fi | ||
42 | } | ||