diff options
author | Derek Straka <derek@asterius.io> | 2020-02-14 14:56:19 -0500 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-02-15 08:05:07 -0800 |
commit | d3fdee897e9871e142f12efe8862e3341c0174e9 (patch) | |
tree | 6338e690d29eb3da510a50204d1f1cab819b6fa9 | |
parent | 401bd658536396dd2504de0a401c0aa74fd8c477 (diff) | |
download | meta-openembedded-d3fdee897e9871e142f12efe8862e3341c0174e9.tar.gz |
python3-can: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python-can.inc | 18 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-can_3.3.2.bb | 17 |
2 files changed, 16 insertions, 19 deletions
diff --git a/meta-python/recipes-devtools/python/python-can.inc b/meta-python/recipes-devtools/python/python-can.inc deleted file mode 100644 index 7d0100d7d7..0000000000 --- a/meta-python/recipes-devtools/python/python-can.inc +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | SUMMARY = "Controller Area Network (CAN) interface module for Python" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "LGPLv3" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e6a600fd5e1d9cbde2d983680233ad02" | ||
5 | |||
6 | SRC_URI[md5sum] = "b724553a330478270267380b4888a18e" | ||
7 | SRC_URI[sha256sum] = "5fefb5c1e7e7f07faefc02c6eac79f9b58376f007048a04d8e7f325d48ec6b2e" | ||
8 | |||
9 | PYPI_PACKAGE="python-can" | ||
10 | |||
11 | RDEPENDS_${PN}_class-target += "\ | ||
12 | ${PYTHON_PN}-ctypes \ | ||
13 | ${PYTHON_PN}-logging \ | ||
14 | ${PYTHON_PN}-misc \ | ||
15 | ${PYTHON_PN}-netserver \ | ||
16 | ${PYTHON_PN}-sqlite3 \ | ||
17 | ${PYTHON_PN}-wrapt \ | ||
18 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-can_3.3.2.bb b/meta-python/recipes-devtools/python/python3-can_3.3.2.bb index aaa9e811ce..4597795d50 100644 --- a/meta-python/recipes-devtools/python/python3-can_3.3.2.bb +++ b/meta-python/recipes-devtools/python/python3-can_3.3.2.bb | |||
@@ -1,7 +1,22 @@ | |||
1 | require python-can.inc | 1 | SUMMARY = "Controller Area Network (CAN) interface module for Python" |
2 | SECTION = "devel/python" | ||
3 | LICENSE = "LGPLv3" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e6a600fd5e1d9cbde2d983680233ad02" | ||
5 | |||
6 | SRC_URI[md5sum] = "b724553a330478270267380b4888a18e" | ||
7 | SRC_URI[sha256sum] = "5fefb5c1e7e7f07faefc02c6eac79f9b58376f007048a04d8e7f325d48ec6b2e" | ||
8 | |||
9 | PYPI_PACKAGE="python-can" | ||
10 | |||
2 | inherit pypi setuptools3 | 11 | inherit pypi setuptools3 |
3 | 12 | ||
4 | RDEPENDS_${PN}_class-target += "\ | 13 | RDEPENDS_${PN}_class-target += "\ |
14 | ${PYTHON_PN}-ctypes \ | ||
5 | ${PYTHON_PN}-codecs \ | 15 | ${PYTHON_PN}-codecs \ |
6 | ${PYTHON_PN}-compression \ | 16 | ${PYTHON_PN}-compression \ |
17 | ${PYTHON_PN}-logging \ | ||
18 | ${PYTHON_PN}-misc \ | ||
19 | ${PYTHON_PN}-netserver \ | ||
20 | ${PYTHON_PN}-sqlite3 \ | ||
21 | ${PYTHON_PN}-wrapt \ | ||
7 | " | 22 | " |