summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2025-03-05 11:52:53 +0100
committerKhem Raj <raj.khem@gmail.com>2025-03-06 06:58:00 -0800
commite35b6e146b2afc8b0070e6821a0553f1234740a6 (patch)
treeab2699ab93867554cb44c8e16e887c58973e3dca
parentd54e2671e62b87532e2dd8f80b73d545fc54aeb4 (diff)
downloadmeta-openembedded-e35b6e146b2afc8b0070e6821a0553f1234740a6.tar.gz
uutils-coreutils: use correct variables
* use STAGING_LIBDIR_NATIVE variable for LIBCLANG_PATH and SELINUX_LIB_DIR and STAGING_INCDIR_NATIVE variable for SELINUX_INCLUDE_DIR not sure why it uses native version and not target, but at least use correct variable * hardcoding: ${WORKDIR}/recipe-sysroot-native${libdir} is just wrong when there is a better variable * This path won't be correct for multilib builds where target ${libdir} might be e.g. /usr/lib32 while native libdir is /usr/lib. * even with meta-selinux added to my builds I don't see any failure maybe these variables aren't really used? * use STAGING_LIBDIR_NATIVE variable which uses correct ${libdir_native} OE qemuarm64-multilib@ /OE/build/oe-core $ bitbake-getvar LIBCLANG_PATH -r uutils-coreutils # # $LIBCLANG_PATH [2 operations] # exported /OE/build/oe-core/meta-openembedded/meta-oe/recipes-core/uutils-coreutils/uutils-coreutils_0.0.29.bb:33 # [export] "1" # set /OE/build/oe-core/meta-openembedded/meta-oe/recipes-core/uutils-coreutils/uutils-coreutils_0.0.29.bb:33 # "${WORKDIR}/recipe-sysroot-native${libdir}" # pre-expansion value: # "${WORKDIR}/recipe-sysroot-native${libdir}" export LIBCLANG_PATH="/OE/build/oe-core/tmp/work/cortexa57-oe-linux/uutils-coreutils/0.0.29/recipe-sysroot-native/usr/lib64" OE qemuarm64-multilib@ /OE/build/oe-core $ bitbake-getvar STAGING_LIBDIR_NATIVE -r uutils-coreutils # # $STAGING_LIBDIR_NATIVE # set /OE/build/oe-core/openembedded-core/meta/conf/bitbake.conf:425 # "${STAGING_DIR_NATIVE}${libdir_native}" STAGING_LIBDIR_NATIVE="/OE/build/oe-core/tmp/work/cortexa57-oe-linux/uutils-coreutils/0.0.29/recipe-sysroot-native/usr/lib" OE qemuarm64-multilib@ /OE/build/oe-core $ bitbake-getvar LIBCLANG_PATH -r lib32-uutils-coreutils # # $LIBCLANG_PATH [2 operations] # exported /OE/build/oe-core/meta-openembedded/meta-oe/recipes-core/uutils-coreutils/uutils-coreutils_0.0.29.bb:33 # [export] "1" # set /OE/build/oe-core/meta-openembedded/meta-oe/recipes-core/uutils-coreutils/uutils-coreutils_0.0.29.bb:33 # "${WORKDIR}/recipe-sysroot-native${libdir}" # pre-expansion value: # "${WORKDIR}/recipe-sysroot-native${libdir}" export LIBCLANG_PATH="/OE/build/oe-core/tmp/work/armv7at2-neon-oemllib32-linux-gnueabi/lib32-uutils-coreutils/0.0.29/recipe-sysroot-native/usr/lib32" OE qemuarm64-multilib@ /OE/build/oe-core $ bitbake-getvar STAGING_LIBDIR_NATIVE -r lib32-uutils-coreutils # # $STAGING_LIBDIR_NATIVE # set /OE/build/oe-core/openembedded-core/meta/conf/bitbake.conf:425 # "${STAGING_DIR_NATIVE}${libdir_native}" STAGING_LIBDIR_NATIVE="/OE/build/oe-core/tmp/work/armv7at2-neon-oemllib32-linux-gnueabi/lib32-uutils-coreutils/0.0.29/recipe-sysroot-native/usr/lib" Signed-off-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-core/uutils-coreutils/uutils-coreutils_0.0.29.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-core/uutils-coreutils/uutils-coreutils_0.0.29.bb b/meta-oe/recipes-core/uutils-coreutils/uutils-coreutils_0.0.29.bb
index 19d628f735..d0a7532984 100644
--- a/meta-oe/recipes-core/uutils-coreutils/uutils-coreutils_0.0.29.bb
+++ b/meta-oe/recipes-core/uutils-coreutils/uutils-coreutils_0.0.29.bb
@@ -30,9 +30,9 @@ CARGO_BUILD_FLAGS += "${@bb.utils.contains('PACKAGECONFIG', 'selinux', '--featur
30 30
31DEPENDS += "${@bb.utils.contains('PACKAGECONFIG', 'selinux', 'clang-native libselinux-native', '', d)}" 31DEPENDS += "${@bb.utils.contains('PACKAGECONFIG', 'selinux', 'clang-native libselinux-native', '', d)}"
32 32
33export LIBCLANG_PATH = "${WORKDIR}/recipe-sysroot-native${libdir}" 33export LIBCLANG_PATH = "${STAGING_LIBDIR_NATIVE}"
34export SELINUX_LIB_DIR = "${WORKDIR}/recipe-sysroot-native${libdir}" 34export SELINUX_LIB_DIR = "${STAGING_LIBDIR_NATIVE}"
35export SELINUX_INCLUDE_DIR = "${WORKDIR}/recipe-sysroot-native${includedir}" 35export SELINUX_INCLUDE_DIR = "${STAGING_INCDIR_NATIVE}"
36 36
37# The code which follows is strongly inspired from the GNU coreutils bitbake recipe: 37# The code which follows is strongly inspired from the GNU coreutils bitbake recipe:
38 38