summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-06-27 17:07:48 +0800
committerKhem Raj <raj.khem@gmail.com>2024-06-28 11:22:05 -0700
commite3a9f88e5ccd9a403c7a652d294dbdc545e8d57c (patch)
tree7365a196b64bc55bf1a62108174cee952d22342a
parent4cdf731c3f651bbce25d65bf71eda54eacbe5dc4 (diff)
downloadmeta-openembedded-e3a9f88e5ccd9a403c7a652d294dbdc545e8d57c.tar.gz
sblim-sfcc: fix build failure with gcc-14
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc/0001-Fix-incompatible-pointer-type-error-with-gcc-option.patch72
-rw-r--r--meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc_2.2.8.bb1
2 files changed, 73 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc/0001-Fix-incompatible-pointer-type-error-with-gcc-option.patch b/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc/0001-Fix-incompatible-pointer-type-error-with-gcc-option.patch
new file mode 100644
index 0000000000..5e8f4fa0d5
--- /dev/null
+++ b/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc/0001-Fix-incompatible-pointer-type-error-with-gcc-option.patch
@@ -0,0 +1,72 @@
1From 5151163d6f4d4de0699d1e85c54fbe2cb5b55460 Mon Sep 17 00:00:00 2001
2From: Wang Mingyu <wangmy@fujitsu.com>
3Date: Thu, 27 Jun 2024 01:51:36 +0000
4Subject: Fix incompatible pointer type error with gcc option
5 -Wincompatible-pointer-types
6
7| ../../sblim-sfcc-2.2.8/TEST/v2test_ec.c: In function 'main':
8| ../../sblim-sfcc-2.2.8/TEST/v2test_ec.c:86:31: error: passing argument 1 of 'showClass' from incompatible pointer type [-Wincompatible-pointer-types]
9| 86 | showClass(data.value.cls);
10| | ~~~~~~~~~~^~~~
11| | |
12| | CIMCClass * {aka struct _CIMCClass *}
13| In file included from ../../sblim-sfcc-2.2.8/TEST/v2test_ec.c:7:
14| ../../sblim-sfcc-2.2.8/TEST/show.h:9:34: note: expected 'CMPIConstClass *' {aka 'struct _CMPIConstClass *'} but argument is of type 'CIMCClass *' {aka 'struct _CIMCClass *'}
15| 9 | void showClass( CMPIConstClass * in_class );
16| | ~~~~~~~~~~~~~~~~~^~~~~~~~
17
18| ../../sblim-sfcc-2.2.8/TEST/v2test_ein.c: In function 'main':
19| ../../sblim-sfcc-2.2.8/TEST/v2test_ein.c:96:36: error: passing argument 1 of 'showObjectPath' from incompatible pointer type [-Wincompatible-pointer-types]
20| 96 | showObjectPath(data.value.ref);
21| | ~~~~~~~~~~^~~~
22| | |
23| | CIMCObjectPath * {aka struct _CIMCObjectPath *}
24| In file included from ../../sblim-sfcc-2.2.8/TEST/v2test_ein.c:7:
25| ../../sblim-sfcc-2.2.8/TEST/show.h:7:39: note: expected 'CMPIObjectPath *' {aka 'struct _CMPIObjectPath *'} but argument is of type 'CIMCObjectPath *' {aka 'struct _CIMCObjectPath *'}
26| 7 | void showObjectPath( CMPIObjectPath * objectpath );
27| | ~~~~~~~~~~~~~~~~~^~~~~~~~~~
28| make[2]: *** [Makefile:1110: v2test_ein.o] Error 1
29| make[2]: *** Waiting for unfinished jobs....
30| ../../sblim-sfcc-2.2.8/TEST/v2test_im.c: In function 'main':
31| ../../sblim-sfcc-2.2.8/TEST/v2test_im.c:82:40: warning: '%s' directive argument is null [-Wformat-overflow=]
32| 82 | printf( "invokeMethod() rc=%d, msg=%s\n",
33| | ^~
34
35Upstream-Status: Backport
36[https://github.com/kkaempf/sblim-sfcc/commit/881fccbaf19e26cbef3da1bebe2b42b3a9de1147#diff-ad9eeee99837ead0f29c70cd5f3956178dc3d51bd79618affd53d72a31404d5f]
37
38Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
39---
40 TEST/v2test_ec.c | 2 +-
41 TEST/v2test_ein.c | 2 +-
42 2 files changed, 2 insertions(+), 2 deletions(-)
43
44diff --git a/TEST/v2test_ec.c b/TEST/v2test_ec.c
45index 940ca57..72a93a5 100644
46--- a/TEST/v2test_ec.c
47+++ b/TEST/v2test_ec.c
48@@ -83,7 +83,7 @@ int main()
49 count = enm->ft->hasNext(enm, NULL) ;
50 while (count > 0) {
51 data = enm->ft->getNext(enm, NULL);
52- showClass(data.value.cls);
53+ showClass((CMPIConstClass *)data.value.cls);
54 /*
55 * see if we have any more
56 */
57diff --git a/TEST/v2test_ein.c b/TEST/v2test_ein.c
58index ede95c1..c9d1152 100644
59--- a/TEST/v2test_ein.c
60+++ b/TEST/v2test_ein.c
61@@ -93,7 +93,7 @@ int count = 0;
62
63 data = enm->ft->getNext(enm, NULL);
64
65- showObjectPath(data.value.ref);
66+ showObjectPath((CMPIObjectPath *)data.value.ref);
67 /*
68 * see if we have any more
69 */
70--
712.34.1
72
diff --git a/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc_2.2.8.bb b/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc_2.2.8.bb
index c9d3ddd6b2..7d5e1c4c24 100644
--- a/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc_2.2.8.bb
+++ b/meta-oe/recipes-extended/sblim-sfcc/sblim-sfcc_2.2.8.bb
@@ -5,6 +5,7 @@ HOMEPAGE = "http://www.sblim.org"
5SRC_URI = "http://netcologne.dl.sourceforge.net/project/sblim/${BPN}/${BPN}-${PV}.tar.bz2 \ 5SRC_URI = "http://netcologne.dl.sourceforge.net/project/sblim/${BPN}/${BPN}-${PV}.tar.bz2 \
6 file://0001-cimxml-Include-sys-select.h-for-fd_set.patch \ 6 file://0001-cimxml-Include-sys-select.h-for-fd_set.patch \
7 file://0001-Fix-implicit-function-declarations.patch \ 7 file://0001-Fix-implicit-function-declarations.patch \
8 file://0001-Fix-incompatible-pointer-type-error-with-gcc-option.patch \
8 " 9 "
9 10
10SRC_URI[md5sum] = "0bac0dec19f17ec065b6c332a56d7bae" 11SRC_URI[md5sum] = "0bac0dec19f17ec065b6c332a56d7bae"