diff options
author | Mingli Yu <mingli.yu@windriver.com> | 2021-04-30 11:05:38 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-04-29 20:17:20 -0700 |
commit | ee7598a40080c983e4b115f7730ebccc46c6ddb2 (patch) | |
tree | 0e4bc6df1dc668a67e54b76beddd748b2f298bf0 | |
parent | 5db9ca847fe0d942bc7b0574ab0fd5aadd9fbf23 (diff) | |
download | meta-openembedded-ee7598a40080c983e4b115f7730ebccc46c6ddb2.tar.gz |
tk: adapt to potential pseudo changes
It failed as below when rerun do_install for tk:
$ bitbake tk
$ bitbake tk -f -cinstall
[snip]
| NOTE: make -j 48 DESTDIR=/build/tmp/work/cortexa53-wrs-linux/tk/8.6.10-r0/image install
| abort()ing pseudo client by server request. See https://wiki.yoctoproject.org/wiki/Pseudo_Abort for more details on this.
| Check logfile: /build/tmp/work/cortexa53-wrs-linux/tk/8.6.10-r0/pseudo//pseudo.log
| Aborted (core dumped)
By default the S is ${WORKDIR}/${BPN}-${PV}, but after unpack,
the tk source [1] unpacked to ${WORKDIR}/${BPN}${PV} and all the
files under ${WORKDIR}/${BPN}${PV} are acutally the source files.
But the the main Makefile.in is under ${WORKDIR}/${BPN}${PV}/unix
for tk, so there is below logic in tk recipe:
S = "${WORKDIR}/${BPN}${PV}/unix"
To adapt the potential pseudo changes, there is a general logic to
exclude ${S} from pseudo database in base.bbclass [2] by default.
That's to say, just the dir ${WORKDIR}/${BPN}${PV}/unix is excluded
from the pseudo database for tk.
But it's not enough for tk, we need to exclude the actual source dir
${WORKDIR}/${BPN}${PV} from pseudo database specifically to fix the
above do_install failure.
[1] https://downloads.sourceforge.net/tcl/tk8.6.0-src.tar.gz
[2] https://git.openembedded.org/openembedded-core/tree/meta/classes/base.bbclass#n396
Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-devtools/tcltk/tk_8.6.10.bb | 2 |
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/tcltk/tk_8.6.10.bb b/meta-oe/recipes-devtools/tcltk/tk_8.6.10.bb index b564e12603..34fca8189e 100644 --- a/meta-oe/recipes-devtools/tcltk/tk_8.6.10.bb +++ b/meta-oe/recipes-devtools/tcltk/tk_8.6.10.bb | |||
@@ -28,6 +28,8 @@ SRC_URI[sha256sum] = "63df418a859d0a463347f95ded5cd88a3dd3aaa1ceecaeee362194bc30 | |||
28 | 28 | ||
29 | S = "${WORKDIR}/${BPN}${PV}/unix" | 29 | S = "${WORKDIR}/${BPN}${PV}/unix" |
30 | 30 | ||
31 | PSEUDO_IGNORE_PATHS .= ",${WORKDIR}/${BPN}${PV}" | ||
32 | |||
31 | # Short version format: "8.6" | 33 | # Short version format: "8.6" |
32 | VER = "${@os.path.splitext(d.getVar('PV'))[0]}" | 34 | VER = "${@os.path.splitext(d.getVar('PV'))[0]}" |
33 | 35 | ||