diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-06-24 18:16:26 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-06-25 10:22:41 -0700 |
commit | eef19bee9899f3e2c0fbeb98c68a476c3710e119 (patch) | |
tree | 28d650d985f0b41ff6e36fd917079ddb91e3f20f | |
parent | df0419f5be2a45711a3cfc63ce0d787c9491f90d (diff) | |
download | meta-openembedded-eef19bee9899f3e2c0fbeb98c68a476c3710e119.tar.gz |
python3-license-expression: Consolidate in a single file
Consolidate inc and bb files into a single bb file.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python-license-expression.inc | 29 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-license-expression_1.0.bb | 31 |
2 files changed, 29 insertions, 31 deletions
diff --git a/meta-python/recipes-devtools/python/python-license-expression.inc b/meta-python/recipes-devtools/python/python-license-expression.inc deleted file mode 100644 index add25810d7..0000000000 --- a/meta-python/recipes-devtools/python/python-license-expression.inc +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | SUMMARY = "Utility library to parse, compare, simplify and normalize license expressions" | ||
2 | HOMEPAGE = "https://github.com/nexB/license-expression" | ||
3 | |||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://apache-2.0.LICENSE;md5=e23fadd6ceef8c618fc1c65191d846fa" | ||
6 | |||
7 | SRC_URI[md5sum] = "81477f779099f55071c6a7b88a29bb01" | ||
8 | SRC_URI[sha256sum] = "8aaa455c5b97c4f2174090178b19792b2a1c620e80591aafd4e0a99b713f9e8d" | ||
9 | |||
10 | inherit pypi ptest | ||
11 | |||
12 | RDEPENDS_${PN} += "\ | ||
13 | ${PYTHON_PN}-booleanpy \ | ||
14 | " | ||
15 | |||
16 | BBCLASSEXTEND = "native nativesdk" | ||
17 | |||
18 | SRC_URI += " \ | ||
19 | file://run-ptest \ | ||
20 | " | ||
21 | |||
22 | RDEPENDS_${PN}-ptest += " \ | ||
23 | ${PYTHON_PN}-pytest \ | ||
24 | " | ||
25 | |||
26 | do_install_ptest() { | ||
27 | install -d ${D}${PTEST_PATH}/tests | ||
28 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
29 | } | ||
diff --git a/meta-python/recipes-devtools/python/python3-license-expression_1.0.bb b/meta-python/recipes-devtools/python/python3-license-expression_1.0.bb index 10a702ca45..b1c38e95da 100644 --- a/meta-python/recipes-devtools/python/python3-license-expression_1.0.bb +++ b/meta-python/recipes-devtools/python/python3-license-expression_1.0.bb | |||
@@ -1,2 +1,29 @@ | |||
1 | inherit setuptools3 | 1 | SUMMARY = "Utility library to parse, compare, simplify and normalize license expressions" |
2 | require python-license-expression.inc | 2 | HOMEPAGE = "https://github.com/nexB/license-expression" |
3 | |||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://apache-2.0.LICENSE;md5=e23fadd6ceef8c618fc1c65191d846fa" | ||
6 | |||
7 | SRC_URI[md5sum] = "81477f779099f55071c6a7b88a29bb01" | ||
8 | SRC_URI[sha256sum] = "8aaa455c5b97c4f2174090178b19792b2a1c620e80591aafd4e0a99b713f9e8d" | ||
9 | |||
10 | inherit pypi ptest setuptools3 | ||
11 | |||
12 | RDEPENDS_${PN} += "\ | ||
13 | ${PYTHON_PN}-booleanpy \ | ||
14 | " | ||
15 | |||
16 | BBCLASSEXTEND = "native nativesdk" | ||
17 | |||
18 | SRC_URI += " \ | ||
19 | file://run-ptest \ | ||
20 | " | ||
21 | |||
22 | RDEPENDS_${PN}-ptest += " \ | ||
23 | ${PYTHON_PN}-pytest \ | ||
24 | " | ||
25 | |||
26 | do_install_ptest() { | ||
27 | install -d ${D}${PTEST_PATH}/tests | ||
28 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
29 | } | ||