summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-01-07 22:27:32 +0800
committerKhem Raj <raj.khem@gmail.com>2022-01-07 11:29:09 -0800
commitf16f628d1f8c2ca37df10b2d84dea05d6b9ebab1 (patch)
tree89ff4cd5436a746eddd6a658ab0fe881328e4712
parentcf08deca8684054d93ab6c3a79ea762ff8af2f65 (diff)
downloadmeta-openembedded-f16f628d1f8c2ca37df10b2d84dea05d6b9ebab1.tar.gz
bats: upgrade 1.4.1 -> 1.5.0
0001-install.sh-consider-multilib.patch removed since it is included in 1.5.0 Changelog: Issues for this release <https://github.com/bats-core/bats-core/pull/####> ========= Added: --------- new command line flags (#488) --verbose-run: Make run print $output by default -x, --trace: Print test commands as they are executed (like set -x)` --show-output-of-passing-tests: Print output of passing tests --print-output-on-failure: Automatically print the value of $output on failed tests --gather-test-outputs-in <directory>: Gather the output of failing and passing tests as files in directory Experimental: add return code checks to run via !/-<N> (#367, #507) install.sh and uninstall.sh take an optional second parameter for the lib folder name to allow for multilib install, e.g. into lib64 (#452) add run flag --keep-empty-lines to retain empty lines in ${lines[@]} (#224, a894fbf) add run flag --separate-stderr which also fills $stderr and $stderr_lines (#47, 5c9b173d, #507) Fixed: --------- don't glob run's $output when splitting into ${lines[@]} (#151, #152, #158, #156, #281, #289) remove empty line after test with pretty formatter on some terminals (#481) don't run setup_file/teardown_file on files without tests, e.g. due to filtering (#484) print final line without newline on Bash 3.2 for midtest (ERREXIT) failures too (#495, #145) abort with error on missing flock/shlock when running in parallel mode (#496) improved set -u test and fixed some unset variable accesses (#498, #501) shorten suite/file/test temporary folder paths to leave enough space even on restricted systems (#503) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-test/bats/bats_1.5.0.bb (renamed from meta-oe/recipes-test/bats/bats_1.4.1.bb)6
-rw-r--r--meta-oe/recipes-test/bats/files/0001-install.sh-consider-multilib.patch43
2 files changed, 2 insertions, 47 deletions
diff --git a/meta-oe/recipes-test/bats/bats_1.4.1.bb b/meta-oe/recipes-test/bats/bats_1.5.0.bb
index 13babd5ea5..ffbb37c8a1 100644
--- a/meta-oe/recipes-test/bats/bats_1.4.1.bb
+++ b/meta-oe/recipes-test/bats/bats_1.5.0.bb
@@ -6,11 +6,9 @@ HOMEPAGE = "https://github.com/bats-core/bats-core"
6LICENSE = "MIT" 6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b" 7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b"
8 8
9SRC_URI = "git://github.com/bats-core/bats-core.git;branch=master;protocol=https \ 9SRC_URI = "git://github.com/bats-core/bats-core.git;branch=master;protocol=https"
10 file://0001-install.sh-consider-multilib.patch \
11 "
12# v1.4.1 10# v1.4.1
13SRCREV = "54e965fa9d269c2b3ff9036d81f32bac3df0edea" 11SRCREV = "99d64eb017abcd6a766dd0d354e625526da69cb3"
14 12
15S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
16 14
diff --git a/meta-oe/recipes-test/bats/files/0001-install.sh-consider-multilib.patch b/meta-oe/recipes-test/bats/files/0001-install.sh-consider-multilib.patch
deleted file mode 100644
index c7393ca2ed..0000000000
--- a/meta-oe/recipes-test/bats/files/0001-install.sh-consider-multilib.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From 6e3d01f1ff199383b78a7504858c374fbce05f4e Mon Sep 17 00:00:00 2001
2From: Kai Kang <kai.kang@windriver.com>
3Date: Thu, 10 Jun 2021 11:11:07 +0800
4Subject: [PATCH] install.sh: consider multilib
5
6It may install files to /usr/lib64 when multilib is enabled. Add an
7optional parameter for install.sh to support it.
8
9Upstream-Status: Submitted [https://github.com/bats-core/bats-core/pull/452]
10
11Signed-off-by: Kai Kang <kai.kang@windriver.com>
12---
13 install.sh | 5 +++--
14 1 file changed, 3 insertions(+), 2 deletions(-)
15
16diff --git a/install.sh b/install.sh
17index e660866..d91159e 100755
18--- a/install.sh
19+++ b/install.sh
20@@ -4,6 +4,7 @@ set -e
21
22 BATS_ROOT="${0%/*}"
23 PREFIX="$1"
24+BASELIB="${2:-lib}"
25
26 if [[ -z "$PREFIX" ]]; then
27 printf '%s\n' \
28@@ -12,10 +13,10 @@ if [[ -z "$PREFIX" ]]; then
29 exit 1
30 fi
31
32-install -d -m 755 "$PREFIX"/{bin,libexec/bats-core,lib/bats-core,share/man/man{1,7}}
33+install -d -m 755 "$PREFIX"/{bin,libexec/bats-core,${BASELIB}/bats-core,share/man/man{1,7}}
34 install -m 755 "$BATS_ROOT/bin"/* "$PREFIX/bin"
35 install -m 755 "$BATS_ROOT/libexec/bats-core"/* "$PREFIX/libexec/bats-core"
36-install -m 755 "$BATS_ROOT/lib/bats-core"/* "$PREFIX/lib/bats-core"
37+install -m 755 "$BATS_ROOT/lib/bats-core"/* "$PREFIX/${BASELIB}/bats-core"
38 install -m 644 "$BATS_ROOT/man/bats.1" "$PREFIX/share/man/man1"
39 install -m 644 "$BATS_ROOT/man/bats.7" "$PREFIX/share/man/man7"
40
41--
422.17.1
43