summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-04-09 13:27:39 -0700
committerKhem Raj <raj.khem@gmail.com>2020-04-09 13:29:11 -0700
commitf47c88c4cde799e69e3e541a4ceceddf2f0bf484 (patch)
tree72f0a6619bc7552a263055c040ae82d2e48fb6a4
parentea55f0c735c733a28762c0db31f49a87a37dc059 (diff)
downloadmeta-openembedded-f47c88c4cde799e69e3e541a4ceceddf2f0bf484.tar.gz
abseil-cpp: Fix build on musl/mips
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0001-absl-always-use-asm-sgidefs.h.patch38
-rw-r--r--meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb1
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0001-absl-always-use-asm-sgidefs.h.patch b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0001-absl-always-use-asm-sgidefs.h.patch
new file mode 100644
index 0000000000..6bb59d9336
--- /dev/null
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp/0001-absl-always-use-asm-sgidefs.h.patch
@@ -0,0 +1,38 @@
1From 14229e8c6f42a96e4d725124193ceefa54e5e1a4 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 9 Apr 2020 13:06:27 -0700
4Subject: [PATCH] absl: always use <asm/sgidefs.h>
5
6Fixes mips/musl build, since sgidefs.h is not present on all C libraries
7but on linux asm/sgidefs.h is there and contains same definitions, using
8that makes it portable.
9
10Upstream-Status: Pending
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 absl/base/internal/direct_mmap.h | 6 +-----
15 1 file changed, 1 insertion(+), 5 deletions(-)
16
17diff --git a/absl/base/internal/direct_mmap.h b/absl/base/internal/direct_mmap.h
18index 2e5e422..c515325 100644
19--- a/absl/base/internal/direct_mmap.h
20+++ b/absl/base/internal/direct_mmap.h
21@@ -41,13 +41,9 @@
22
23 #ifdef __mips__
24 // Include definitions of the ABI currently in use.
25-#ifdef __BIONIC__
26-// Android doesn't have sgidefs.h, but does have asm/sgidefs.h, which has the
27+// bionic/musl C libs don't have sgidefs.h, but do have asm/sgidefs.h, which has the
28 // definitions we need.
29 #include <asm/sgidefs.h>
30-#else
31-#include <sgidefs.h>
32-#endif // __BIONIC__
33 #endif // __mips__
34
35 // SYS_mmap and SYS_munmap are not defined in Android.
36--
372.26.0
38
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
index b6ea5fdecc..9a44133c56 100644
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
@@ -15,6 +15,7 @@ SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH} \
15 file://0002-Add-forgotten-ABSL_HAVE_VDSO_SUPPORT-conditional.patch \ 15 file://0002-Add-forgotten-ABSL_HAVE_VDSO_SUPPORT-conditional.patch \
16 file://0003-Add-fPIC-option.patch \ 16 file://0003-Add-fPIC-option.patch \
17 file://0001-Add-RISCV-support-to-GetProgramCounter.patch \ 17 file://0001-Add-RISCV-support-to-GetProgramCounter.patch \
18 file://0001-absl-always-use-asm-sgidefs.h.patch \
18 " 19 "
19 20
20S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"