summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSakib Sajal <sakib.sajal@windriver.com>2020-09-22 12:07:51 -0400
committerKhem Raj <raj.khem@gmail.com>2020-09-22 10:19:13 -0700
commitf5df715e2c8717fcc6c83c7da3e2a0b7334c3a3c (patch)
tree4c91f928c6841e19dc253d7b02b1838fd9620e44
parentd7c8d85f959a693690bbf4d99102e8a68e78df13 (diff)
downloadmeta-openembedded-f5df715e2c8717fcc6c83c7da3e2a0b7334c3a3c.tar.gz
libssh2: enable ptest
Signed-off-by: Sakib Sajal <sakib.sajal@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/libssh2/files/run-ptest7
-rw-r--r--meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb17
2 files changed, 23 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libssh2/files/run-ptest b/meta-oe/recipes-support/libssh2/files/run-ptest
new file mode 100644
index 0000000000..2a7922f1aa
--- /dev/null
+++ b/meta-oe/recipes-support/libssh2/files/run-ptest
@@ -0,0 +1,7 @@
1#!/bin/sh
2
3ptestdir=$(dirname "$(readlink -f "$0")")
4for test in $(ls $ptestdir/tests)
5do
6 ./test-driver --test-name $test --log-file $test.log --trs-file $test.trs --color-tests no --enable-hard-errors yes --expect-failure no -- ./tests/$test
7done
diff --git a/meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb b/meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb
index c1f337a440..a1d85617a6 100644
--- a/meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb
+++ b/meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb
@@ -9,11 +9,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c5cf34fc0acb44b082ef50ef5e4354ca"
9 9
10SRC_URI = "http://www.libssh2.org/download/${BP}.tar.gz \ 10SRC_URI = "http://www.libssh2.org/download/${BP}.tar.gz \
11 file://CVE-2019-17498.patch \ 11 file://CVE-2019-17498.patch \
12 file://run-ptest \
12" 13"
13SRC_URI[md5sum] = "1beefafe8963982adc84b408b2959927" 14SRC_URI[md5sum] = "1beefafe8963982adc84b408b2959927"
14SRC_URI[sha256sum] = "d5fb8bd563305fd1074dda90bd053fb2d29fc4bce048d182f96eaa466dfadafd" 15SRC_URI[sha256sum] = "d5fb8bd563305fd1074dda90bd053fb2d29fc4bce048d182f96eaa466dfadafd"
15 16
16inherit autotools pkgconfig 17inherit autotools pkgconfig ptest
17 18
18EXTRA_OECONF += "\ 19EXTRA_OECONF += "\
19 --with-libz \ 20 --with-libz \
@@ -26,3 +27,17 @@ PACKAGECONFIG[openssl] = "--with-crypto=openssl --with-libssl-prefix=${STAGING_L
26PACKAGECONFIG[gcrypt] = "--with-crypto=libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR}, , libgcrypt" 27PACKAGECONFIG[gcrypt] = "--with-crypto=libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR}, , libgcrypt"
27 28
28BBCLASSEXTEND = "native nativesdk" 29BBCLASSEXTEND = "native nativesdk"
30
31RDEPENDS_${PN}-ptest = "bash"
32
33do_compile_ptest() {
34 sed -i "/\$(MAKE) \$(AM_MAKEFLAGS) check-TESTS/d" tests/Makefile
35 oe_runmake check
36}
37
38do_install_ptest() {
39 install -d ${D}${PTEST_PATH}/tests
40 install -m 0755 ${B}/tests/.libs/simple ${D}${PTEST_PATH}/tests/
41 install -m 0755 ${S}/tests/mansyntax.sh ${D}${PTEST_PATH}/tests/
42 install -m 0755 ${S}/test-driver ${D}${PTEST_PATH}/
43}