summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2025-04-27 20:53:04 +0200
committerKhem Raj <raj.khem@gmail.com>2025-04-27 15:23:47 -0700
commitfe472f5a8363328ef0ef1453beb64ea82dd7ecef (patch)
treedf6a9f3e8cf4536f5cd79f3838a3cd3f90cd21e2
parent0ccc751f13fafe5e5b28ba1565fe43f988d830ab (diff)
downloadmeta-openembedded-fe472f5a8363328ef0ef1453beb64ea82dd7ecef.tar.gz
xfstests: bstat: use uint32_t instead of __uint32_t to fix build with musl
* with musl this fails with: http://errors.yoctoproject.org/Errors/Details/853041/ bstat.c:65:33: error: unknown type name '__uint32_t'; did you mean 'uint32_t'? 65 | static inline int xfs_highbit32(__uint32_t v) | ^~~~~~~~~~ | uint32_t Signed-off-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-filesystems/recipes-utils/xfstests/xfstests/0001-bstat-use-uint32_t-instead-of-__uint32_t-to-fix-buil.patch33
-rw-r--r--meta-filesystems/recipes-utils/xfstests/xfstests_2025.03.30.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/xfstests/xfstests/0001-bstat-use-uint32_t-instead-of-__uint32_t-to-fix-buil.patch b/meta-filesystems/recipes-utils/xfstests/xfstests/0001-bstat-use-uint32_t-instead-of-__uint32_t-to-fix-buil.patch
new file mode 100644
index 0000000000..6ac2dd92b4
--- /dev/null
+++ b/meta-filesystems/recipes-utils/xfstests/xfstests/0001-bstat-use-uint32_t-instead-of-__uint32_t-to-fix-buil.patch
@@ -0,0 +1,33 @@
1From c3cc5c68a297a98adb9a7046c7563d0678245243 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <martin.jansa@gmail.com>
3Date: Sun, 27 Apr 2025 20:29:09 +0200
4Subject: [PATCH] bstat: use uint32_t instead of __uint32_t to fix build with
5 musl
6
7* with musl this fails with:
8 http://errors.yoctoproject.org/Errors/Details/853041/
9
10bstat.c:65:33: error: unknown type name '__uint32_t'; did you mean 'uint32_t'?
11 65 | static inline int xfs_highbit32(__uint32_t v)
12 | ^~~~~~~~~~
13 | uint32_t
14
15Upstream-Status: Pending
16Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
17---
18 src/bstat.c | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/src/bstat.c b/src/bstat.c
22index 9a028a0d..a833af59 100644
23--- a/src/bstat.c
24+++ b/src/bstat.c
25@@ -62,7 +62,7 @@ static inline int fls(int x)
26 return r;
27 }
28
29-static inline int xfs_highbit32(__uint32_t v)
30+static inline int xfs_highbit32(uint32_t v)
31 {
32 return fls(v) - 1;
33 }
diff --git a/meta-filesystems/recipes-utils/xfstests/xfstests_2025.03.30.bb b/meta-filesystems/recipes-utils/xfstests/xfstests_2025.03.30.bb
index 5a6affa078..55b509549a 100644
--- a/meta-filesystems/recipes-utils/xfstests/xfstests_2025.03.30.bb
+++ b/meta-filesystems/recipes-utils/xfstests/xfstests_2025.03.30.bb
@@ -12,6 +12,7 @@ SRC_URI = "git://git.kernel.org/pub/scm/fs/xfs/xfstests-dev.git;branch=master;ta
12 file://0002-Drop-detached_mounts_propagation-and-remove-sys-moun.patch \ 12 file://0002-Drop-detached_mounts_propagation-and-remove-sys-moun.patch \
13 file://0001-include-libgen.h-for-basename-API-prototype.patch \ 13 file://0001-include-libgen.h-for-basename-API-prototype.patch \
14 file://0002-Add-missing-STATX_ATTR_-defines-from-musl-sys-stat.h.patch \ 14 file://0002-Add-missing-STATX_ATTR_-defines-from-musl-sys-stat.h.patch \
15 file://0001-bstat-use-uint32_t-instead-of-__uint32_t-to-fix-buil.patch \
15 " 16 "
16 17
17S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"