summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-04-07 15:25:18 -0700
committerArmin Kuster <akuster808@gmail.com>2018-04-13 12:43:40 -0700
commit68c8fe1aba92ca2ed5e1156fa0050609ab4f73af (patch)
tree0b97556ce77ef357924cab0df45284778f8a08f6 /meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch
parentc3b41c1f3cdb3f2c4b39e295c36c01a1b43abb74 (diff)
downloadmeta-openembedded-68c8fe1aba92ca2ed5e1156fa0050609ab4f73af.tar.gz
squid: refresh patches
ARNING: Some of the context lines in patches were ignored. This can lead to incorrectly applied patches. The context lines in the patches can be updated with devtool: devtool modify <recipe> devtool finish --force-patch-refresh <recipe> <layer_path> Then the updated patches and the source tree (in devtool's workspace) should be reviewed to make sure the patches apply in the correct place and don't introduce duplicate lines (which can, and does happen when some of the context is ignored). Further information: http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450 Details: checking file configure.ac Hunk #1 succeeded at 27 with fuzz 1 (offset 8 lines). and others Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch')
-rw-r--r--meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch19
1 files changed, 14 insertions, 5 deletions
diff --git a/meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch b/meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch
index cc1ea78a55..2feca4986e 100644
--- a/meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch
+++ b/meta-networking/recipes-daemons/squid/files/gcc7-fixes.patch
@@ -1,11 +1,20 @@
1../../squid-3.5.26/src/DiskIO/DiskThreads/aiops.cc: In function 'void squidaio_init()': ../../squid-3.5.26/src/DiskIO/DiskThreads/DiskThreads.h:30:50: error: '*' in boolean context, suggest '&&' instead [-Werror=int-in-bool-context] #define NUMTHREADS (Config.cacheSwap.n_configured*16) 1From 660fce9cfa00a57e5b7cec46116a31e21595c306 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 19 Jun 2017 23:47:01 -0700
4Subject: [PATCH] squid: Upgrade to 3.5.26
2 5
6../../squid-3.5.26/src/DiskIO/DiskThreads/aiops.cc: In function 'void squidaio_init()': ../../squid-3.5.26/src/DiskIO/DiskThreads/DiskThreads.h:30:50: error: '*' in boolean context, suggest '&&' instead [-Werror=int-in-bool-context] #define NUMTHREADS (Config.cacheSwap.n_configured*16)
3 7
4Upstream-Status: Backport 8Upstream-Status: Backport
5Index: squid-3.5.26/src/DiskIO/DiskThreads/aiops.cc 9
6=================================================================== 10---
7--- squid-3.5.26.orig/src/DiskIO/DiskThreads/aiops.cc 11 src/DiskIO/DiskThreads/aiops.cc | 2 +-
8+++ squid-3.5.26/src/DiskIO/DiskThreads/aiops.cc 12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/src/DiskIO/DiskThreads/aiops.cc b/src/DiskIO/DiskThreads/aiops.cc
15index b44adfa..e11f948 100644
16--- a/src/DiskIO/DiskThreads/aiops.cc
17+++ b/src/DiskIO/DiskThreads/aiops.cc
9@@ -290,7 +290,7 @@ squidaio_init(void) 18@@ -290,7 +290,7 @@ squidaio_init(void)
10 /* Create threads and get them to sit in their wait loop */ 19 /* Create threads and get them to sit in their wait loop */
11 squidaio_thread_pool = memPoolCreate("aio_thread", sizeof(squidaio_thread_t)); 20 squidaio_thread_pool = memPoolCreate("aio_thread", sizeof(squidaio_thread_t));