diff options
author | Dan McDougall <daniel.mcdougall@liftoffsoftware.com> | 2012-06-08 20:52:38 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-06-20 13:36:28 +0200 |
commit | 43010e86aa505afa878a9a8797db59b7cfd81ac6 (patch) | |
tree | f132d0e8bc6e65fd22c331e6519ba8b00b8c7e37 /meta-oe/recipes-devtools/python/python-matplotlib/fix_setup.patch | |
parent | cdfe54310d11191fad462ed8425d5265da93fb37 (diff) | |
download | meta-openembedded-43010e86aa505afa878a9a8797db59b7cfd81ac6.tar.gz |
python-matplotlib : Add recipe for matplotlib 1.1.0.
Adding python-matplotlib recipe. I'm sure many folks will find this useful.
Signed-off-by: Dan McDougall <daniel.mcdougall@liftoffsoftware.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/python/python-matplotlib/fix_setup.patch')
-rw-r--r-- | meta-oe/recipes-devtools/python/python-matplotlib/fix_setup.patch | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-matplotlib/fix_setup.patch b/meta-oe/recipes-devtools/python/python-matplotlib/fix_setup.patch new file mode 100644 index 0000000000..9381583537 --- /dev/null +++ b/meta-oe/recipes-devtools/python/python-matplotlib/fix_setup.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | This fixes the dependency checks inside of setup.py since things like | ||
2 | 'import numpy' won't work with bitbake. | ||
3 | |||
4 | diff --git a/setup.py b/setup.py | ||
5 | index 2f13821..e6d6ed0 100644 | ||
6 | --- a/setup.py | ||
7 | +++ b/setup.py | ||
8 | @@ -113,12 +113,6 @@ if 1: | ||
9 | baseline_images = [chop_package(f) for f in baseline_images] | ||
10 | package_data['matplotlib'].extend(baseline_images) | ||
11 | |||
12 | -if not check_for_numpy(): | ||
13 | - sys.exit(1) | ||
14 | - | ||
15 | -if not check_for_freetype(): | ||
16 | - sys.exit(1) | ||
17 | - | ||
18 | build_ft2font(ext_modules, packages) | ||
19 | build_ttconv(ext_modules, packages) | ||
20 | build_contour(ext_modules, packages) | ||
21 | @@ -129,7 +123,7 @@ build_tri(ext_modules, packages) | ||
22 | |||
23 | print_raw("") | ||
24 | print_raw("OPTIONAL BACKEND DEPENDENCIES") | ||
25 | -has_libpng = check_for_libpng() | ||
26 | +has_libpng = True | ||
27 | |||
28 | if has_libpng and options['build_agg']: | ||
29 | build_agg(ext_modules, packages) | ||