diff options
author | Gianfranco Costamagna <costamagna.gianfranco@gmail.com> | 2018-08-06 10:29:17 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-08-08 12:04:13 -0700 |
commit | 47d2bfaff1336ac47ca187bbeade88693a6a79dd (patch) | |
tree | 20642c0fd3d923f068e97ce7a4ce1b3e7086f928 /meta-oe/recipes-support/cpprest/cpprest-2.10.3/fix-cmake-install.patch | |
parent | 19b47730e079aacceb04fbb6d77247158d90f87c (diff) | |
download | meta-openembedded-47d2bfaff1336ac47ca187bbeade88693a6a79dd.tar.gz |
cpprest: update to new 2.10.3 release, simplify recipe now that it has a cmake file in the root location
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/cpprest/cpprest-2.10.3/fix-cmake-install.patch')
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest-2.10.3/fix-cmake-install.patch | 59 |
1 files changed, 59 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.3/fix-cmake-install.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/fix-cmake-install.patch new file mode 100644 index 0000000000..4d03e6d282 --- /dev/null +++ b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/fix-cmake-install.patch | |||
@@ -0,0 +1,59 @@ | |||
1 | Description: install cmake files into /usr/lib/cmake/cpprestsdk | ||
2 | Author: Gianfranco Costamagna <locutusofborg@debian.org> | ||
3 | Upstream-Status: https://github.com/Microsoft/cpprestsdk/pull/737 | ||
4 | Forwarded: https://github.com/Microsoft/cpprestsdk/pull/737 | ||
5 | Last-Update: 2018-04-19 | ||
6 | |||
7 | Index: cpprest/Release/CMakeLists.txt | ||
8 | =================================================================== | ||
9 | --- cpprest.orig/Release/CMakeLists.txt | ||
10 | +++ cpprest/Release/CMakeLists.txt | ||
11 | @@ -18,7 +18,6 @@ | ||
12 | set(WERROR ON CACHE BOOL "Treat Warnings as Errors.") | ||
13 | set(CPPREST_EXCLUDE_WEBSOCKETS OFF CACHE BOOL "Exclude websockets functionality.") | ||
14 | set(CPPREST_EXCLUDE_COMPRESSION OFF CACHE BOOL "Exclude compression functionality.") | ||
15 | -set(CPPREST_EXPORT_DIR lib/cpprestsdk CACHE STRING "Directory to install CMake config files.") | ||
16 | set(CPPREST_INSTALL_HEADERS ON CACHE BOOL "Install header files.") | ||
17 | set(CPPREST_INSTALL ON CACHE BOOL "Add install commands.") | ||
18 | |||
19 | @@ -63,6 +62,9 @@ | ||
20 | include(cmake/cpprest_find_openssl.cmake) | ||
21 | include(cmake/cpprest_find_websocketpp.cmake) | ||
22 | include(CheckIncludeFiles) | ||
23 | +if(UNIX) | ||
24 | +include(GNUInstallDirs) | ||
25 | +endif(UNIX) | ||
26 | |||
27 | find_package(Threads REQUIRED) | ||
28 | if(THREADS_HAVE_PTHREAD_ARG) | ||
29 | Index: cpprest/Release/src/CMakeLists.txt | ||
30 | =================================================================== | ||
31 | --- cpprest.orig/Release/src/CMakeLists.txt | ||
32 | +++ cpprest/Release/src/CMakeLists.txt | ||
33 | @@ -253,21 +253,21 @@ | ||
34 | install( | ||
35 | TARGETS ${CPPREST_TARGETS} | ||
36 | EXPORT cpprestsdk-targets | ||
37 | - RUNTIME DESTINATION bin | ||
38 | - LIBRARY DESTINATION lib | ||
39 | - ARCHIVE DESTINATION lib | ||
40 | + RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} | ||
41 | + LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} | ||
42 | + ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR} | ||
43 | ) | ||
44 | |||
45 | configure_file(../cmake/cpprestsdk-config.in.cmake "${CMAKE_CURRENT_BINARY_DIR}/cpprestsdk-config.cmake" @ONLY) | ||
46 | |||
47 | install( | ||
48 | FILES "${CMAKE_CURRENT_BINARY_DIR}/cpprestsdk-config.cmake" | ||
49 | - DESTINATION ${CPPREST_EXPORT_DIR} | ||
50 | + DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake | ||
51 | ) | ||
52 | install( | ||
53 | EXPORT cpprestsdk-targets | ||
54 | FILE cpprestsdk-targets.cmake | ||
55 | NAMESPACE cpprestsdk:: | ||
56 | - DESTINATION ${CPPREST_EXPORT_DIR} | ||
57 | + DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake | ||
58 | ) | ||
59 | endif() | ||