diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2017-07-05 05:13:17 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-14 23:44:30 +0200 |
commit | 1acfde8120eaa290df64f709e5a322bd6a44d19c (patch) | |
tree | 13d387707da99934f98ba276efe497f0d8c40388 /meta-oe/recipes-support/multipath-tools/files/shared-libs-avoid-linking-.so-as-executable.patch | |
parent | 5688c8e24cf106f8248ea44e98ba15931844ed9b (diff) | |
download | meta-openembedded-1acfde8120eaa290df64f709e5a322bd6a44d19c.tar.gz |
multipath-tools: 0.6.4 -> 0.7.1
1. In fedora/redhat, it is renamed to device-mapper-multipath,
use PROVIDE and RPROVIDE to support.
2. Split ${PN}-libs
3. Add multipath.conf.example
4. Backport patches from fedora:
git://pkgs.fedoraproject.org/rpms/device-mapper-multipath
- 0001 ~ 0011
5. Rebase local patches:
- makefile_inc.patch -> 0012-multipath-tools-modify-Makefile.inc-for-cross-compil.patch
- always-use-libdevmapper.patch -> 0013-Always-use-devmapper.patch
- always-use-libdevmapper-kpartx.patch -> 0014-Always-use-devmapper-for-kpartx.patch
6. Drop obsolete patches:
- 0001-multipathd.service-Error-fix.patch
- shared-libs-avoid-linking-.so-as-executable.patch
- checkers-disable-libcheckrbd.so.patch
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/multipath-tools/files/shared-libs-avoid-linking-.so-as-executable.patch')
-rw-r--r-- | meta-oe/recipes-support/multipath-tools/files/shared-libs-avoid-linking-.so-as-executable.patch | 55 |
1 files changed, 0 insertions, 55 deletions
diff --git a/meta-oe/recipes-support/multipath-tools/files/shared-libs-avoid-linking-.so-as-executable.patch b/meta-oe/recipes-support/multipath-tools/files/shared-libs-avoid-linking-.so-as-executable.patch deleted file mode 100644 index 88579e6aab..0000000000 --- a/meta-oe/recipes-support/multipath-tools/files/shared-libs-avoid-linking-.so-as-executable.patch +++ /dev/null | |||
@@ -1,55 +0,0 @@ | |||
1 | From 4311856200480288494df8df737f71ea316592d0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Patrick Ohly <patrick.ohly@intel.com> | ||
3 | Date: Thu, 26 Jan 2017 15:28:34 +0100 | ||
4 | Subject: [PATCH] shared libs: avoid linking .so as executable | ||
5 | |||
6 | When the OE build systems sets CFLAGS including -pie, gcc overrides | ||
7 | the earlier -shared parameter and tries to link a binary, leading to | ||
8 | errors about missing functions like main(). | ||
9 | |||
10 | Reordering the parameters so that -shared comes after CFLAGS | ||
11 | fixes this. | ||
12 | |||
13 | Upstream-Status: Inappropriate [OE specific, -pie shouldn't be in CFLAGS?!] | ||
14 | |||
15 | Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> | ||
16 | --- | ||
17 | diff --git a/libmpathcmd/Makefile b/libmpathcmd/Makefile | ||
18 | index 457c4ca..f68c82c 100644 | ||
19 | --- a/libmpathcmd/Makefile | ||
20 | +++ b/libmpathcmd/Makefile | ||
21 | @@ -9,7 +9,7 @@ OBJS = mpath_cmd.o | ||
22 | all: $(LIBS) | ||
23 | |||
24 | $(LIBS): $(OBJS) | ||
25 | - $(CC) $(LDFLAGS) $(SHARED_FLAGS) -Wl,-soname=$@ $(CFLAGS) -o $@ $(OBJS) $(LIBDEPS) | ||
26 | + $(CC) $(LDFLAGS) $(CFLAGS) $(SHARED_FLAGS) -Wl,-soname=$@ -o $@ $(OBJS) $(LIBDEPS) | ||
27 | $(LN) $@ $(DEVLIB) | ||
28 | |||
29 | install: $(LIBS) | ||
30 | diff --git a/libmpathpersist/Makefile b/libmpathpersist/Makefile | ||
31 | index 6e43427..2486302 100644 | ||
32 | --- a/libmpathpersist/Makefile | ||
33 | +++ b/libmpathpersist/Makefile | ||
34 | @@ -15,7 +15,7 @@ all: $(LIBS) | ||
35 | |||
36 | $(LIBS): | ||
37 | $(CC) -c $(CFLAGS) *.c | ||
38 | - $(CC) $(LDFLAGS) $(SHARED_FLAGS) $(LIBDEPS) -Wl,-soname=$@ $(CFLAGS) -o $@ $(OBJS) | ||
39 | + $(CC) $(LDFLAGS) $(CFLAGS) $(SHARED_FLAGS) $(LIBDEPS) -Wl,-soname=$@ -o $@ $(OBJS) | ||
40 | $(LN) $(LIBS) $(DEVLIB) | ||
41 | $(GZIP) mpath_persistent_reserve_in.3 > mpath_persistent_reserve_in.3.gz | ||
42 | $(GZIP) mpath_persistent_reserve_out.3 > mpath_persistent_reserve_out.3.gz | ||
43 | diff --git a/libmultipath/Makefile b/libmultipath/Makefile | ||
44 | index 495cebe..752bcc0 100644 | ||
45 | --- a/libmultipath/Makefile | ||
46 | +++ b/libmultipath/Makefile | ||
47 | @@ -55,7 +55,7 @@ OBJS = memory.o parser.o vector.o devmapper.o callout.o \ | ||
48 | all: $(LIBS) | ||
49 | |||
50 | $(LIBS): $(OBJS) | ||
51 | - $(CC) $(LDFLAGS) $(SHARED_FLAGS) -Wl,-soname=$@ $(CFLAGS) -o $@ $(OBJS) $(LIBDEPS) | ||
52 | + $(CC) $(LDFLAGS) $(CFLAGS) $(SHARED_FLAGS) -Wl,-soname=$@ -o $@ $(OBJS) $(LIBDEPS) | ||
53 | $(LN) $@ $(DEVLIB) | ||
54 | |||
55 | install: | ||