summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.30.bb
diff options
context:
space:
mode:
authorJens Rehsack <sno@netbsd.org>2018-08-28 15:21:06 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-28 09:37:00 -0700
commit1fd61636f9f6451b63b879ed34b8b3eff4c67d45 (patch)
treeecea9e87a3f5b40ce3be3ed6b34641ac274450aa /meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.30.bb
parent0a83476cac91ee1ea19f4e220bb986b5e111751f (diff)
downloadmeta-openembedded-1fd61636f9f6451b63b879ed34b8b3eff4c67d45.tar.gz
libcrypt-openssl-rsa-perl: Update to 0.30
Update recipe for CPAN hosted Perl5 module Crypt::OpenSSL::RSA from 0.28 to 0.30 to fix build issues when using openssl 1.1 and to express our love to the Perl Programming Language. LICENSE checksum updated because of: f0a2ed2 Purge trailing whitespace Changes since 0.28: https://metacpan.org/changes/release/TODDR/Crypt-OpenSSL-RSA-0.30 Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.30.bb')
-rw-r--r--meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.30.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.30.bb b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.30.bb
new file mode 100644
index 0000000000..0a2ad8aa44
--- /dev/null
+++ b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.30.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Crypt Openssl RSA cpan module"
2SECTION = "libs"
3LICENSE = "Artistic-1.0 | GPL-1.0+"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a67ceecc5d9a91a5a0d003ba50c26346"
5
6SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-RSA-${PV}.tar.gz "
7
8SRC_URI[md5sum] = "10bca2fc6d0ba1aa329f227424ae87d5"
9SRC_URI[sha256sum] = "23e13531397af102db4fd24bcf70137add7c85c23cca697c43aa71c2959a29ac"
10
11DEPENDS += "libcrypt-openssl-guess-native openssl"
12
13RDEPENDS_${PN}="libcrypt-openssl-random-perl"
14
15EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'"
16
17S = "${WORKDIR}/Crypt-OpenSSL-RSA-${PV}"
18
19inherit cpan
20
21do_compile() {
22 export OTHERLDFLAGS='-Wl,-rpath'
23 cpan_do_compile
24}