diff options
author | Jens Rehsack <sno@netbsd.org> | 2018-08-28 15:21:06 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-08-28 09:37:00 -0700 |
commit | 1fd61636f9f6451b63b879ed34b8b3eff4c67d45 (patch) | |
tree | ecea9e87a3f5b40ce3be3ed6b34641ac274450aa /meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.30.bb | |
parent | 0a83476cac91ee1ea19f4e220bb986b5e111751f (diff) | |
download | meta-openembedded-1fd61636f9f6451b63b879ed34b8b3eff4c67d45.tar.gz |
libcrypt-openssl-rsa-perl: Update to 0.30
Update recipe for CPAN hosted Perl5 module Crypt::OpenSSL::RSA
from 0.28 to 0.30 to fix build issues when using openssl 1.1 and
to express our love to the Perl Programming Language.
LICENSE checksum updated because of:
f0a2ed2 Purge trailing whitespace
Changes since 0.28: https://metacpan.org/changes/release/TODDR/Crypt-OpenSSL-RSA-0.30
Signed-off-by: Jens Rehsack <sno@netbsd.org>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.30.bb')
-rw-r--r-- | meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.30.bb | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.30.bb b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.30.bb new file mode 100644 index 0000000000..0a2ad8aa44 --- /dev/null +++ b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.30.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | SUMMARY = "Crypt Openssl RSA cpan module" | ||
2 | SECTION = "libs" | ||
3 | LICENSE = "Artistic-1.0 | GPL-1.0+" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a67ceecc5d9a91a5a0d003ba50c26346" | ||
5 | |||
6 | SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-RSA-${PV}.tar.gz " | ||
7 | |||
8 | SRC_URI[md5sum] = "10bca2fc6d0ba1aa329f227424ae87d5" | ||
9 | SRC_URI[sha256sum] = "23e13531397af102db4fd24bcf70137add7c85c23cca697c43aa71c2959a29ac" | ||
10 | |||
11 | DEPENDS += "libcrypt-openssl-guess-native openssl" | ||
12 | |||
13 | RDEPENDS_${PN}="libcrypt-openssl-random-perl" | ||
14 | |||
15 | EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'" | ||
16 | |||
17 | S = "${WORKDIR}/Crypt-OpenSSL-RSA-${PV}" | ||
18 | |||
19 | inherit cpan | ||
20 | |||
21 | do_compile() { | ||
22 | export OTHERLDFLAGS='-Wl,-rpath' | ||
23 | cpan_do_compile | ||
24 | } | ||