diff options
author | Tim Orling <ticotimo@gmail.com> | 2024-02-19 20:10:24 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-02-19 23:22:24 -0800 |
commit | 94c20e1ef4d7bd1dde1003cde25b9adb1ccc8310 (patch) | |
tree | 660b031c78987c950276b88e25731fff42588c49 /meta-python/classes | |
parent | 16935136bd80c1ce832a86bd1972d2e5d4c061d6 (diff) | |
download | meta-openembedded-94c20e1ef4d7bd1dde1003cde25b9adb1ccc8310.tar.gz |
meta-python: drop ${PYTHON_PN}
python 2 is long unsupported, so we no longer need this variable.
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/classes')
-rw-r--r-- | meta-python/classes/distutils3-base.bbclass | 6 | ||||
-rw-r--r-- | meta-python/classes/distutils3.bbclass | 8 |
2 files changed, 7 insertions, 7 deletions
diff --git a/meta-python/classes/distutils3-base.bbclass b/meta-python/classes/distutils3-base.bbclass index 850c535bb1..4f13ea6fe7 100644 --- a/meta-python/classes/distutils3-base.bbclass +++ b/meta-python/classes/distutils3-base.bbclass | |||
@@ -1,6 +1,6 @@ | |||
1 | DEPENDS:append:class-target = " ${PYTHON_PN}-native ${PYTHON_PN}" | 1 | DEPENDS:append:class-target = " python3-native python3" |
2 | DEPENDS:append:class-nativesdk = " ${PYTHON_PN}-native ${PYTHON_PN}" | 2 | DEPENDS:append:class-nativesdk = " python3-native python3" |
3 | RDEPENDS:${PN} += "${@['', '${PYTHON_PN}-core']['${CLASSOVERRIDE}' == 'class-target']}" | 3 | RDEPENDS:${PN} += "${@['', 'python3-core']['${CLASSOVERRIDE}' == 'class-target']}" |
4 | 4 | ||
5 | inherit distutils-common-base python3native python3targetconfig | 5 | inherit distutils-common-base python3native python3targetconfig |
6 | 6 | ||
diff --git a/meta-python/classes/distutils3.bbclass b/meta-python/classes/distutils3.bbclass index a6d8e8763f..909415efa0 100644 --- a/meta-python/classes/distutils3.bbclass +++ b/meta-python/classes/distutils3.bbclass | |||
@@ -27,9 +27,9 @@ distutils3_do_compile() { | |||
27 | NO_FETCH_BUILD=1 \ | 27 | NO_FETCH_BUILD=1 \ |
28 | STAGING_INCDIR=${STAGING_INCDIR} \ | 28 | STAGING_INCDIR=${STAGING_INCDIR} \ |
29 | STAGING_LIBDIR=${STAGING_LIBDIR} \ | 29 | STAGING_LIBDIR=${STAGING_LIBDIR} \ |
30 | ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py \ | 30 | ${STAGING_BINDIR_NATIVE}/python3-native/python3 setup.py \ |
31 | build --build-base=${B} ${DISTUTILS_BUILD_ARGS} || \ | 31 | build --build-base=${B} ${DISTUTILS_BUILD_ARGS} || \ |
32 | bbfatal_log "'${PYTHON_PN} setup.py build ${DISTUTILS_BUILD_ARGS}' execution failed." | 32 | bbfatal_log "'python3 setup.py build ${DISTUTILS_BUILD_ARGS}' execution failed." |
33 | } | 33 | } |
34 | distutils3_do_compile[vardepsexclude] = "MACHINE" | 34 | distutils3_do_compile[vardepsexclude] = "MACHINE" |
35 | 35 | ||
@@ -39,9 +39,9 @@ distutils3_do_install() { | |||
39 | STAGING_INCDIR=${STAGING_INCDIR} \ | 39 | STAGING_INCDIR=${STAGING_INCDIR} \ |
40 | STAGING_LIBDIR=${STAGING_LIBDIR} \ | 40 | STAGING_LIBDIR=${STAGING_LIBDIR} \ |
41 | PYTHONPATH=${D}${PYTHON_SITEPACKAGES_DIR} \ | 41 | PYTHONPATH=${D}${PYTHON_SITEPACKAGES_DIR} \ |
42 | ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py \ | 42 | ${STAGING_BINDIR_NATIVE}/python3-native/python3 setup.py \ |
43 | build --build-base=${B} install --skip-build ${DISTUTILS_INSTALL_ARGS} || \ | 43 | build --build-base=${B} install --skip-build ${DISTUTILS_INSTALL_ARGS} || \ |
44 | bbfatal_log "'${PYTHON_PN} setup.py install ${DISTUTILS_INSTALL_ARGS}' execution failed." | 44 | bbfatal_log "'python3 setup.py install ${DISTUTILS_INSTALL_ARGS}' execution failed." |
45 | 45 | ||
46 | # support filenames with *spaces* | 46 | # support filenames with *spaces* |
47 | find ${D} -name "*.py" -exec grep -q ${D} {} \; \ | 47 | find ${D} -name "*.py" -exec grep -q ${D} {} \; \ |